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This is a quick step-by-step tutorial that can be followed to learn the basics of circuit simulation 
using National Instruments Multisim.  Part 1 covers the entry of a schematic diagram that represents the 
circuit, a process also known as schematic capture.  Part 2 covers setting up the model parameters for a 
semiconductor device.  Part 3 walks through the process of performing a DC transfer curve analysis, and 
Part 4 walks through the process of performing a transient simulation.   

This tutorial was written using Multisim version 11.0, but most of the steps are the same if an 
earlier version is being used.     

Part 1 – Schematic Capture 
First, launch Multisim.  After the splash screen, you should get the Multisim  design environment 

as shown below:   

 

 
 

Multisim opens with a default new design file, named “Design1”, which contains a default blank 
schematic sheet, also called “Design1” that has been opened for editing.  The design file and its open 
schematic sheet can be seen in the navigation pane on the left hand side of the main design window.   



The primary tasks in capturing a schematic include placing the components, setting their 
properties, connecting them into a circuit using wires or buses, and then labeling any nodes, connectors, 
or interfaces needed to exchange signals with other schematics or information with other processors.  This 
tutorial will build up a full-wave bridge rectifier using four diodes.  The first task is to place these 
components into the schematic sheet.   

From the menu bar, select Place > Component …, or use the keyboard shortcut of Ctrl+W, to 
bring up the Select a Component window:   

 

 
 

Another fast way to bring up the Select a Component window with the Group already specified is 
to click on the Component Group from the Component Toolbar.  For example, clicking on the Diode 
button, the third from the left, would bring up the same window as that show above.   

An industry standard 1N4004 rectifier diode will be used to construct the full-wave bridge 
rectifier.  Select the Master Database, the Diodes Group, and the Diode Family, as shown above.  The 
Database, Group, and Family selections allow a device to be picked out quickly from the extremely large 
number of components in the database.  For most purposes, the Master Database should be used.  Most of 
the semiconductor devices such as diodes and transistors have their own groups, while R, L, & C linear 
elements are found in the Basic Group, and independent and controlled sources are found in the Sources 
Group.  To select a particular component, just select it in the long vertical list under Component, or if its 
name is known, just type the first few characters into the textbox underneath the word Component, and 
the list will be automatically filtered to give just those entries starting with the characters that were typed.  
After selecting the component, there may be additional options for selecting a model manufacturer and/or 
a PCB footprint.  For simulation purposes, these selections are not important.   

To place the selected 1N4004 diode, click on OK, the Select a Component window will close, 
and the cursor will have an outline of the new part attached to it within the open schematic page.  Simply 



click to where the component is to be placed on the page, and an instance of that new part will be placed 
there with a component reference designator that automatically indexes forward from the last part of that 
same type.  Since there were no diodes yet placed on the schematic page, this first instance is 
automatically given the reference designator “D1.”  The default global schematic settings for a new 
schematic page have the reference designator and the value displayed for each new component.  For the 
diode just placed, the value is just the part number.  If the default reference designator is not what one had 
in mind, this can be changed after the component has been placed.  The properties window for any placed 
component can be opened by either double clicking on the component, right clicking over the component 
and selecting Properties, or by selecting the part and using the keyboard shortcut of Ctrl+M.  To change 
the reference designator, open the properties window, select the Label tab, change the name in the RefDes 
textbox, and click OK.  If for some reason the reference designator or value are not to be displayed on the 
schematic, open the properties window for that component, select the Display tab, de-select Use 
schematic global setting, and de-select either the Show values or Show RefDes checkboxes, and click the 
OK button.  The DIODE Properties window for D1 is shown below:   

 

 
 

Many times the component will need to be rotated CW or CCW, or flipped horizontally or 
vertically on the schematic page.  The most common operation is a horizontal flip.  This can be performed 
either just before the selected component has been placed on the page, or after it has been placed and then 
again selected.  In both cases the operations are the same.  To flip the component horizontally, use Alt+X; 
to flip the component vertically, use Alt+Y; to rotate the component CW, use Ctrl+R; and to rotate the 
component CCW, use Ctrl+Shift+R.  Right clicking over the component once it has been placed also 
brings up these same options in the context menu.  To continue the schematic capture of the full-wave 
bridge rectifier, add three more 1N4004 diodes to the schematic page, and flip horizontally the last two, 
D3 and D4.  The result should look like that shown below:   
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At this point, save the design file by clicking on the Save button or hitting Ctrl+S to bring up the 
Save dialog.  Rename the file from Design1 to Full Wave Bridge 1 and click on the Save button.  
Multisim version 11 circuit design files have the extension .ms11.   

Once a few components have been placed on the schematic page, it is often necessary to move 
around and zoom-in and zoom-out to gain better views of them.  Nearly all EE CAD tools use the same 
set of mouse and keyboard commands for these operations.  Using the mouse wheel zooms in or out, 
centered about where the cursor is located on the schematic page.  This is usually the quickest way to 
zoom into a particular region.  Holding down Ctrl while rolling the mouse wheel will pan up and down, 
while holding down Ctrl+Shift while rolling the mouse wheel will pan left and right.  In addition to the 
mouse wheel, the function keys F7, F8, F9, F10, and F11 also provide for quick changes in view.  F7 
zooms to put the entire schematic in view, which is useful if one gets lost while deeply zoomed in.  F8 
zooms in, centered about the current cursor position, and F9 zooms out, also centered about the current 
cursor position.  Using F8 and F9 while positioning the cursor with the mouse is usually the fastest and 
most precise method for zooming in or out.  F10 selects the zoom box function, which zooms into a 
rectangular region which is diagonally drawn by the mouse after hitting the F10 key.  F11 zooms in to a 
specified magnification.  100% magnification is the default setting when a new schematic page is opened.  
These same zoom commands can also be found under the View menu item.   

Next, place a resistor and a capacitor on the output side of the diode bridge.  Open the Select a 
Component window with the keyboard shortcut Ctrl-W, or from the menu Place > Component…, or click 
on the Place Basic button in the Component Toolbar.  Select the Resistor Family, and the 1k (Ω) resistor 
value will come up as the default component.  The resistor value can be selected from the list of standard 
1% tolerance values shown in the list, or the value can be set to any number after the resistor has been 
placed.  Click on OK, and then rotate the component 90 degrees CW with the keyboard shortcut Ctrl+R.  
Place the rotated resistor to the right of the four diodes.  After the resistor is placed, the Select a 
Component window will return.  Next select the Capacitor Family, and the 1µ (Farad) capacitor value 
will come up as the default component.  Again, standard 5% tolerance capacitor values can be selected 
from the list, or any numerical value can be assigned after the capacitor has been placed.  Click on OK, 
and again rotate the component 90 degrees CW and place it beside the resistor.  After placing the 
capacitor, the Select a Component window will return.  Click Close to dismiss this window.   

Two additional components are required for any SPICE circuit analysis.  The first is a source 
which is used to excite the circuit.  Open the Select a Component window with the keyboard shortcut 
Ctrl+W, or from the menu Place > Component …, or click on the Place Source button in the Component 
Toolbar.  Select the SIGNAL_VOLTAGE_SOURCE Family, and select the AC_VOLTAGE Component.  
Click on OK and place the signal source to the left of the four diodes.  It will already be in the correct 
vertical orientation.  The second required component is a ground.  All of the voltages computed by SPICE 
are node voltages and the reference point to which they are being defined must be specified.  This is also 



known as Node #0 in many SPICE versions.  After placing the signal source, the Select a Component 
window will have returned.  Now select the POWER_SOURCES Family, and select the GROUND 
Component.  Click on OK and place the ground directly below the signal source.  The Select a 
Component window will reopen; click on Close to dismiss this window.  Double click on the signal 
source to open its properties window, and change its reference designator to VS1, change its voltage to 24 
V (peak), change its frequency to 60 Hz, and then click on OK to apply these changes.  At this point, the 
schematic should look similar to that shown below:   
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The next step is wire the components together, which is particularly simple in Multisim.  When 
the cursor is brought sufficiently close to the unconnected end of any component, it will change from a 
pointer into a small black connection dot and crosshair.  Simply left click on the end of the component to 
start the wire, and move the cursor to where it is to be connected.  This is known as automatic wiring 
mode, in which Multisim will try to automatically find the best route for the wire through the schematic to 
connect the two selected points.  Sometimes this works fine, other times it needs some user assistance.  
To better control the path that a wire is being routed along, the manual wiring mode allows specific 
corners to be placed.  Manual mode is selected by simply clicking on a blank point in the schematic page 
which does not have an unconnected end of a component located there.  Unfortunately, Multisim does not 
have the ability to place wires at an angle, so all wire routing must be done “Manhattan Style” with all 
wire segments running either horizontally or vertically.  Using this technique, wire up the components to 
produce the circuit shown below:   
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Often, the components and wire segments need to be jogged around to pretty up the schematic.  

Moving either of these is accomplished by first selected them, moving them with the mouse or keyboard, 
and then deselecting them.  When components are selected, Multisim places a blue rectangular border 
around them to identify them as selected.  Single components or wires can be selected by just left clicking 
over them; multiple components or wires can be selected by dragging a bounding box over them, or by 
adding or subtracting them from the current selection by holding down Shift and clicking over them.  
Holding down the left mouse button and dragging will move the components; however, fine positioning 
can usually be better accomplished by selecting the component and using the up/down/right/left arrow 
keys to move the component in unit grid increments.  When a component is moved, Multisim will try to 
modify the routing of any wires attached to it, although this sometimes needs some additional help, too.  
Component placement takes priority over wire segment placement, so moving a component will move its 
attached wires, but moving a wire will not move the components that it is attached to.  It usually works 
best to place the components first, and then place or readjust the wire segments afterwards.  Components 
can be moved up, down, right, and left.  Wire segments can only be moved orthogonal to the direction 
that they are running – a horizontal segment can only be moved up and down, and a vertical segment can 
only be moved right and left.  After a wire segment has been selected, placing the cursor over any part of 
its length except for its end points will produce a pair of black arrows which indicate the allowed 
directions of movement.  Wire junctions are where three or more wire segments meet at a point which is 
not the terminal of a component.  Wire junctions can be move just like regular components with the 
keyboard arrows, and can be added to the schematic just like a component would.  The keyboard shortcut 
to place a wire junction is Ctrl+J.   

To delete a wire segment, select just the segment and press the Delete key, the same as if one 
were deleting a component.  To select several segments, use a bounding box to select as many as possible 
at once, then hold down the Shift key to select and deselect any additional segments.  Undo (Ctrl+Z) and 
Redo (Ctrl+Y) are very useful commands when moving parts around on the schematic.  Cut (Ctrl+X), 
Copy (Ctrl+C), and Paste (Ctrl+V) are also extremely useful when constructing a schematic.  When 
making a copy of a component, the new component will retain all of the properties of the original from 
which it was copied, except that the reference designator will be incremented to the next available 
number.  For example, copying the resistor R1 and then pasting down a duplicate will create a new 
resistor with referenced designator R2, but otherwise identical to the original R1.  This technique can save 
time when many instances of the same part are needed.   

SPICE performs node analysis of circuits, and it fundamentally computes the node voltages to 
satisfy KVL, KCL, and the element equations.  All of the other requested variables are then found from 
the node voltages.  Because of the central importance of node voltages to SPICE, it is important to be able 
to correctly identify which node is which within a schematic, and the easiest way to do this is to name 
them.  As components in a schematic page are wired together, Multisim assigns node numbers 
sequentially in the order in which the components are connected, with the Ground node always being 
assigned Node number 0.  Node names, which are also referred to as net names, can be viewed and 
changed within the Properties window for that net.  To bring up the Properties window for a node, select 
the node and use the keyboard shortcut Ctrl+M, or right click over the wire segment and select Properties 
from the context menu.  The Net Settings window will display the current net name for the node, and it 
provides a textbox in which a preferred net name can be entered.  Selecting the checkbox below the 
textbox will display the preferred net name on the schematic.  Another convenient way to see all of the 
net names is to select the Nets tab of the Spreadsheet View pane at the bottom of the screen.  To quickly 
see what the nets or nodes are named, just scroll through the Nets spreadsheet, and clicking on any line 
will highlight that net in the schematic above.  If it is desired to change the name of a net, double click on 
a line, or click again on a selected line, and the Net Settings window will display through which these 
changes can be made.  Once a net name is made visible on the schematic, it can be repositioned by 
selecting it and dragging it, or moving it with the arrow keys, just like a component.  While doing so, 



small fly wires will appear to remind you which wire segments the net name is attached to.  Global nets, 
such as the Ground net 0, cannot be renamed.  Shown below is the Net Settings window for the positive 
output node of the bridge rectifier, for which the default Net name of “2” has been changed to “VoutPlus”  
and made visible on the schematic page.   

 

 
 

Schematic capture is used to document circuit designs, and part of this documentation is simple 
labeling of the schematic itself which is accomplished using a title block.  A title block can be inserted 
into the schematic page from the menu item Place > Title Block …, which brings up a file open dialog.  
Title blocks are stored with the file extension .tb7.  From the Open file dialog, select DefaultV6.tb7, and 
then place the outline of the title block in the lower right hand corner of the schematic page, the 
traditional location for electrical and mechanical drawings.  Multisim automatically enters the Schematic 
page name into the Title field of the title block.  The remaining fields can be filled out by double clicking 
on the title block to bring up the Title Block window.  Enter your name as the designer, and give the 
schematic page a description that will go into the second line of the title block.  The date of the title block 
is automatically updated each time that the design file is saved to reflect the most current changes that 
have been made.   

The screen shot below shows the Multisim design environment after two net names have been 
changed and a title block added:   

 



 
 

Those are the basic elements of schematic capture, the process of entering and documenting a 
circuit design.  Save your work to this point by clicking on the Save toolbar button, or by using the 
keyboard shortcut Ctrl+S.   



Part 2 – Device Modeling 
Numerical circuit simulation using SPICE or similar programs is the de facto standard for 

electrical engineering.  Any circuit of reasonable complexity is going to be too complicated to analyze 
accurately with hand analysis alone.  Hand analysis and even qualitative analysis is highly desired for 
understanding the operation of a circuit, but when the final performance needs to be quantitatively 
evaluated, EEs turn to SPICE circuit analysis to provide those more accurate answers.   

The biggest pitfall of SPICE analysis is lack of attention to proper device modeling.  Everyone 
has heard the expression “garbage in equals garbage out,” and this is never more true than in SPICE 
analysis of circuits.  If the models used for the analysis of the devices do not faithfully represent their 
behavior, then the performance of the circuit computed by SPICE will not be any better than the accuracy 
of these models.  Far too often, lazy students and engineers just blindly accept the defaults for device 
parameters, or unwittingly assume that the models that they have cut and pasted were tested by someone 
else.  In most cases they were not, and so it no surprise that the simulation results do not predict the 
performance of the circuit that was measured in the laboratory.  Proper device modeling takes time and 
effort, but once the actual device has a numerical model that represents it well, the resulting SPICE 
simulations using that model will be surprisingly accurate and trustworthy.  But without that modeling 
effort, the simulation results are just going to be, well, garbage.   

Learning where the device models are located within the simulation tool and how to insert the 
proper device parameters into them is the first essential for successful device modeling.  Multisim has the 
advantage of making these device model parameters very accessible.  As an example, select the top diode 
D1 in the schematic page, and double click on it to open up its Properties window, shown below.   

 

 
 

Select the Value tab which should show the Value as equal to the part number of 1N4004.  Click 
on the Edit model button near the bottom to open the Edit Model window, as shown below:   

 



 
 

The Edit Model window shows the current state of all of the parameters which are used to define 
the 1N4004 part number.  These parameters were automatically entered into the design as a model 
statement called “.MODEL 1N4004__DIODE__1” when the first component of this part number was 
added to the schematic.  Each of the three additional diodes, D2 – D4, have the same part number, so this 
same model is applied to them.  Since all four diodes have the same part number, they share the same 
single model definition for the 1N4004 diode.   

The first two entries in the Edit Model window list are the primary parameters in the Shockley 
diode equation.  IS is the reverse saturation current, and N is the ideality factor, although the description 
in the window incorrectly calls it an emission coefficient.  (SPICE was written by computer programmers 
whose knowledge of device physics has sometimes been lacking.)  The thermal voltage VT = kBT/q is 
automatically computed by SPICE since it is based upon only physical constants and temperature.  
Scrolling down to the bottom of the list, there are a four different temperatures listed.  TNOM is the 
temperature at which all of the parameters above it were measured, and for almost all SPICE programs, 
this is 27°C, or 300.15 K.  T_ABS is the temperature at which the simulation is carried out, i.e. the 
operating temperature of the circuit.  This parameter can be altered by the SPICE analysis specifications, 
and in practice just sets the default value for the operating temperature.  SPICE will recompute the device 
parameters based upon the equations for their temperature dependence when the operating temperature of 
the circuit differs from the temperature at which the parameters were measured.   

To understand how these diode model parameters are used within SPICE, one needs to know 
what model equations are being used.  To see these, close the Edit Model window and return to the diode 
Properties window.  Click the Info button at the bottom to open the Component Reference help window.  
Expand the Diode help section, and click on DC Model to display the equations used, as shown below:   

 



 
 

The list of diode parameters and their default values is found  a few pages down in the help 
section:   

 



 
 

Similarly, for any of the other major electronic devices implemented in Multisim’s SPICE, their 
model equations and default values can be found within the Component Reference help section, and this 
can be pulled up by clicking on the Info button in the component Properties window, or by selecting the 
menu item Help > Component Reference.   

To change a model parameter, open the Edit Model window for that part, and select the parameter 
line to be changed.  Double click on the parameter to be edited, enter the new value, change the units as 
necessary, and press Enter.  An information flag will appear saying that the original model has been 
changed.  Click the Change part model button at the bottom, and a new model definition .MODEL 
1N4004__DIODE__1__1 will be added to the design and used by diode D1.  The other three diodes were 
not affected by this change, and each of them still uses the original .MODEL 1N4004__DIODE__1 
model with the original value of IS.   

To see this more clearly, the SPICE Netlist can be viewed.  The SPICE Netlist is a single file 
which contains all of the electrical information about the circuit design.  It is a fairly compact ASCII text 
file which can be read and used by other SPICE simulators, often with only minor changes, since the 
syntax of a SPICE Netlist is both simple and nearly standardized.  To view the SPICE Netlist for the 
current design file, click the Show/Hide SPICE Netlist Viewer button in the main toolbar, or select the 
menu item View > SPICE Netlist Viewer.  The current SPICE Netlist appears as shown below:   

 



 
 

Notice that diodes D2, D3, and D4 use the original .MODEL 1N4004__DIODE__1 model, while 
the modified diode D1 uses the new .MODEL 1N4004__DIODE__1__1 model.  If the Change all models 
button had been pressed in the Edit Model window, then all four diodes would have been assigned to the 
new model.  To bring all component instances back to their original default model parameters, select one 
of the devices, double click to open up the Properties window, click on Edit model, and click the Reset to 
default button.  Then click on the Change all models button and close the window.  The original state of 
the device models can be verified in the SPICE Netlist Viewer which is automatically updated whenever 
an electrical change is made to the design file.  It is a good habit to frequently check the SPICE Netlist 
Viewer to insure that the circuit is electrically as you think it should be entered, and most importantly to 
insure that the proper models are being used for each component in the schematic pages.   



Part 3 – DC Transfer Curve Analysis 
There are two primary methods to simulate circuits in Multisim.  The first, which will be 

illustrated in this Part 3, is to manually define the type of analysis by entering all of the simulation 
parameters and then display the output in the Grapher window.  This method provides the most control 
over the simulation, but requires a bit more work to set up.  It is also closer to the “original” way of 
running SPICE that is found on other circuit simulators.  The second method, which will be illustrated in 
Part 4, is to add Multisim instruments to the schematic, run the simulation, and observe the outputs that 
appear on these instruments.  While this has a high cuteness factor to it, it does illustrate how the same 
measurements would be performed in the laboratory, particularly in terms of their connections to the 
circuit, and thus makes it easier to relate the simulation results back to the measurements taken on a real 
operating circuit.   

One of the best ways of understanding what a circuit does is to construct a DC transfer curve, 
sometimes known as a voltage transfer characteristic or VTC.  This is simply a plot of the output voltage 
versus the input voltage, and from this plot the function of the circuit usually becomes obvious.  Once a 
circuit has been entered into a schematic page, along with some excitation source, no further components 
are needed to produce the DC transfer curve.  In Multisim, the type of analysis that will be used is termed 
a DC Sweep, whereby one of the excitation sources is specified to be swept over a range of values, and 
certain output node voltages will be collected at each of the excitation points.   

Start by insuring the current Full Wave Bridge 1 circuit looks like that shown below:   
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From the menu bar, select Simulate > Analyses > DC Sweep…, and the DC Sweep Analysis 
window will open.  In the Analysis parameters tab, make sure that Source 1 is set to VS1, the name of the 
voltage source in the schematic.  Set the Start value to −20 V, set the Stop value to +20 V, and set the 
Increment to 0.05 V.  These are shown in first screen shot below.  Note that these values specified in the 
DC Sweep Analysis will override any values given to the source when it was added to the schematic.   

Next, switch to the Output tab.  The variables which can be determined from the DC Sweep 
analysis are listed in the panel on the left.  Scroll down to the bottom, select V(voutminus), and click on 
Add to move it over to the panel on the right.  Do the same operations to move V(voutplus) over to the 
panel on the right.  Notice that the component currents (which start with an I) and the component powers 
(which start with a P) are fairly easy to pick out from the list.  However, the node voltages (which start 
with a V) are more difficult to pick unless you know what the node name is.  This was part of the reason 
for renaming the nodes in the schematic earlier.  The new preferred net names are usually easier to pick 



out in the analysis lists, and they are also easier to identify in the generated output plots.  Next, click on 
the Add expression… button.  The Analysis Expression window will open, and any valid expression can 
be typed in the textbox at the bottom and this will be an output which can also be plotted later on.  To 
create a valid expression, it is usually best to use the variable and function names that appear in the lists 
above the textbox.  The voltage across R1 and C1 is of interest, so in the Variables list, select 
V(voutplus), and click on Copy variable to expression to enter it into the textbox.  For the minus sign, you 
can just type in a minus sign from the keyboard.  Next, select V(voutminus), and click on Copy variable 
to expression.  The textbox should now contain “V(voutplus)-V(voutminus)” and so then click on OK.  
The DC Sweep Analysis window Output tab should then look like the second screen shot below:   

 

 
 

 
 



The simulation and its parameters are now all setup, so just click on Simulate to run the 
simulation.  The simulation will run and the variables that were specified as outputs will be plotted in the 
Grapher View window, as shown below:   

 

 
 

The three output voltages are shown in the legend at the bottom of the graph.  This illustrates 
again the utility of adding preferred names to the nets before simulation, as it is now fairly easy to identify 
the colored traces with their corresponding node voltages.  From this output, it is easy to see that the full 
wave bridge rectifier can be used for creating a number of different output functions.  If the positive 
V(voutplus) node is considered the output relative to the input voltage ground, then it provides forward 
rectification, making the output zero when the input is negative.  If the negative V(voutminus) node is 
considered the output relative to the input voltage ground, then it provides reverse rectification, making 
the output zero when the input is positive.  If the output is taken as the difference between these two, i.e. 
the voltage across the capacitor C1 or the resistor R1, then the circuit provides full-wave rectification, 
which can also be thought of as taking the absolute value of the input voltage.  The non-idealities 
introduced by the diode turn-on voltages are also evident in this DC transfer curve.   

Many times the graph in the Grapher View window will need to be copied into a document for a 
report.  There are a few standard things to do to pretty up the graph before copying and pasting it.  First, 
increase the trace width to 2 to make the lines stand out better.  The easiest way to do this is to open up 
the Graph Properties window by selecting Graph > Properties from the menu bar.  Under the Traces tab, 
the Trace ID can be selected, and the color and trace width can be quickly selected from the dropdown list 
or spin controls.  This is shown in the screen shot below.   



 

 
 

Next, click on the Show Grid and Black Background buttons on the toolbar to add the grid and 
change the background from black to white, which will look 100 percent better in a document.  If specific 
points need to be illustrated, the cursors can be used to pick these out and display the output with better 
numerical accuracy, as shown below.   

 

 



 
The cursors are turned on by clicking on the Show Cursors button of the toolbar.  This will add 

vertical bar cursors to the graph, along with a Cursor window which displays the data for each cursor as it 
crosses each trace.  Select Cursor1, and then from the menu select Cursor > Set X Value.  A window will 
appear in which you can enter the X Value, in this case 5, and click OK to move Cursor 1 to that specific 
location.  This is usually faster and more accurate than trying to slide the cursors around using the mouse.  
Similarly, select Cursor2 and move it to an X Value of 15.  A data label can be added to the cursor 
locations by the Add Data Label at Cursor command which is initiated by clicking on the toolbar icon or 
under the Cursor menu.  Once the data labels have been added, they can be moved around on the graph by 
selecting them and just moving them with the mouse to better position them.  Turn off the cursors by 
clicking on the Show Cursors toolbar button again, and the data labels will remain.  The result is shown in 
the screen shot above.  There are other commands available in the menus to change the titles and axis 
labeling, and to scale the graph to more specific data value ranges.  These are fairly obvious menu items 
or they can be found within the Graph Properties window.   

To copy the Grapher View graph into a document such as Word, simply copy the graph to the 
clipboard using Ctrl+C, which is also available under the Edit menu item.  Once in Word, select Paste 
Special…, and paste the graph into the document as a bitmap or device independent bitmap graphic.  The 
result is shown below:   

 

 
 

That’s all there is to it.   



Part 4 – Transient Analysis 
A transient simulation of the full wave bridge rectifier can be set up in much the same manner as 

was done previously for the DC transfer curve, by starting with Simulate > Analyses > Transient 
Analysis… from the menu bar.  This provides the most control over the simulation, since it gives direct 
access to a few of the simulation parameters such as the time step and accuracy tolerances which are 
sometimes needed to fine tune this type of simulation.  In this Part 4, a different method for setting up the 
simulation will be illustrated which uses the Multisim instrument components.   

The first thing to do is to change the value of capacitor C1 from 1 µF to 100 µF.  This will 
increase the RC time constant to 100 ms, which will give a better looking output with less ripple for a 60 
Hz input from VS1.  Just double click on capacitor C1 to bring up its Properties window, change the 
value of C1 to 100 µF, and click OK.   

The voltage source VS1 has already been set to a 24 V peak sinewave at 60 Hz, so as far as the 
circuit is concerned, the input is already fully specified.  Multisim allows instrument components to be 
added to the schematic page which will display readings much like their real-world counterparts once 
they are connected to the circuit.  The available instrument components in Multisim can be found either in 
the Instruments toolbar on the right hand side of the main window, or in the Simulate > Instruments > … 
selection of the menu bar.  For transient analyses, oscilloscopes are usually the instrument of choice to 
monitor voltages versus time.  Add an oscilloscope to the schematic page by either clicking on the 
Oscilloscope icon in the Instruments toolbar, or selecting Simulate > Instruments > Oscilloscope from the 
menu bar.  Place the oscilloscope component above and to the right of the rest of the circuit to more easily 
make its connections.   

Notice that the oscilloscope has two inputs, A and B.  Both of these need two wires to connect 
them to the circuit to be measured.  Place wires so that the A channel of the oscilloscope is connected to 
the input source voltage VS1 and the B channel is connected to the voltage across the resistor R1, as 
shown below.  After the wires to the oscilloscope have been placed, it is a good idea to color them 
differently, as these same colors will be the colors of the oscilloscope traces, and different colors will 
make them easier to identify.  To color a wire segment, right click over top of the segment, which will 
select it at the same time, and choose Color Segment… from the context menu.  The Colors window will 
open, from which any RGB color can be chosen.  Select an appropriate color and click on OK.  Do this 
for all four of the wires to the oscilloscope, keeping them in pairs for each input channel.  The final circuit 
should look similar to that shown in the screen shot clip below.  Notice one important feature:  The 
Multisim Oscilloscope component allows one to connect what are effectively differential inputs to the two 
channels.  On a real laboratory oscilloscope, the (−) connections on both inputs are grounded, so the 
connections shown in the schematic would not work in the laboratory, since the two (−) inputs on the A 
and B channels would short out diode D4!   

The next step is to just run the simulation by clicking on the Run/Resume Simulation button in 
the simulation toolbar.  This is the button that has the green “play” triangle on it.  The simulation can also 
be controlled by the function keys, too.  F5 starts and resumes the simulation, and F6 pauses the 
simulation.  When the simulation is running, click on the red square Stop button on the simulation 
toolbar.  When the simulation is running, the status bar at the very bottom of the main design environment 
window will show “Simulating…”, along with the amount of elapsed time, and a green indicator will also 
flash back and forth.  The simulation can also be started, paused, and stopped using the rocker switch and 
pause button located in the very top right of the main window.   

To see the oscilloscope output, just double click on the oscilloscope to bring up its virtual front 
panel of display and controls, as shown below.  Since the simulation will keep running continuously until 
stopped, either pause or stop the simulation when the traces get near the right edge of the display.  One of 
the more interesting features of using the Multisim instruments is that you have to use some good 



keyboard timing to get the traces to fill the instrument displays.  As shown below, the traces on the 
oscilloscope match in color to the wire segments that make the connections.  The input voltage source is 
the blue trace, and the capacitively filtered full-wave rectifier output is shown in green.  Multisim is set up 
so that multiple instrument components can each be monitoring the same circuit simultaneously.  This has 
some big advantages when performing mixed-signal analysis (digital and analog at the same time).   
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The easiest way to create graphs for inclusion in documents is to use the Grapher View window.  

Simply open the Grapher View window by selecting View > Grapher from the menu bar.  Anything ever 
displayed on the Oscilloscope will automatically create a graph in the Grapher.  After running several 
simulations, there will generally be a large number of graph tabs available in the Grapher, with the most 
recent one open for display when the Grapher View window is opened.  As before, pasted graphs look 
much better when the grid is added, the background is changed to white, and the width of each trace is 
increased to setting 2, as shown below.   

 

 
 

The Oscilloscope window itself can be used to save the recorded simulation results.  The Reverse 
button on the Oscilloscope changes the background to white, and the Save button below it allows the 
Oscilloscope data to be saved as a .scp data file.  However, for insertion of graphics into documents, the 
Grapher View window generally gives better results with improved control over the resulting graphs.   

When a simulation such as the above is running, the simulation parameters in use are those which 
are specified under the transient analysis.  These can be edited by opening the Transient Analysis window 
by selecting Simulate > Analyses > Transient Analysis… from the menu bar.  The Analysis parameters 
tab is where most of the simulation fine tuning adjustments are made.  Initial conditions can be set, as 
well as the maximum time step, which becomes important for certain types of circuits which exhibit both 
short and long time constants, most commonly the switching circuits used in power electronics.  The 
Transient Analysis window is shown below.  The Start and Stop times do not have any relevance when 
the simulation is performed with the Run button, since this just keeps the simulation running indefinitely 
until it is halted by a Pause or a Stop.  To run a simulation with a specific time duration, it is better to run 
the simulation through the Transient Analysis window by clicking on the Simulate button.  Running the 
simulation through the Transient Analysis window does not invoke the Oscilloscope instrument at all; this 
is effectively an entirely different simulation which is not controlled by the simulation Run, Pause, or 
Stop buttons.  The resulting graph in the Grapher View window is shown below.   

 



 
 

 
 

So that’s it!  The above techniques should provide a good starting point for most of the Multisim 
SPICE circuit simulations that are needed for EE-331.   

 


