Upgrade your WordPress!

FYI – it you are running a version of WordPress prior to 2.8.4 (as I was until last week), consider upgrading to the most recent version. A worm has been infecting WordPress blogs. Version 2.8.4 and the previous version are immune, but the previous versions may experience broken links and, according to WordPress, being removed from Google search results. Removing the malware is supposedly very difficult.

WordPress › Blog » How to Keep WordPress Secure.