XNACS1Lib Namespace

XNACS1Lib Documentation
XNACS1Lib Namespace
Send Feedback
XNACS1Lib: CSS490 Spring 2011
Classes and functions in the library.

Classes

 | Class | Description
Public class | XNACS1Base | This is the base class for your program. To work with the XNACS1Lib, your main class must subclass from this class.
Public class | XNACS1Base..::..World | This this the class for setting, inquiring, and changing information corresponding to the "World", including: Coordinate System, Background color/texture, Clamping/colliding with the boundary, and removing all primitives from the AutoDraw set.
Public class | XNACS1Circle | A circle primitive.
Public class | XNACS1Particle | A particle primitive, inherits from circle but draws using additive blending. Used in particleEmitters as well.
Public class | XNACS1ParticleEmitter | Inherits from XNACS1PrimitiveSet, allows a user to define behavior for a group of particles.
Public class | XNACS1ParticleEmitter..::..ExplodeEmitter | Emits explosions when Explode() is called.
Public class | XNACS1ParticleEmitter..::..FireEmitter | Emits a fire
Public class | XNACS1ParticleEmitter..::..TailEmitter | Emits particles at the center of the emitter at a constant rate, which fade out according to InitialParticleLife. If the emitter is moving around this will look like a tail. Works best if attached to other primitives.
Public class | XNACS1Primitive | This is the base class for the behavior of Primitives (circle, rectangle, and primitive-set).
Public class | XNACS1PrimitiveSet | XNACS1PrimitiveSet supports hiding/unhiding a collection of Primitives (Circle, or Rectangle).
Public class | XNACS1Rectangle | A Rectangle primitive.

Enumerations

 | Enumeration | Description
Public enumeration | BoundCollideStatus | Enum data type for collision results between a Primitive and the world bound Status returned by ClampAtWorldBound() and CollideWorldBound.
Public enumeration | ParticleTravelMode | Defines how particles with ShouldTravel==true will be displaced along their travel direction.
Public enumeration | SpriteSheetAnimationMode | Define SpriteSheet Animation
Computing and Software Systems, University of Washington, Bothell

Send comments on this topic to Kelvin Sung

Copyright (C 2011) all right reserved.


BoundCollideStatus Enumeration

BoundCollideStatus Enumeration
See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Enum data type for collision results between a Primitive and the world bound Status returned by ClampAtWorldBound() and CollideWorldBound.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public enum BoundCollideStatus

Members

Member name | Description
CollideLeft |
CollideRight |
CollideBottom |
CollideTop |
InsideBound |

See Also


ParticleTravelMode Enumeration

ParticleTravelMode Enumeration
See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Defines how particles with ShouldTravel==true will be displaced along their travel direction.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public enum ParticleTravelMode

Members

Member name | Description
Linear |
TransverseSine |
CompressionSine |
VerticalSine |
HorizontalSine |
RandomDisplace |

See Also


SpriteSheetAnimationMode Enumeration

SpriteSheetAnimationMode Enumeration
See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Define SpriteSheet Animation

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public enum SpriteSheetAnimationMode

Members

Member name | Description
AnimateForward |
AnimateBackward |
AnimateSwing |

See Also


XNACS1Base Class

XNACS1Base Class
Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
This is the base class for your program. To work with the XNACS1Lib, your main class must subclass from this class.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public class XNACS1Base : Game

Inheritance Hierarchy

System..::..Object
Game
XNACS1Lib..::..XNACS1Base

See Also

XNACS1Base Members


XNACS1Base Members

[image]

XNACS1Lib Documentation
XNACS1Base Members
XNACS1Base Class Constructors Methods Properties See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Base type exposes the following members.

Constructors

 | Name | Description
Public method | XNACS1Base | This is the constructor of the base class for the library. You can define your own constructor to initialize your instance variables. You are free to _not_ implement a constructor. You will receive a defualt applicaiton window with HDTV aspect ratio.

Methods

 | Name | Description
Protected method | Draw | Do not override this method! This method is used by the XNACS1Lib to setup all the internal and font drawing. Override DrawWorld() if you are going to control the drawing of your primitives. Otherwise, you don't need to worry about drawing. (Overrides GameDraw(GameTime).)
Protected method | DrawWorld | subclass can override this to customize the redrawing of the world. This function is called 40 times a second.
 | EchoToBottomStatus | Echo message to the status area located at the bottom of the drawing window.
 | EchoToTopStatus | Echo message to the status area located at the top of the drawing window.
Protected method | Initialize | Do not override this method! This method is used by the XNACS1Lib to create and initialize the entire system. Override InitializeWorld() and perform all your intialization there! Allows the game to perform any initialization it needs to before starting to run. This is where it can query for any required services and load any non-graphic related content. Calling base.Initialize will enumerate through any components and initialize them as well. (Overrides GameInitialize()()()().)
Protected method | InitializeWorld | Subclass should override this to define the World Cooridnate origin and width, and to allocate and otherwise initialize the application state. This method is called once at the beginning of the application.
 | PlayACue | Play the spcified audio cue for the specified length of seconds.
 | PlayBackgroundAudio | Plays the specific audo file name continuously as the background audio.
 | RandomFloat()()()() | Returns a random number between 0.0 to 1.0
 | RandomFloat(Single) | Returns a random float between 0 and max. This function may return 0, or may return a number that's close to max, but will never return max itself
 | RandomFloat(Single, Single) | Returns a float between min and max. This function may return min, or may return a number that's close to max, but will never return max itself
 | RandomInt()()()() | Returns a random integer between 0 and some VERY LARGE number.
 | RandomInt(Int32) | Returns a random integer between 0 and max.
 | RandomInt(Int32, Int32) | Returns a random integer between min and max.
 | SetAppWindowPixelDimension | Sets the Size of the Appplication Window (in pixel unit).
 | SetBottomEchoColor | Sets the bottom status echo font color.
 | SetKeyboardMapFile | Reassigns the keyboard mapping for the keyboard to gamepad to a new mapping, specified by the ini file passed. Example: SetKeyboardMapFile(".\\CS1setting.ini");
 | SetPhoneOrientation | Meaningful only when run on a Windows Phone device. Enable/Disable changing orientation based on the phone's physical settings. Valid orientations are: Portrait, LandscapeLeft, LandscapeRight
 | SetTopEchoColor | Sets the top status echo font color.
Protected method | Update | Do not override this method! This method is used by the XNACS1Lib to maintain and update the system internal state. Override UpdateWorld() and perform all your application specific update there! (Overrides GameUpdate(GameTime).)
Protected method | UpdateWorld | Subclass should override this method to update the world. This function is called 40 times a second.

Properties

Name | Description
GamePad | For accessing the state of the XBOX 360 GamePad Controller. In the absence of a GamePad controller, the keyboard will be polled according to the default mapping.

See Also

XNACS1Base Class


XNACS1Base Constructor

XNACS1Base Constructor
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
This is the constructor of the base class for the library. You can define your own constructor to initialize your instance variables. You are free to _not_ implement a constructor. You will receive a defualt applicaiton window with HDTV aspect ratio.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public XNACS1Base()

See Also

XNACS1Base Class


XNACS1Base Methods

[image]

XNACS1Lib Documentation
XNACS1Base Methods
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Base type exposes the following members.

Methods

 | Name | Description
Protected method | Draw | Do not override this method! This method is used by the XNACS1Lib to setup all the internal and font drawing. Override DrawWorld() if you are going to control the drawing of your primitives. Otherwise, you don't need to worry about drawing. (Overrides GameDraw(GameTime).)
Protected method | DrawWorld | subclass can override this to customize the redrawing of the world. This function is called 40 times a second.
 | EchoToBottomStatus | Echo message to the status area located at the bottom of the drawing window.
 | EchoToTopStatus | Echo message to the status area located at the top of the drawing window.
Protected method | Initialize | Do not override this method! This method is used by the XNACS1Lib to create and initialize the entire system. Override InitializeWorld() and perform all your intialization there! Allows the game to perform any initialization it needs to before starting to run. This is where it can query for any required services and load any non-graphic related content. Calling base.Initialize will enumerate through any components and initialize them as well. (Overrides GameInitialize()()()().)
Protected method | InitializeWorld | Subclass should override this to define the World Cooridnate origin and width, and to allocate and otherwise initialize the application state. This method is called once at the beginning of the application.
 | PlayACue | Play the spcified audio cue for the specified length of seconds.
 | PlayBackgroundAudio | Plays the specific audo file name continuously as the background audio.
 | RandomFloat()()()() | Returns a random number between 0.0 to 1.0
 | RandomFloat(Single) | Returns a random float between 0 and max. This function may return 0, or may return a number that's close to max, but will never return max itself
 | RandomFloat(Single, Single) | Returns a float between min and max. This function may return min, or may return a number that's close to max, but will never return max itself
 | RandomInt()()()() | Returns a random integer between 0 and some VERY LARGE number.
 | RandomInt(Int32) | Returns a random integer between 0 and max.
 | RandomInt(Int32, Int32) | Returns a random integer between min and max.
 | SetAppWindowPixelDimension | Sets the Size of the Appplication Window (in pixel unit).
 | SetBottomEchoColor | Sets the bottom status echo font color.
 | SetKeyboardMapFile | Reassigns the keyboard mapping for the keyboard to gamepad to a new mapping, specified by the ini file passed. Example: SetKeyboardMapFile(".\\CS1setting.ini");
 | SetPhoneOrientation | Meaningful only when run on a Windows Phone device. Enable/Disable changing orientation based on the phone's physical settings. Valid orientations are: Portrait, LandscapeLeft, LandscapeRight
 | SetTopEchoColor | Sets the top status echo font color.
Protected method | Update | Do not override this method! This method is used by the XNACS1Lib to maintain and update the system internal state. Override UpdateWorld() and perform all your application specific update there! (Overrides GameUpdate(GameTime).)
Protected method | UpdateWorld | Subclass should override this method to update the world. This function is called 40 times a second.

See Also

XNACS1Base Class


Draw Method

XNACS1Base..::..Draw Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Do not override this method! This method is used by the XNACS1Lib to setup all the internal and font drawing. Override DrawWorld() if you are going to control the drawing of your primitives. Otherwise, you don't need to worry about drawing.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void Draw(
    GameTime gameTime
)

Parameters

gameTime
Type: GameTime
Provides a snapshot of timing values.

See Also

XNACS1Base Class


DrawWorld Method

XNACS1Base..::..DrawWorld Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
subclass can override this to customize the redrawing of the world. This function is called 40 times a second.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void DrawWorld()

See Also

XNACS1Base Class


EchoToBottomStatus Method

XNACS1Base..::..EchoToBottomStatus Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Echo message to the status area located at the bottom of the drawing window.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static void EchoToBottomStatus(
    string msg
)

Parameters

msg
Type: System..::..String
Message to be echoed.

See Also

XNACS1Base Class


EchoToTopStatus Method

XNACS1Base..::..EchoToTopStatus Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Echo message to the status area located at the top of the drawing window.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static void EchoToTopStatus(
    string msg
)

Parameters

msg
Type: System..::..String
Message to be echoed.

See Also

XNACS1Base Class


Initialize Method

XNACS1Base..::..Initialize Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Do not override this method! This method is used by the XNACS1Lib to create and initialize the entire system. Override InitializeWorld() and perform all your intialization there! Allows the game to perform any initialization it needs to before starting to run. This is where it can query for any required services and load any non-graphic related content. Calling base.Initialize will enumerate through any components and initialize them as well.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void Initialize()

See Also

XNACS1Base Class


InitializeWorld Method

XNACS1Base..::..InitializeWorld Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Subclass should override this to define the World Cooridnate origin and width, and to allocate and otherwise initialize the application state. This method is called once at the beginning of the application.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void InitializeWorld()

See Also

XNACS1Base Class


PlayACue Method

XNACS1Base..::..PlayACue Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Play the spcified audio cue for the specified length of seconds.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static void PlayACue(
    string cueName
)

Parameters

cueName
Type: System..::..String
Name of the audio cue (wav filename without the .wav extension).

See Also

XNACS1Base Class


PlayBackgroundAudio Method

XNACS1Base..::..PlayBackgroundAudio Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Plays the specific audo file name continuously as the background audio.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static void PlayBackgroundAudio(
    string bgAudio,
    float level
)

Parameters

bgAudio
Type: System..::..String
Name of the file to be used as background music.
level
Type: System..::..Single
The loudness of bg music (1.0 is loudest, 0.0 is silent).

Remarks

Pass in a null string (null) to stop the background audio.

See Also

XNACS1Base Class


RandomFloat Method

[image]

XNACS1Lib Documentation
XNACS1Base..::..RandomFloat Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

Name | Description
RandomFloat()()()() | Returns a random number between 0.0 to 1.0
RandomFloat(Single) | Returns a random float between 0 and max. This function may return 0, or may return a number that's close to max, but will never return max itself
RandomFloat(Single, Single) | Returns a float between min and max. This function may return min, or may return a number that's close to max, but will never return max itself

See Also

XNACS1Base Class
XNACS1Base Members


RandomFloat Method

XNACS1Base..::..RandomFloat Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Returns a random number between 0.0 to 1.0

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static float RandomFloat()

Return Value

A random number between 0.0 to 1.0.

See Also

XNACS1Base Class
RandomFloat Overload


RandomFloat Method (Single)

XNACS1Base..::..RandomFloat Method (Single)
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Returns a random float between 0 and max. This function may return 0, or may return a number that's close to max, but will never return max itself

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static float RandomFloat(
    float max
)

Parameters

max
Type: System..::..Single
Max number to be returned.

Return Value

A random number between 0 and max.

See Also

XNACS1Base Class
RandomFloat Overload


RandomFloat Method (Single, Single)

XNACS1Base..::..RandomFloat Method (Single, Single)
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Returns a float between min and max. This function may return min, or may return a number that's close to max, but will never return max itself

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static float RandomFloat(
    float min,
    float max
)

Parameters

min
Type: System..::..Single
Min number to be returned.
max
Type: System..::..Single
Max number to be returned.

Return Value

A random number between min and max.

See Also

XNACS1Base Class
RandomFloat Overload


RandomInt Method

[image]

XNACS1Lib Documentation
XNACS1Base..::..RandomInt Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

Name | Description
RandomInt()()()() | Returns a random integer between 0 and some VERY LARGE number.
RandomInt(Int32) | Returns a random integer between 0 and max.
RandomInt(Int32, Int32) | Returns a random integer between min and max.

See Also

XNACS1Base Class
XNACS1Base Members


RandomInt Method

XNACS1Base..::..RandomInt Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Returns a random integer between 0 and some VERY LARGE number.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static int RandomInt()

Return Value

A random integer between 0 and some very large number.

See Also

XNACS1Base Class
RandomInt Overload


RandomInt Method (Int32)

XNACS1Base..::..RandomInt Method (Int32)
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Returns a random integer between 0 and max.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static int RandomInt(
    int max
)

Parameters

max
Type: System..::..Int32
Max integer to be returned.

Return Value

Returns a random integer between 0 and max.

See Also

XNACS1Base Class
RandomInt Overload


RandomInt Method (Int32, Int32)

XNACS1Base..::..RandomInt Method (Int32, Int32)
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Returns a random integer between min and max.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static int RandomInt(
    int min,
    int max
)

Parameters

min
Type: System..::..Int32
Min integer to be returned.
max
Type: System..::..Int32
Max integer to be returned.

Return Value

Returns a random integer between min and max.

See Also

XNACS1Base Class
RandomInt Overload


SetAppWindowPixelDimension Method

XNACS1Base..::..SetAppWindowPixelDimension Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Sets the Size of the Appplication Window (in pixel unit).

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static void SetAppWindowPixelDimension(
    bool fullScreen,
    int widthInPixel,
    int heightInPixel
)

Parameters

fullScreen
Type: System..::..Boolean
Run in full screen mode. If ture, the width/height parameters are ignored.
widthInPixel
Type: System..::..Int32
Width of the applicaiton window (in pixel).
heightInPixel
Type: System..::..Int32
Height of the application window (in pixel).

See Also

XNACS1Base Class


SetBottomEchoColor Method

XNACS1Base..::..SetBottomEchoColor Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Sets the bottom status echo font color.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static void SetBottomEchoColor(
    Color bottomEchoColor
)

Parameters

bottomEchoColor
Type: Color
Color of the bottom echo font.

See Also

XNACS1Base Class


SetKeyboardMapFile Method

XNACS1Base..::..SetKeyboardMapFile Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Reassigns the keyboard mapping for the keyboard to gamepad to a new mapping, specified by the ini file passed. Example: SetKeyboardMapFile(".\\CS1setting.ini");

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static void SetKeyboardMapFile(
    string fileName
)

Parameters

fileName
Type: System..::..String

[Missing <param name="fileName"/> documentation for "M:XNACS1Lib.XNACS1Base.SetKeyboardMapFile(System.String)"]

See Also

XNACS1Base Class


SetPhoneOrientation Method

XNACS1Base..::..SetPhoneOrientation Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Meaningful only when run on a Windows Phone device. Enable/Disable changing orientation based on the phone's physical settings. Valid orientations are: Portrait, LandscapeLeft, LandscapeRight

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static void SetPhoneOrientation(
    bool locked,
    DisplayOrientation orientation
)

Parameters

locked
Type: System..::..Boolean
If True, orienation of app will maintained as set.
orientation
Type: DisplayOrientation
The orientation to set to.

See Also

XNACS1Base Class


SetTopEchoColor Method

XNACS1Base..::..SetTopEchoColor Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Sets the top status echo font color.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static void SetTopEchoColor(
    Color topEchoColor
)

Parameters

topEchoColor
Type: Color
Color of the top echo font.

See Also

XNACS1Base Class


Update Method

XNACS1Base..::..Update Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Do not override this method! This method is used by the XNACS1Lib to maintain and update the system internal state. Override UpdateWorld() and perform all your application specific update there!

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void Update(
    GameTime gameTime
)

Parameters

gameTime
Type: GameTime
Provides a snapshot of timing values.

See Also

XNACS1Base Class


UpdateWorld Method

XNACS1Base..::..UpdateWorld Method
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Subclass should override this method to update the world. This function is called 40 times a second.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void UpdateWorld()

See Also

XNACS1Base Class


XNACS1Base Properties

[image]

XNACS1Lib Documentation
XNACS1Base Properties
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Base type exposes the following members.

Properties

Name | Description
GamePad | For accessing the state of the XBOX 360 GamePad Controller. In the absence of a GamePad controller, the keyboard will be polled according to the default mapping.

See Also

XNACS1Base Class


GamePad Property

XNACS1Base..::..GamePad Property
XNACS1Base Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
For accessing the state of the XBOX 360 GamePad Controller. In the absence of a GamePad controller, the keyboard will be polled according to the default mapping.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static GamePadStruct GamePad { get; }

See Also

XNACS1Base Class


XNACS1Base.World Class

XNACS1Base..::..World Class
XNACS1Base Class Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
This this the class for setting, inquiring, and changing information corresponding to the "World", including: Coordinate System, Background color/texture, Clamping/colliding with the boundary, and removing all primitives from the AutoDraw set.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static class World

Inheritance Hierarchy

System..::..Object
XNACS1Lib..::..XNACS1Base..::..World

See Also

XNACS1Base..::..World Members


XNACS1Base.World Members

[image]

XNACS1Lib Documentation
XNACS1Base..::..World Members
XNACS1Base..::..World Class Methods Properties See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

This is the base class for your program. To work with the XNACS1Lib, your main class must subclass from this class.

The XNACS1Base..::..World type exposes the following members.

Methods

Name | Description
ClampAtWorldBound | Ensures that the inputPrimitive is kept within bounds of the world. If inputPrimitive position is outside of the world bound, This function will determine the distances to the closes bound and force the inputPrimitive to be insde that world bound.
CollideWorldBound | Collide the inputPrimitive with the worldBound and return which of the worldBound (left/right/top/bottom or inside) did this primitive intersect with.
OutsideWorldBound | Returns true if the inputPrimitive is outside of the worldBound.
RemoveAllFromDrawSet | Remove all Primitives from the default draw set. After this funciton, you will observe a blank screen.
SetBackgroundColor | Sets the background color.
SetBackgroundTexture | Set the background texture. The texture image will cover the entire background such that the background color will not be visible.
SetWorldCoordinate | Defines the world coordinate system to draw in.

Properties

Name | Description
Paused | Pausing the World Update (ShouldTravel primitive will stop moving).
TicksInASecond | Gets or sets the number of ticks/frames in one second.
WorldDimension | Get the dimension (width/height) of the world.
WorldMax | Get the coordinate position that corresponds to the upper-right corner of the world.
WorldMin | Get the coodinate position that corresponds to the lower-left corner of the world.

See Also

XNACS1Base..::..World Class


XNACS1Base.World Methods

[image]

XNACS1Lib Documentation
XNACS1Base..::..World Methods
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Base..::..World type exposes the following members.

Methods

Name | Description
ClampAtWorldBound | Ensures that the inputPrimitive is kept within bounds of the world. If inputPrimitive position is outside of the world bound, This function will determine the distances to the closes bound and force the inputPrimitive to be insde that world bound.
CollideWorldBound | Collide the inputPrimitive with the worldBound and return which of the worldBound (left/right/top/bottom or inside) did this primitive intersect with.
OutsideWorldBound | Returns true if the inputPrimitive is outside of the worldBound.
RemoveAllFromDrawSet | Remove all Primitives from the default draw set. After this funciton, you will observe a blank screen.
SetBackgroundColor | Sets the background color.
SetBackgroundTexture | Set the background texture. The texture image will cover the entire background such that the background color will not be visible.
SetWorldCoordinate | Defines the world coordinate system to draw in.

See Also

XNACS1Base..::..World Class


ClampAtWorldBound Method

XNACS1Base..::..World..::..ClampAtWorldBound Method
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Ensures that the inputPrimitive is kept within bounds of the world. If inputPrimitive position is outside of the world bound, This function will determine the distances to the closes bound and force the inputPrimitive to be insde that world bound.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static BoundCollideStatus ClampAtWorldBound(
    XNACS1Primitive inputPrimitive
)

Parameters

inputPrimitive
Type: XNACS1Lib..::..XNACS1Primitive
The primtive to be tested

Return Value

Which of the world bound that the inputPrimitive has moved out of.

See Also

XNACS1Base..::..World Class


CollideWorldBound Method

XNACS1Base..::..World..::..CollideWorldBound Method
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Collide the inputPrimitive with the worldBound and return which of the worldBound (left/right/top/bottom or inside) did this primitive intersect with.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static BoundCollideStatus CollideWorldBound(
    XNACS1Primitive inputPrimitive
)

Parameters

inputPrimitive
Type: XNACS1Lib..::..XNACS1Primitive
Primitive to be tested

Return Value

The side upon which the primitive has collided with (or if the primitive is inside the world bound).

See Also

XNACS1Base..::..World Class


OutsideWorldBound Method

XNACS1Base..::..World..::..OutsideWorldBound Method
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Returns true if the inputPrimitive is outside of the worldBound.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static bool OutsideWorldBound(
    XNACS1Primitive inputPrimitive
)

Parameters

inputPrimitive
Type: XNACS1Lib..::..XNACS1Primitive
the primitive to check

Return Value

True if inputPrimitive is outside the world bound, otherwise returns false.

See Also

XNACS1Base..::..World Class


RemoveAllFromDrawSet Method

XNACS1Base..::..World..::..RemoveAllFromDrawSet Method
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Remove all Primitives from the default draw set. After this funciton, you will observe a blank screen.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static void RemoveAllFromDrawSet()

See Also

XNACS1Base..::..World Class


SetBackgroundColor Method

XNACS1Base..::..World..::..SetBackgroundColor Method
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Sets the background color.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static void SetBackgroundColor(
    Color bgColor
)

Parameters

bgColor
Type: Color
The specified color for the entire background.

See Also

XNACS1Base..::..World Class


SetBackgroundTexture Method

XNACS1Base..::..World..::..SetBackgroundTexture Method
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Set the background texture. The texture image will cover the entire background such that the background color will not be visible.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static void SetBackgroundTexture(
    string tex
)

Parameters

tex
Type: System..::..String
name of the background texture image.

See Also

XNACS1Base..::..World Class


SetWorldCoordinate Method

XNACS1Base..::..World..::..SetWorldCoordinate Method
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Defines the world coordinate system to draw in.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static void SetWorldCoordinate(
    Vector2 min,
    float width
)

Parameters

min
Type: Vector2
Coordinate position of the lower left corner of the drawing window.
width
Type: System..::..Single
Width represented by the drawing window.

See Also

XNACS1Base..::..World Class


XNACS1Base.World Properties

[image]

XNACS1Lib Documentation
XNACS1Base..::..World Properties
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Base..::..World type exposes the following members.

Properties

Name | Description
Paused | Pausing the World Update (ShouldTravel primitive will stop moving).
TicksInASecond | Gets or sets the number of ticks/frames in one second.
WorldDimension | Get the dimension (width/height) of the world.
WorldMax | Get the coordinate position that corresponds to the upper-right corner of the world.
WorldMin | Get the coodinate position that corresponds to the lower-left corner of the world.

See Also

XNACS1Base..::..World Class


Paused Property

XNACS1Base..::..World..::..Paused Property
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Pausing the World Update (ShouldTravel primitive will stop moving).

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static bool Paused { get; set; }

See Also

XNACS1Base..::..World Class


TicksInASecond Property

XNACS1Base..::..World..::..TicksInASecond Property
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or sets the number of ticks/frames in one second.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static int TicksInASecond { get; set; }

See Also

XNACS1Base..::..World Class


WorldDimension Property

XNACS1Base..::..World..::..WorldDimension Property
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Get the dimension (width/height) of the world.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static Vector2 WorldDimension { get; }

See Also

XNACS1Base..::..World Class
XNACS1Lib Namespace
XNACS1Base..::..World..::..WorldMin
XNACS1Base..::..World..::..WorldMax


WorldMax Property

XNACS1Base..::..World..::..WorldMax Property
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Get the coordinate position that corresponds to the upper-right corner of the world.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static Vector2 WorldMax { get; }

See Also

XNACS1Base..::..World Class
XNACS1Lib Namespace
XNACS1Base..::..World..::..WorldMin
XNACS1Base..::..World..::..WorldDimension


WorldMin Property

XNACS1Base..::..World..::..WorldMin Property
XNACS1Base..::..World Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Get the coodinate position that corresponds to the lower-left corner of the world.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public static Vector2 WorldMin { get; }

See Also

XNACS1Base..::..World Class
XNACS1Lib Namespace
XNACS1Base..::..World..::..WorldMax
XNACS1Base..::..World..::..WorldDimension


XNACS1Circle Class

XNACS1Circle Class
Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
A circle primitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public class XNACS1Circle : XNACS1Primitive

Inheritance Hierarchy

System..::..Object
XNACS1Lib..::..XNACS1Primitive
XNACS1Lib..::..XNACS1Circle
XNACS1Lib..::..XNACS1Particle

See Also

XNACS1Circle Members


XNACS1Circle Members

[image]

XNACS1Lib Documentation
XNACS1Circle Members
XNACS1Circle Class Constructors Methods Properties See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Circle type exposes the following members.

Constructors

 | Name | Description
Public method | XNACS1Circle()()()() | Constructs a circle, with center located at (0,0), and radius of 1.0.
Public method | XNACS1Circle(Vector2, Single) | Constructs a circle.
Public method | XNACS1Circle(Vector2, Single, String) | Contstructs a circle.

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws the circle. (Overrides XNACS1Primitive..::..DrawPrimitive()()()().)
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Moves the primitive during each update cycle. This function is automacially called for all visible primitives. Default behavior is to move the primitive if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true (Inherited from XNACS1Primitive.)

Properties

 | Name | Description
Public property | Center | Center of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | Radius | Radius of the circle.
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false. (Inherited from XNACS1Primitive.)
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)

See Also

XNACS1Circle Class


XNACS1Circle Constructor

[image]

XNACS1Lib Documentation
XNACS1Circle Constructor
XNACS1Circle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Public method | XNACS1Circle()()()() | Constructs a circle, with center located at (0,0), and radius of 1.0.
Public method | XNACS1Circle(Vector2, Single) | Constructs a circle.
Public method | XNACS1Circle(Vector2, Single, String) | Contstructs a circle.

See Also

XNACS1Circle Class
XNACS1Circle Members


XNACS1Circle Constructor

XNACS1Circle Constructor
XNACS1Circle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Constructs a circle, with center located at (0,0), and radius of 1.0.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public XNACS1Circle()

See Also

XNACS1Circle Class
XNACS1Circle Overload


XNACS1Circle Constructor (, Single)

XNACS1Circle Constructor (, Single)
XNACS1Circle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Constructs a circle.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public XNACS1Circle(
    Vector2 center,
    float radius
)

Parameters

center
Type: Vector2
center of the circle.
radius
Type: System..::..Single
radius of the circle.

See Also

XNACS1Circle Class
XNACS1Circle Overload


XNACS1Circle Constructor (, Single, String)

XNACS1Circle Constructor (, Single, String)
XNACS1Circle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Contstructs a circle.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public XNACS1Circle(
    Vector2 center,
    float radius,
    string tex
)

Parameters

center
Type: Vector2
center of the circle.
radius
Type: System..::..Single
radius of the circle.
tex
Type: System..::..String
texture to be used for the circle.

See Also

XNACS1Circle Class
XNACS1Circle Overload


XNACS1Circle Methods

[image]

XNACS1Lib Documentation
XNACS1Circle Methods
XNACS1Circle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Circle type exposes the following members.

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws the circle. (Overrides XNACS1Primitive..::..DrawPrimitive()()()().)
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Moves the primitive during each update cycle. This function is automacially called for all visible primitives. Default behavior is to move the primitive if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true (Inherited from XNACS1Primitive.)

See Also

XNACS1Circle Class


Collided Method

[image]

XNACS1Lib Documentation
XNACS1Circle..::..Collided Method
XNACS1Circle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)

See Also

XNACS1Circle Class
XNACS1Circle Members


DrawPrimitive Method

XNACS1Circle..::..DrawPrimitive Method
XNACS1Circle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Draws the circle.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void DrawPrimitive()

See Also

XNACS1Circle Class


XNACS1Circle Properties

[image]

XNACS1Lib Documentation
XNACS1Circle Properties
XNACS1Circle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Circle type exposes the following members.

Properties

 | Name | Description
Public property | Center | Center of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | Radius | Radius of the circle.
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false. (Inherited from XNACS1Primitive.)
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)

See Also

XNACS1Circle Class


Radius Property

XNACS1Circle..::..Radius Property
XNACS1Circle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Radius of the circle.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float Radius { get; set; }

See Also

XNACS1Circle Class


XNACS1Particle Class

XNACS1Particle Class
Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
A particle primitive, inherits from circle but draws using additive blending. Used in particleEmitters as well.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public class XNACS1Particle : XNACS1Circle

Inheritance Hierarchy

System..::..Object
XNACS1Lib..::..XNACS1Primitive
XNACS1Lib..::..XNACS1Circle
XNACS1Lib..::..XNACS1Particle
XNACS1Lib..::..XNACS1ParticleEmitter

See Also

XNACS1Particle Members


XNACS1Particle Members

[image]

XNACS1Lib Documentation
XNACS1Particle Members
XNACS1Particle Class Constructors Methods Properties See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Particle type exposes the following members.

Constructors

 | Name | Description
Public method | XNACS1Particle(Vector2, Single, Int32) | Constructs the particle
Public method | XNACS1Particle(Vector2, Single, Int32, String) | Constructs the particle

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws the particle. (Overrides XNACS1Circle..::..DrawPrimitive()()()().)
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Overloaded TravelPrimitive for Particles. Moves the particle during each update cycle. This function is automacially called for all visible particle. Default behavior is to move the particle if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true This method moves the particle in the direction of its velocity and also displaces it according to the ParticleTravelMode chosen. (Overrides XNACS1Primitive..::..TravelPrimitive()()()().)

Properties

 | Name | Description
Public property | Center | Center of the primitive.
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | DisplacementAmplitude | The amplitude of the Particle TravelMode displacement. For example, the amplitude of the Sine Wave.
Public property | DisplacementFrequency | The frequency of the Particle TravelMode displacement. The default is 1, values between 0..1 would stretch a sine wave while values >1 would compress it.
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | Life | Gets or sets the life parameter of a particle.
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | Radius | Radius of the circle. (Inherited from XNACS1Circle.)
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false.
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | TravelMode | Gets or Sets the primitive's TravelMode if ShouldTravel = True. Used in conjunction with DisplacementAmplitude and DisplacementFrequecy.
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)

See Also

XNACS1Particle Class


XNACS1Particle Constructor

[image]

XNACS1Lib Documentation
XNACS1Particle Constructor
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Public method | XNACS1Particle(Vector2, Single, Int32) | Constructs the particle
Public method | XNACS1Particle(Vector2, Single, Int32, String) | Constructs the particle

See Also

XNACS1Particle Class
XNACS1Particle Members


XNACS1Particle Constructor (, Single, Int32)

XNACS1Particle Constructor (, Single, Int32)
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Constructs the particle

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public XNACS1Particle(
    Vector2 center,
    float size,
    int life
)

Parameters

center
Type: Vector2
center of particle
size
Type: System..::..Single
radius of particle
life
Type: System..::..Int32
Life parameter, used by emitters, autodecrements by one each tick if larger than zero.

See Also

XNACS1Particle Class
XNACS1Particle Overload


XNACS1Particle Constructor (, Single, Int32, String)

XNACS1Particle Constructor (, Single, Int32, String)
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Constructs the particle

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public XNACS1Particle(
    Vector2 center,
    float size,
    int life,
    string tex
)

Parameters

center
Type: Vector2
Center of particle.
size
Type: System..::..Single
Radius of particle.
life
Type: System..::..Int32
Life parameter, used by emitters, autodecrements by one each tick if larger than zero.
tex
Type: System..::..String
Texture to be used by particle.

See Also

XNACS1Particle Class
XNACS1Particle Overload


XNACS1Particle Methods

[image]

XNACS1Lib Documentation
XNACS1Particle Methods
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Particle type exposes the following members.

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws the particle. (Overrides XNACS1Circle..::..DrawPrimitive()()()().)
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Overloaded TravelPrimitive for Particles. Moves the particle during each update cycle. This function is automacially called for all visible particle. Default behavior is to move the particle if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true This method moves the particle in the direction of its velocity and also displaces it according to the ParticleTravelMode chosen. (Overrides XNACS1Primitive..::..TravelPrimitive()()()().)

See Also

XNACS1Particle Class


Collided Method

[image]

XNACS1Lib Documentation
XNACS1Particle..::..Collided Method
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)

See Also

XNACS1Particle Class
XNACS1Particle Members


DrawPrimitive Method

XNACS1Particle..::..DrawPrimitive Method
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Draws the particle.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void DrawPrimitive()

See Also

XNACS1Particle Class


TravelPrimitive Method

XNACS1Particle..::..TravelPrimitive Method
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Overloaded TravelPrimitive for Particles. Moves the particle during each update cycle. This function is automacially called for all visible particle. Default behavior is to move the particle if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true This method moves the particle in the direction of its velocity and also displaces it according to the ParticleTravelMode chosen.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public override void TravelPrimitive()

See Also

XNACS1Particle Class


XNACS1Particle Properties

[image]

XNACS1Lib Documentation
XNACS1Particle Properties
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Particle type exposes the following members.

Properties

 | Name | Description
Public property | Center | Center of the primitive.
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | DisplacementAmplitude | The amplitude of the Particle TravelMode displacement. For example, the amplitude of the Sine Wave.
Public property | DisplacementFrequency | The frequency of the Particle TravelMode displacement. The default is 1, values between 0..1 would stretch a sine wave while values >1 would compress it.
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | Life | Gets or sets the life parameter of a particle.
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | Radius | Radius of the circle. (Inherited from XNACS1Circle.)
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false.
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | TravelMode | Gets or Sets the primitive's TravelMode if ShouldTravel = True. Used in conjunction with DisplacementAmplitude and DisplacementFrequecy.
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)

See Also

XNACS1Particle Class


Center Property

XNACS1Particle..::..Center Property
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Center of the primitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Vector2 Center { get; set; }

Remarks

For PrimitiveCircle (center), PrimitiveRectangle (center), PrimitiveSet (undefined).

See Also

XNACS1Particle Class
XNACS1Lib Namespace
XNACS1Lib..::..XNACS1Rectangle
XNACS1Lib..::..XNACS1Circle


DisplacementAmplitude Property

XNACS1Particle..::..DisplacementAmplitude Property
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
The amplitude of the Particle TravelMode displacement. For example, the amplitude of the Sine Wave.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float DisplacementAmplitude { get; set; }

See Also

XNACS1Particle Class


DisplacementFrequency Property

XNACS1Particle..::..DisplacementFrequency Property
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
The frequency of the Particle TravelMode displacement. The default is 1, values between 0..1 would stretch a sine wave while values >1 would compress it.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float DisplacementFrequency { get; set; }

See Also

XNACS1Particle Class


Life Property

XNACS1Particle..::..Life Property
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or sets the life parameter of a particle.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public int Life { get; set; }

See Also

XNACS1Particle Class


ShouldTravel Property

XNACS1Particle..::..ShouldTravel Property
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Defines if the primitive should move by its current velocity. Defaults to false.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool ShouldTravel { get; set; }

Remarks

Must be set to true for a primitive to move.

See Also

XNACS1Particle Class


TravelMode Property

XNACS1Particle..::..TravelMode Property
XNACS1Particle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or Sets the primitive's TravelMode if ShouldTravel = True. Used in conjunction with DisplacementAmplitude and DisplacementFrequecy.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ParticleTravelMode TravelMode { get; set; }

See Also

XNACS1Particle Class


XNACS1ParticleEmitter Class

XNACS1ParticleEmitter Class
Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Inherits from XNACS1PrimitiveSet, allows a user to define behavior for a group of particles.
Inherits from XNACS1PrimitiveSet, allows a user to define behavior for a group of particles.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public abstract class XNACS1ParticleEmitter : XNACS1Particle

Inheritance Hierarchy

System..::..Object
XNACS1Lib..::..XNACS1Primitive
XNACS1Lib..::..XNACS1Circle
XNACS1Lib..::..XNACS1Particle
XNACS1Lib..::..XNACS1ParticleEmitter
XNACS1Lib..::..XNACS1ParticleEmitter..::..ExplodeEmitter
XNACS1Lib..::..XNACS1ParticleEmitter..::..FireEmitter
XNACS1Lib..::..XNACS1ParticleEmitter..::..TailEmitter

See Also

XNACS1ParticleEmitter Members


XNACS1ParticleEmitter Members

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter Members
XNACS1ParticleEmitter Class Constructors Methods Properties See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1ParticleEmitter type exposes the following members.

Constructors

 | Name | Description
Public method | XNACS1ParticleEmitter | Constructs a particle Emitter.

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddEmitterToUpdateSet | Adds the emitter to the emitter update list. This will cause the emitter's UpdateEmitter function to be called once per tick and it to emit particles as defined. Newly created emitters are automatically in the update set.
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws all the particles in the emitter (Overrides XNACS1Particle..::..DrawPrimitive()()()().)
Protected method | Emit | When this method is called a new particle will be added to the emitter set and NewParticle() will be called to change the initial parameters of the particle if needed.
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Protected method | KillParticle(Int32) | Removes a particle from the emitter list.
Protected method | KillParticle(XNACS1Particle) | Removes a particle from the emitter list.
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Protected method | NewParticle | This method is called by the Emit method whenever a particle is created. By default particles are created at the Center location of the emitter with InitialLife, InitialSize, DefaultTexture, and DefaultColor. Newly created particles also have shouldtravel set to false and velocity = 0. By overloading this method you can change these properties to make particles emit in different ways. Particle that has just been created and added to the set.
Public method | RemoveEmitterFromUpdateSet | Removes the emitter from the emitter update list. To be called before removing all references to the emitter so that garbage collection can collect it.
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Overloaded TravelPrimitive for Particles. Moves the particle during each update cycle. This function is automacially called for all visible particle. Default behavior is to move the particle if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true This method moves the particle in the direction of its velocity and also displaces it according to the ParticleTravelMode chosen. (Inherited from XNACS1Particle.)
Protected method | Update | Controls updates for AttachedPrimitive, AutoRemoveDead, and AutoEmit. Overload at your own risk!
Protected method | UpdateParticle | This is where you define the behavior of particles in the emitter. This method will be called once a tick for each particle if the emitter is in the Emitter Update Set. This is an abstract method and must be overloaded.

Properties

 | Name | Description
Public property | AttachedPrimitive | Gets or Sets the primitive that this emitter is attached to. The emitter's center will be automatically updated each tick to match the attached primitive's center.
Public property | AutoEmitEnabled | Gets or Sets whether or not particles should automatically be emitted every EmitFrequency ticks.
Public property | AutoRemoveDeadParticles | Gets or sets whether or not particles with zero life remaining will be automatically deleted from the particle emitter set. Setting a particle's life to negative will ensure it is never deleted via this functionality.
Public property | Center | Center of the primitive. (Inherited from XNACS1Particle.)
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | DefaultColor | Gets or Sets The default color of emitted particles.
Public property | DefaultTexture | Gets or Sets The default texture of emitted particles.
Public property | DisplacementAmplitude | The amplitude of the Particle TravelMode displacement. For example, the amplitude of the Sine Wave. (Inherited from XNACS1Particle.)
Public property | DisplacementFrequency | The frequency of the Particle TravelMode displacement. The default is 1, values between 0..1 would stretch a sine wave while values >1 would compress it. (Inherited from XNACS1Particle.)
Public property | EmitFrequency | Gets or Sets how many ticks between calls of EmitParticle if AutoEmitEnable = True.
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | InitialLife | Gets or Sets the default life in ticks for emitted particles.
Public property | InitialSize | Gets or Sets The default size of emitted particles.
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | Life | Gets or sets the life parameter of a particle. (Inherited from XNACS1Particle.)
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | ParticlesPerEmit | Gets or Sets the number of particles to be emitted per emit cycle if AutoEmitEnabled = true.
Public property | Radius | Radius of the circle. (Inherited from XNACS1Circle.)
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false. (Inherited from XNACS1Particle.)
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | TravelMode | Gets or Sets the primitive's TravelMode if ShouldTravel = True. Used in conjunction with DisplacementAmplitude and DisplacementFrequecy. (Inherited from XNACS1Particle.)
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)

See Also

XNACS1ParticleEmitter Class


XNACS1ParticleEmitter Constructor

XNACS1ParticleEmitter Constructor
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Constructs a particle Emitter.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public XNACS1ParticleEmitter(
    Vector2 center,
    int initialParticleLife,
    float particleSize,
    string defaultTex,
    Color defaultTint
)

Parameters

center
Type: Vector2
The center of the particle Emitter
initialParticleLife
Type: System..::..Int32
The life in ticks of newly emitted particles.
particleSize
Type: System..::..Single
The radius of newly emitted particles.
defaultTex
Type: System..::..String
The default texture of newly emitted particles.
defaultTint
Type: Color
The default tint of newly emitted particles.

See Also

XNACS1ParticleEmitter Class


XNACS1ParticleEmitter Methods

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter Methods
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1ParticleEmitter type exposes the following members.

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddEmitterToUpdateSet | Adds the emitter to the emitter update list. This will cause the emitter's UpdateEmitter function to be called once per tick and it to emit particles as defined. Newly created emitters are automatically in the update set.
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws all the particles in the emitter (Overrides XNACS1Particle..::..DrawPrimitive()()()().)
Protected method | Emit | When this method is called a new particle will be added to the emitter set and NewParticle() will be called to change the initial parameters of the particle if needed.
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Protected method | KillParticle(Int32) | Removes a particle from the emitter list.
Protected method | KillParticle(XNACS1Particle) | Removes a particle from the emitter list.
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Protected method | NewParticle | This method is called by the Emit method whenever a particle is created. By default particles are created at the Center location of the emitter with InitialLife, InitialSize, DefaultTexture, and DefaultColor. Newly created particles also have shouldtravel set to false and velocity = 0. By overloading this method you can change these properties to make particles emit in different ways. Particle that has just been created and added to the set.
Public method | RemoveEmitterFromUpdateSet | Removes the emitter from the emitter update list. To be called before removing all references to the emitter so that garbage collection can collect it.
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Overloaded TravelPrimitive for Particles. Moves the particle during each update cycle. This function is automacially called for all visible particle. Default behavior is to move the particle if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true This method moves the particle in the direction of its velocity and also displaces it according to the ParticleTravelMode chosen. (Inherited from XNACS1Particle.)
Protected method | Update | Controls updates for AttachedPrimitive, AutoRemoveDead, and AutoEmit. Overload at your own risk!
Protected method | UpdateParticle | This is where you define the behavior of particles in the emitter. This method will be called once a tick for each particle if the emitter is in the Emitter Update Set. This is an abstract method and must be overloaded.

See Also

XNACS1ParticleEmitter Class


AddEmitterToUpdateSet Method

XNACS1ParticleEmitter..::..AddEmitterToUpdateSet Method
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Adds the emitter to the emitter update list. This will cause the emitter's UpdateEmitter function to be called once per tick and it to emit particles as defined. Newly created emitters are automatically in the update set.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public void AddEmitterToUpdateSet()

See Also

XNACS1ParticleEmitter Class


Collided Method

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter..::..Collided Method
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)

See Also

XNACS1ParticleEmitter Class
XNACS1ParticleEmitter Members


DrawPrimitive Method

XNACS1ParticleEmitter..::..DrawPrimitive Method
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Draws all the particles in the emitter

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void DrawPrimitive()

See Also

XNACS1ParticleEmitter Class


Emit Method

XNACS1ParticleEmitter..::..Emit Method
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
When this method is called a new particle will be added to the emitter set and NewParticle() will be called to change the initial parameters of the particle if needed.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected void Emit()

See Also

XNACS1ParticleEmitter Class


KillParticle Method

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter..::..KillParticle Method
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Protected method | KillParticle(Int32) | Removes a particle from the emitter list.
Protected method | KillParticle(XNACS1Particle) | Removes a particle from the emitter list.

See Also

XNACS1ParticleEmitter Class
XNACS1ParticleEmitter Members


KillParticle Method (Int32)

XNACS1ParticleEmitter..::..KillParticle Method (Int32)
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Removes a particle from the emitter list.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected void KillParticle(
    int i
)

Parameters

i
Type: System..::..Int32
Index of particle

See Also

XNACS1ParticleEmitter Class
KillParticle Overload


KillParticle Method (XNACS1Particle)

XNACS1ParticleEmitter..::..KillParticle Method (XNACS1Particle)
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Removes a particle from the emitter list.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected void KillParticle(
    XNACS1Particle particle
)

Parameters

particle
Type: XNACS1Lib..::..XNACS1Particle
Particle to remove.

See Also

XNACS1ParticleEmitter Class
KillParticle Overload


NewParticle Method

XNACS1ParticleEmitter..::..NewParticle Method
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
This method is called by the Emit method whenever a particle is created. By default particles are created at the Center location of the emitter with InitialLife, InitialSize, DefaultTexture, and DefaultColor. Newly created particles also have shouldtravel set to false and velocity = 0. By overloading this method you can change these properties to make particles emit in different ways. Particle that has just been created and added to the set.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void NewParticle(
    XNACS1Particle newParticle
)

Parameters

newParticle
Type: XNACS1Lib..::..XNACS1Particle

[Missing <param name="newParticle"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.NewParticle(XNACS1Lib.XNACS1Particle)"]

See Also

XNACS1ParticleEmitter Class
XNACS1Lib Namespace
XNACS1ParticleEmitter..::..AutoEmitEnabled
XNACS1ParticleEmitter..::..InitialLife
XNACS1ParticleEmitter..::..InitialSize
XNACS1ParticleEmitter..::..DefaultTexture
XNACS1ParticleEmitter..::..DefaultColor
XNACS1ParticleEmitter..::..EmitFrequency
XNACS1ParticleEmitter..::..Emit()()()()
XNACS1ParticleEmitter..::..UpdateParticle(XNACS1Particle)


RemoveEmitterFromUpdateSet Method

XNACS1ParticleEmitter..::..RemoveEmitterFromUpdateSet Method
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Removes the emitter from the emitter update list. To be called before removing all references to the emitter so that garbage collection can collect it.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public void RemoveEmitterFromUpdateSet()

See Also

XNACS1ParticleEmitter Class


Update Method

XNACS1ParticleEmitter..::..Update Method
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Controls updates for AttachedPrimitive, AutoRemoveDead, and AutoEmit. Overload at your own risk!

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected virtual void Update()

See Also

XNACS1ParticleEmitter Class


UpdateParticle Method

XNACS1ParticleEmitter..::..UpdateParticle Method
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
This is where you define the behavior of particles in the emitter. This method will be called once a tick for each particle if the emitter is in the Emitter Update Set. This is an abstract method and must be overloaded.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected abstract void UpdateParticle(
    XNACS1Particle particle
)

Parameters

particle
Type: XNACS1Lib..::..XNACS1Particle
The particle being updated

See Also

XNACS1ParticleEmitter Class
XNACS1Lib Namespace
XNACS1ParticleEmitter..::..AddEmitterToUpdateSet()()()()
XNACS1ParticleEmitter..::..RemoveEmitterFromUpdateSet()()()()


XNACS1ParticleEmitter Properties

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter Properties
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1ParticleEmitter type exposes the following members.

Properties

 | Name | Description
Public property | AttachedPrimitive | Gets or Sets the primitive that this emitter is attached to. The emitter's center will be automatically updated each tick to match the attached primitive's center.
Public property | AutoEmitEnabled | Gets or Sets whether or not particles should automatically be emitted every EmitFrequency ticks.
Public property | AutoRemoveDeadParticles | Gets or sets whether or not particles with zero life remaining will be automatically deleted from the particle emitter set. Setting a particle's life to negative will ensure it is never deleted via this functionality.
Public property | Center | Center of the primitive. (Inherited from XNACS1Particle.)
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | DefaultColor | Gets or Sets The default color of emitted particles.
Public property | DefaultTexture | Gets or Sets The default texture of emitted particles.
Public property | DisplacementAmplitude | The amplitude of the Particle TravelMode displacement. For example, the amplitude of the Sine Wave. (Inherited from XNACS1Particle.)
Public property | DisplacementFrequency | The frequency of the Particle TravelMode displacement. The default is 1, values between 0..1 would stretch a sine wave while values >1 would compress it. (Inherited from XNACS1Particle.)
Public property | EmitFrequency | Gets or Sets how many ticks between calls of EmitParticle if AutoEmitEnable = True.
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | InitialLife | Gets or Sets the default life in ticks for emitted particles.
Public property | InitialSize | Gets or Sets The default size of emitted particles.
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | Life | Gets or sets the life parameter of a particle. (Inherited from XNACS1Particle.)
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | ParticlesPerEmit | Gets or Sets the number of particles to be emitted per emit cycle if AutoEmitEnabled = true.
Public property | Radius | Radius of the circle. (Inherited from XNACS1Circle.)
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false. (Inherited from XNACS1Particle.)
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | TravelMode | Gets or Sets the primitive's TravelMode if ShouldTravel = True. Used in conjunction with DisplacementAmplitude and DisplacementFrequecy. (Inherited from XNACS1Particle.)
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)

See Also

XNACS1ParticleEmitter Class


AttachedPrimitive Property

XNACS1ParticleEmitter..::..AttachedPrimitive Property
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or Sets the primitive that this emitter is attached to. The emitter's center will be automatically updated each tick to match the attached primitive's center.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public XNACS1Primitive AttachedPrimitive { get; set; }

See Also

XNACS1ParticleEmitter Class


AutoEmitEnabled Property

XNACS1ParticleEmitter..::..AutoEmitEnabled Property
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or Sets whether or not particles should automatically be emitted every EmitFrequency ticks.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool AutoEmitEnabled { get; set; }

See Also

XNACS1ParticleEmitter Class
XNACS1ParticleEmitter..::..EmitFrequency


AutoRemoveDeadParticles Property

XNACS1ParticleEmitter..::..AutoRemoveDeadParticles Property
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or sets whether or not particles with zero life remaining will be automatically deleted from the particle emitter set. Setting a particle's life to negative will ensure it is never deleted via this functionality.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool AutoRemoveDeadParticles { get; set; }

See Also

XNACS1ParticleEmitter Class


DefaultColor Property

XNACS1ParticleEmitter..::..DefaultColor Property
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or Sets The default color of emitted particles.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Color DefaultColor { get; set; }

See Also

XNACS1ParticleEmitter Class


DefaultTexture Property

XNACS1ParticleEmitter..::..DefaultTexture Property
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or Sets The default texture of emitted particles.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public string DefaultTexture { get; set; }

See Also

XNACS1ParticleEmitter Class


EmitFrequency Property

XNACS1ParticleEmitter..::..EmitFrequency Property
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or Sets how many ticks between calls of EmitParticle if AutoEmitEnable = True.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public int EmitFrequency { get; set; }

See Also

XNACS1ParticleEmitter Class
XNACS1ParticleEmitter..::..AutoEmitEnabled


InitialLife Property

XNACS1ParticleEmitter..::..InitialLife Property
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or Sets the default life in ticks for emitted particles.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public int InitialLife { get; set; }

See Also

XNACS1ParticleEmitter Class


InitialSize Property

XNACS1ParticleEmitter..::..InitialSize Property
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or Sets The default size of emitted particles.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float InitialSize { get; set; }

See Also

XNACS1ParticleEmitter Class


ParticlesPerEmit Property

XNACS1ParticleEmitter..::..ParticlesPerEmit Property
XNACS1ParticleEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or Sets the number of particles to be emitted per emit cycle if AutoEmitEnabled = true.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public int ParticlesPerEmit { get; set; }

See Also

XNACS1ParticleEmitter Class


XNACS1ParticleEmitter.ExplodeEmitter Class

XNACS1ParticleEmitter..::..ExplodeEmitter Class
XNACS1ParticleEmitter Class Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Emits explosions when Explode() is called.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public class ExplodeEmitter : XNACS1ParticleEmitter

Inheritance Hierarchy

System..::..Object
XNACS1Lib..::..XNACS1Primitive
XNACS1Lib..::..XNACS1Circle
XNACS1Lib..::..XNACS1Particle
XNACS1Lib..::..XNACS1ParticleEmitter
XNACS1Lib..::..XNACS1ParticleEmitter..::..ExplodeEmitter

See Also

XNACS1ParticleEmitter..::..ExplodeEmitter Members


XNACS1ParticleEmitter.ExplodeEmitter Members

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter..::..ExplodeEmitter Members
XNACS1ParticleEmitter..::..ExplodeEmitter Class Constructors Methods Properties See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Inherits from XNACS1PrimitiveSet, allows a user to define behavior for a group of particles.
Inherits from XNACS1PrimitiveSet, allows a user to define behavior for a group of particles.

The XNACS1ParticleEmitter..::..ExplodeEmitter type exposes the following members.

Constructors

 | Name | Description
Public method | XNACS1ParticleEmitter..::..ExplodeEmitter | Constructor for explode emitter. Explode emitters do nothing until the Explode() method is called.

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddEmitterToUpdateSet | Adds the emitter to the emitter update list. This will cause the emitter's UpdateEmitter function to be called once per tick and it to emit particles as defined. Newly created emitters are automatically in the update set. (Inherited from XNACS1ParticleEmitter.)
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws all the particles in the emitter (Inherited from XNACS1ParticleEmitter.)
Protected method | Emit | When this method is called a new particle will be added to the emitter set and NewParticle() will be called to change the initial parameters of the particle if needed. (Inherited from XNACS1ParticleEmitter.)
Public method | Explode | Creates particles which explode outward from the center of the emitter at varying velocities.
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Protected method | KillParticle(Int32) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Protected method | KillParticle(XNACS1Particle) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Protected method | NewParticle | Overloaded NewParticle Method, gives explosion particles initial velocity and sets ShouldTravel = true. (Overrides XNACS1ParticleEmitter..::..NewParticle(XNACS1Particle).)
Public method | RemoveEmitterFromUpdateSet | Removes the emitter from the emitter update list. To be called before removing all references to the emitter so that garbage collection can collect it. (Inherited from XNACS1ParticleEmitter.)
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Overloaded TravelPrimitive for Particles. Moves the particle during each update cycle. This function is automacially called for all visible particle. Default behavior is to move the particle if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true This method moves the particle in the direction of its velocity and also displaces it according to the ParticleTravelMode chosen. (Inherited from XNACS1Particle.)
Protected method | Update | Controls updates for AttachedPrimitive, AutoRemoveDead, and AutoEmit. Overload at your own risk! (Inherited from XNACS1ParticleEmitter.)
Protected method | UpdateParticle | Overloaded UpdateParticle method, makes particles fade out according to what percentage of the default life they have remaining. (Overrides XNACS1ParticleEmitter..::..UpdateParticle(XNACS1Particle).)

Properties

 | Name | Description
Public property | AttachedPrimitive | Gets or Sets the primitive that this emitter is attached to. The emitter's center will be automatically updated each tick to match the attached primitive's center. (Inherited from XNACS1ParticleEmitter.)
Public property | AutoEmitEnabled | Gets or Sets whether or not particles should automatically be emitted every EmitFrequency ticks. (Inherited from XNACS1ParticleEmitter.)
Public property | AutoRemoveDeadParticles | Gets or sets whether or not particles with zero life remaining will be automatically deleted from the particle emitter set. Setting a particle's life to negative will ensure it is never deleted via this functionality. (Inherited from XNACS1ParticleEmitter.)
Public property | Center | Center of the primitive. (Inherited from XNACS1Particle.)
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | DefaultColor | Gets or Sets The default color of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | DefaultTexture | Gets or Sets The default texture of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | DisplacementAmplitude | The amplitude of the Particle TravelMode displacement. For example, the amplitude of the Sine Wave. (Inherited from XNACS1Particle.)
Public property | DisplacementFrequency | The frequency of the Particle TravelMode displacement. The default is 1, values between 0..1 would stretch a sine wave while values >1 would compress it. (Inherited from XNACS1Particle.)
Public property | EmitFrequency | Gets or Sets how many ticks between calls of EmitParticle if AutoEmitEnable = True. (Inherited from XNACS1ParticleEmitter.)
Public property | ExplodeSpeed | Get or set the speed at which particles explode outward. Default is radius / life;
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | InitialLife | Gets or Sets the default life in ticks for emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | InitialSize | Gets or Sets The default size of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | Life | Gets or sets the life parameter of a particle. (Inherited from XNACS1Particle.)
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | ParticlesPerEmit | Gets or Sets the number of particles to be emitted per emit cycle if AutoEmitEnabled = true. (Inherited from XNACS1ParticleEmitter.)
Public property | Radius | Radius of the circle. (Inherited from XNACS1Circle.)
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false. (Inherited from XNACS1Particle.)
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | TravelMode | Gets or Sets the primitive's TravelMode if ShouldTravel = True. Used in conjunction with DisplacementAmplitude and DisplacementFrequecy. (Inherited from XNACS1Particle.)
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)

See Also

XNACS1ParticleEmitter..::..ExplodeEmitter Class


XNACS1ParticleEmitter.ExplodeEmitter Constructor

XNACS1ParticleEmitter..::..ExplodeEmitter Constructor
XNACS1ParticleEmitter..::..ExplodeEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Constructor for explode emitter. Explode emitters do nothing until the Explode() method is called.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ExplodeEmitter(
    Vector2 center,
    int initialParticleLife,
    float particleSize,
    string tex,
    Color defaultColor,
    float radius
)

Parameters

center
Type: Vector2

[Missing <param name="center"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.ExplodeEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color,System.Single)"]

initialParticleLife
Type: System..::..Int32

[Missing <param name="initialParticleLife"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.ExplodeEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color,System.Single)"]

particleSize
Type: System..::..Single

[Missing <param name="particleSize"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.ExplodeEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color,System.Single)"]

tex
Type: System..::..String

[Missing <param name="tex"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.ExplodeEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color,System.Single)"]

defaultColor
Type: Color

[Missing <param name="defaultColor"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.ExplodeEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color,System.Single)"]

radius
Type: System..::..Single
Approximate Radius of explosion

See Also

XNACS1ParticleEmitter..::..ExplodeEmitter Class


XNACS1ParticleEmitter.ExplodeEmitter Methods

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter..::..ExplodeEmitter Methods
XNACS1ParticleEmitter..::..ExplodeEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1ParticleEmitter..::..ExplodeEmitter type exposes the following members.

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddEmitterToUpdateSet | Adds the emitter to the emitter update list. This will cause the emitter's UpdateEmitter function to be called once per tick and it to emit particles as defined. Newly created emitters are automatically in the update set. (Inherited from XNACS1ParticleEmitter.)
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws all the particles in the emitter (Inherited from XNACS1ParticleEmitter.)
Protected method | Emit | When this method is called a new particle will be added to the emitter set and NewParticle() will be called to change the initial parameters of the particle if needed. (Inherited from XNACS1ParticleEmitter.)
Public method | Explode | Creates particles which explode outward from the center of the emitter at varying velocities.
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Protected method | KillParticle(Int32) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Protected method | KillParticle(XNACS1Particle) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Protected method | NewParticle | Overloaded NewParticle Method, gives explosion particles initial velocity and sets ShouldTravel = true. (Overrides XNACS1ParticleEmitter..::..NewParticle(XNACS1Particle).)
Public method | RemoveEmitterFromUpdateSet | Removes the emitter from the emitter update list. To be called before removing all references to the emitter so that garbage collection can collect it. (Inherited from XNACS1ParticleEmitter.)
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Overloaded TravelPrimitive for Particles. Moves the particle during each update cycle. This function is automacially called for all visible particle. Default behavior is to move the particle if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true This method moves the particle in the direction of its velocity and also displaces it according to the ParticleTravelMode chosen. (Inherited from XNACS1Particle.)
Protected method | Update | Controls updates for AttachedPrimitive, AutoRemoveDead, and AutoEmit. Overload at your own risk! (Inherited from XNACS1ParticleEmitter.)
Protected method | UpdateParticle | Overloaded UpdateParticle method, makes particles fade out according to what percentage of the default life they have remaining. (Overrides XNACS1ParticleEmitter..::..UpdateParticle(XNACS1Particle).)

See Also

XNACS1ParticleEmitter..::..ExplodeEmitter Class


Collided Method

[image]

XNACS1Lib Documentation
ExplodeEmitter..::..Collided Method
XNACS1ParticleEmitter..::..ExplodeEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)

See Also

XNACS1ParticleEmitter..::..ExplodeEmitter Class
XNACS1ParticleEmitter..::..ExplodeEmitter Members


Explode Method

XNACS1ParticleEmitter..::..ExplodeEmitter..::..Explode Method
XNACS1ParticleEmitter..::..ExplodeEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Creates particles which explode outward from the center of the emitter at varying velocities.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public void Explode(
    int NumParticles
)

Parameters

NumParticles
Type: System..::..Int32
Number of particles to create.

See Also

XNACS1ParticleEmitter..::..ExplodeEmitter Class


KillParticle Method

[image]

XNACS1Lib Documentation
ExplodeEmitter..::..KillParticle Method
XNACS1ParticleEmitter..::..ExplodeEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Protected method | KillParticle(Int32) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Protected method | KillParticle(XNACS1Particle) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)

See Also

XNACS1ParticleEmitter..::..ExplodeEmitter Class
XNACS1ParticleEmitter..::..ExplodeEmitter Members


NewParticle Method

XNACS1ParticleEmitter..::..ExplodeEmitter..::..NewParticle Method
XNACS1ParticleEmitter..::..ExplodeEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Overloaded NewParticle Method, gives explosion particles initial velocity and sets ShouldTravel = true.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void NewParticle(
    XNACS1Particle newParticle
)

Parameters

newParticle
Type: XNACS1Lib..::..XNACS1Particle

[Missing <param name="newParticle"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.ExplodeEmitter.NewParticle(XNACS1Lib.XNACS1Particle)"]

See Also

XNACS1ParticleEmitter..::..ExplodeEmitter Class


UpdateParticle Method

XNACS1ParticleEmitter..::..ExplodeEmitter..::..UpdateParticle Method
XNACS1ParticleEmitter..::..ExplodeEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Overloaded UpdateParticle method, makes particles fade out according to what percentage of the default life they have remaining.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void UpdateParticle(
    XNACS1Particle particle
)

Parameters

particle
Type: XNACS1Lib..::..XNACS1Particle

[Missing <param name="particle"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.ExplodeEmitter.UpdateParticle(XNACS1Lib.XNACS1Particle)"]

See Also

XNACS1ParticleEmitter..::..ExplodeEmitter Class


XNACS1ParticleEmitter.ExplodeEmitter Properties

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter..::..ExplodeEmitter Properties
XNACS1ParticleEmitter..::..ExplodeEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1ParticleEmitter..::..ExplodeEmitter type exposes the following members.

Properties

 | Name | Description
Public property | AttachedPrimitive | Gets or Sets the primitive that this emitter is attached to. The emitter's center will be automatically updated each tick to match the attached primitive's center. (Inherited from XNACS1ParticleEmitter.)
Public property | AutoEmitEnabled | Gets or Sets whether or not particles should automatically be emitted every EmitFrequency ticks. (Inherited from XNACS1ParticleEmitter.)
Public property | AutoRemoveDeadParticles | Gets or sets whether or not particles with zero life remaining will be automatically deleted from the particle emitter set. Setting a particle's life to negative will ensure it is never deleted via this functionality. (Inherited from XNACS1ParticleEmitter.)
Public property | Center | Center of the primitive. (Inherited from XNACS1Particle.)
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | DefaultColor | Gets or Sets The default color of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | DefaultTexture | Gets or Sets The default texture of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | DisplacementAmplitude | The amplitude of the Particle TravelMode displacement. For example, the amplitude of the Sine Wave. (Inherited from XNACS1Particle.)
Public property | DisplacementFrequency | The frequency of the Particle TravelMode displacement. The default is 1, values between 0..1 would stretch a sine wave while values >1 would compress it. (Inherited from XNACS1Particle.)
Public property | EmitFrequency | Gets or Sets how many ticks between calls of EmitParticle if AutoEmitEnable = True. (Inherited from XNACS1ParticleEmitter.)
Public property | ExplodeSpeed | Get or set the speed at which particles explode outward. Default is radius / life;
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | InitialLife | Gets or Sets the default life in ticks for emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | InitialSize | Gets or Sets The default size of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | Life | Gets or sets the life parameter of a particle. (Inherited from XNACS1Particle.)
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | ParticlesPerEmit | Gets or Sets the number of particles to be emitted per emit cycle if AutoEmitEnabled = true. (Inherited from XNACS1ParticleEmitter.)
Public property | Radius | Radius of the circle. (Inherited from XNACS1Circle.)
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false. (Inherited from XNACS1Particle.)
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | TravelMode | Gets or Sets the primitive's TravelMode if ShouldTravel = True. Used in conjunction with DisplacementAmplitude and DisplacementFrequecy. (Inherited from XNACS1Particle.)
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)

See Also

XNACS1ParticleEmitter..::..ExplodeEmitter Class


ExplodeSpeed Property

XNACS1ParticleEmitter..::..ExplodeEmitter..::..ExplodeSpeed Property
XNACS1ParticleEmitter..::..ExplodeEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Get or set the speed at which particles explode outward. Default is radius / life;

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float ExplodeSpeed { get; set; }

See Also

XNACS1ParticleEmitter..::..ExplodeEmitter Class


XNACS1ParticleEmitter.FireEmitter Class

XNACS1ParticleEmitter..::..FireEmitter Class
XNACS1ParticleEmitter Class Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Emits a fire

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public class FireEmitter : XNACS1ParticleEmitter

Inheritance Hierarchy

System..::..Object
XNACS1Lib..::..XNACS1Primitive
XNACS1Lib..::..XNACS1Circle
XNACS1Lib..::..XNACS1Particle
XNACS1Lib..::..XNACS1ParticleEmitter
XNACS1Lib..::..XNACS1ParticleEmitter..::..FireEmitter

See Also

XNACS1ParticleEmitter..::..FireEmitter Members


XNACS1ParticleEmitter.FireEmitter Members

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter..::..FireEmitter Members
XNACS1ParticleEmitter..::..FireEmitter Class Constructors Methods Properties See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Inherits from XNACS1PrimitiveSet, allows a user to define behavior for a group of particles.
Inherits from XNACS1PrimitiveSet, allows a user to define behavior for a group of particles.

The XNACS1ParticleEmitter..::..FireEmitter type exposes the following members.

Constructors

 | Name | Description
Public method | XNACS1ParticleEmitter..::..FireEmitter | constructor for fire emitter

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddEmitterToUpdateSet | Adds the emitter to the emitter update list. This will cause the emitter's UpdateEmitter function to be called once per tick and it to emit particles as defined. Newly created emitters are automatically in the update set. (Inherited from XNACS1ParticleEmitter.)
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws all the particles in the emitter (Inherited from XNACS1ParticleEmitter.)
Protected method | Emit | When this method is called a new particle will be added to the emitter set and NewParticle() will be called to change the initial parameters of the particle if needed. (Inherited from XNACS1ParticleEmitter.)
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Protected method | KillParticle(Int32) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Protected method | KillParticle(XNACS1Particle) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Protected method | NewParticle | Creates a new particle with a random start location, and verticle velocity (Overrides XNACS1ParticleEmitter..::..NewParticle(XNACS1Particle).)
Public method | RemoveEmitterFromUpdateSet | Removes the emitter from the emitter update list. To be called before removing all references to the emitter so that garbage collection can collect it. (Inherited from XNACS1ParticleEmitter.)
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Overloaded TravelPrimitive for Particles. Moves the particle during each update cycle. This function is automacially called for all visible particle. Default behavior is to move the particle if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true This method moves the particle in the direction of its velocity and also displaces it according to the ParticleTravelMode chosen. (Inherited from XNACS1Particle.)
Protected method | Update | Controls updates for AttachedPrimitive, AutoRemoveDead, and AutoEmit. Overload at your own risk! (Inherited from XNACS1ParticleEmitter.)
Protected method | UpdateParticle | Overloaded UpdateParticle method, makes particles fade out according to what percentage of the default life they have remaining. (Overrides XNACS1ParticleEmitter..::..UpdateParticle(XNACS1Particle).)

Properties

 | Name | Description
Public property | AttachedPrimitive | Gets or Sets the primitive that this emitter is attached to. The emitter's center will be automatically updated each tick to match the attached primitive's center. (Inherited from XNACS1ParticleEmitter.)
Public property | AutoEmitEnabled | Gets or Sets whether or not particles should automatically be emitted every EmitFrequency ticks. (Inherited from XNACS1ParticleEmitter.)
Public property | AutoRemoveDeadParticles | Gets or sets whether or not particles with zero life remaining will be automatically deleted from the particle emitter set. Setting a particle's life to negative will ensure it is never deleted via this functionality. (Inherited from XNACS1ParticleEmitter.)
Public property | Center | Center of the primitive. (Inherited from XNACS1Particle.)
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | DefaultColor | Gets or Sets The default color of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | DefaultTexture | Gets or Sets The default texture of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | DisplacementAmplitude | The amplitude of the Particle TravelMode displacement. For example, the amplitude of the Sine Wave. (Inherited from XNACS1Particle.)
Public property | DisplacementFrequency | The frequency of the Particle TravelMode displacement. The default is 1, values between 0..1 would stretch a sine wave while values >1 would compress it. (Inherited from XNACS1Particle.)
Public property | EmitFrequency | Gets or Sets how many ticks between calls of EmitParticle if AutoEmitEnable = True. (Inherited from XNACS1ParticleEmitter.)
Public property | FireDirection | gets and sets the angle for the fire
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | InitialLife | Gets or Sets the default life in ticks for emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | InitialSize | Gets or Sets The default size of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | Life | Gets or sets the life parameter of a particle. (Inherited from XNACS1Particle.)
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | ParticlesPerEmit | Gets or Sets the number of particles to be emitted per emit cycle if AutoEmitEnabled = true. (Inherited from XNACS1ParticleEmitter.)
Public property | Radius | Radius of the circle. (Inherited from XNACS1Circle.)
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false. (Inherited from XNACS1Particle.)
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | TravelMode | Gets or Sets the primitive's TravelMode if ShouldTravel = True. Used in conjunction with DisplacementAmplitude and DisplacementFrequecy. (Inherited from XNACS1Particle.)
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)

See Also

XNACS1ParticleEmitter..::..FireEmitter Class


XNACS1ParticleEmitter.FireEmitter Constructor

XNACS1ParticleEmitter..::..FireEmitter Constructor
XNACS1ParticleEmitter..::..FireEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
constructor for fire emitter

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public FireEmitter(
    Vector2 center,
    int initialParticleLife,
    float particleSize,
    string tex,
    Color defaultColor,
    float fireHeight,
    float fireWidth,
    Vector2 fireDirection
)

Parameters

center
Type: Vector2

[Missing <param name="center"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.FireEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color,System.Single,System.Single,Microsoft.Xna.Framework.Vector2)"]

initialParticleLife
Type: System..::..Int32

[Missing <param name="initialParticleLife"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.FireEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color,System.Single,System.Single,Microsoft.Xna.Framework.Vector2)"]

particleSize
Type: System..::..Single

[Missing <param name="particleSize"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.FireEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color,System.Single,System.Single,Microsoft.Xna.Framework.Vector2)"]

tex
Type: System..::..String
The texture for the fire particles
defaultColor
Type: Color

[Missing <param name="defaultColor"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.FireEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color,System.Single,System.Single,Microsoft.Xna.Framework.Vector2)"]

fireHeight
Type: System..::..Single
The height of the fire
fireWidth
Type: System..::..Single
The width of the fire
fireDirection
Type: Vector2
The direction that the fire will travel in.

See Also

XNACS1ParticleEmitter..::..FireEmitter Class


XNACS1ParticleEmitter.FireEmitter Methods

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter..::..FireEmitter Methods
XNACS1ParticleEmitter..::..FireEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1ParticleEmitter..::..FireEmitter type exposes the following members.

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddEmitterToUpdateSet | Adds the emitter to the emitter update list. This will cause the emitter's UpdateEmitter function to be called once per tick and it to emit particles as defined. Newly created emitters are automatically in the update set. (Inherited from XNACS1ParticleEmitter.)
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws all the particles in the emitter (Inherited from XNACS1ParticleEmitter.)
Protected method | Emit | When this method is called a new particle will be added to the emitter set and NewParticle() will be called to change the initial parameters of the particle if needed. (Inherited from XNACS1ParticleEmitter.)
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Protected method | KillParticle(Int32) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Protected method | KillParticle(XNACS1Particle) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Protected method | NewParticle | Creates a new particle with a random start location, and verticle velocity (Overrides XNACS1ParticleEmitter..::..NewParticle(XNACS1Particle).)
Public method | RemoveEmitterFromUpdateSet | Removes the emitter from the emitter update list. To be called before removing all references to the emitter so that garbage collection can collect it. (Inherited from XNACS1ParticleEmitter.)
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Overloaded TravelPrimitive for Particles. Moves the particle during each update cycle. This function is automacially called for all visible particle. Default behavior is to move the particle if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true This method moves the particle in the direction of its velocity and also displaces it according to the ParticleTravelMode chosen. (Inherited from XNACS1Particle.)
Protected method | Update | Controls updates for AttachedPrimitive, AutoRemoveDead, and AutoEmit. Overload at your own risk! (Inherited from XNACS1ParticleEmitter.)
Protected method | UpdateParticle | Overloaded UpdateParticle method, makes particles fade out according to what percentage of the default life they have remaining. (Overrides XNACS1ParticleEmitter..::..UpdateParticle(XNACS1Particle).)

See Also

XNACS1ParticleEmitter..::..FireEmitter Class


Collided Method

[image]

XNACS1Lib Documentation
FireEmitter..::..Collided Method
XNACS1ParticleEmitter..::..FireEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)

See Also

XNACS1ParticleEmitter..::..FireEmitter Class
XNACS1ParticleEmitter..::..FireEmitter Members


KillParticle Method

[image]

XNACS1Lib Documentation
FireEmitter..::..KillParticle Method
XNACS1ParticleEmitter..::..FireEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Protected method | KillParticle(Int32) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Protected method | KillParticle(XNACS1Particle) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)

See Also

XNACS1ParticleEmitter..::..FireEmitter Class
XNACS1ParticleEmitter..::..FireEmitter Members


NewParticle Method

XNACS1ParticleEmitter..::..FireEmitter..::..NewParticle Method
XNACS1ParticleEmitter..::..FireEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Creates a new particle with a random start location, and verticle velocity

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void NewParticle(
    XNACS1Particle newParticle
)

Parameters

newParticle
Type: XNACS1Lib..::..XNACS1Particle

[Missing <param name="newParticle"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.FireEmitter.NewParticle(XNACS1Lib.XNACS1Particle)"]

See Also

XNACS1ParticleEmitter..::..FireEmitter Class


UpdateParticle Method

XNACS1ParticleEmitter..::..FireEmitter..::..UpdateParticle Method
XNACS1ParticleEmitter..::..FireEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Overloaded UpdateParticle method, makes particles fade out according to what percentage of the default life they have remaining.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void UpdateParticle(
    XNACS1Particle particle
)

Parameters

particle
Type: XNACS1Lib..::..XNACS1Particle

[Missing <param name="particle"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.FireEmitter.UpdateParticle(XNACS1Lib.XNACS1Particle)"]

See Also

XNACS1ParticleEmitter..::..FireEmitter Class


XNACS1ParticleEmitter.FireEmitter Properties

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter..::..FireEmitter Properties
XNACS1ParticleEmitter..::..FireEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1ParticleEmitter..::..FireEmitter type exposes the following members.

Properties

 | Name | Description
Public property | AttachedPrimitive | Gets or Sets the primitive that this emitter is attached to. The emitter's center will be automatically updated each tick to match the attached primitive's center. (Inherited from XNACS1ParticleEmitter.)
Public property | AutoEmitEnabled | Gets or Sets whether or not particles should automatically be emitted every EmitFrequency ticks. (Inherited from XNACS1ParticleEmitter.)
Public property | AutoRemoveDeadParticles | Gets or sets whether or not particles with zero life remaining will be automatically deleted from the particle emitter set. Setting a particle's life to negative will ensure it is never deleted via this functionality. (Inherited from XNACS1ParticleEmitter.)
Public property | Center | Center of the primitive. (Inherited from XNACS1Particle.)
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | DefaultColor | Gets or Sets The default color of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | DefaultTexture | Gets or Sets The default texture of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | DisplacementAmplitude | The amplitude of the Particle TravelMode displacement. For example, the amplitude of the Sine Wave. (Inherited from XNACS1Particle.)
Public property | DisplacementFrequency | The frequency of the Particle TravelMode displacement. The default is 1, values between 0..1 would stretch a sine wave while values >1 would compress it. (Inherited from XNACS1Particle.)
Public property | EmitFrequency | Gets or Sets how many ticks between calls of EmitParticle if AutoEmitEnable = True. (Inherited from XNACS1ParticleEmitter.)
Public property | FireDirection | gets and sets the angle for the fire
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | InitialLife | Gets or Sets the default life in ticks for emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | InitialSize | Gets or Sets The default size of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | Life | Gets or sets the life parameter of a particle. (Inherited from XNACS1Particle.)
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | ParticlesPerEmit | Gets or Sets the number of particles to be emitted per emit cycle if AutoEmitEnabled = true. (Inherited from XNACS1ParticleEmitter.)
Public property | Radius | Radius of the circle. (Inherited from XNACS1Circle.)
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false. (Inherited from XNACS1Particle.)
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | TravelMode | Gets or Sets the primitive's TravelMode if ShouldTravel = True. Used in conjunction with DisplacementAmplitude and DisplacementFrequecy. (Inherited from XNACS1Particle.)
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)

See Also

XNACS1ParticleEmitter..::..FireEmitter Class


FireDirection Property

XNACS1ParticleEmitter..::..FireEmitter..::..FireDirection Property
XNACS1ParticleEmitter..::..FireEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
gets and sets the angle for the fire

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Vector2 FireDirection { get; set; }

See Also

XNACS1ParticleEmitter..::..FireEmitter Class


XNACS1ParticleEmitter.TailEmitter Class

XNACS1ParticleEmitter..::..TailEmitter Class
XNACS1ParticleEmitter Class Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Emits particles at the center of the emitter at a constant rate, which fade out according to InitialParticleLife. If the emitter is moving around this will look like a tail. Works best if attached to other primitives.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public class TailEmitter : XNACS1ParticleEmitter

Inheritance Hierarchy

System..::..Object
XNACS1Lib..::..XNACS1Primitive
XNACS1Lib..::..XNACS1Circle
XNACS1Lib..::..XNACS1Particle
XNACS1Lib..::..XNACS1ParticleEmitter
XNACS1Lib..::..XNACS1ParticleEmitter..::..TailEmitter

See Also

XNACS1ParticleEmitter..::..TailEmitter Members


XNACS1ParticleEmitter.TailEmitter Members

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter..::..TailEmitter Members
XNACS1ParticleEmitter..::..TailEmitter Class Constructors Methods Fields Properties See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Inherits from XNACS1PrimitiveSet, allows a user to define behavior for a group of particles.
Inherits from XNACS1PrimitiveSet, allows a user to define behavior for a group of particles.

The XNACS1ParticleEmitter..::..TailEmitter type exposes the following members.

Constructors

 | Name | Description
Public method | XNACS1ParticleEmitter..::..TailEmitter | Constructor for TailEmitter

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddEmitterToUpdateSet | Adds the emitter to the emitter update list. This will cause the emitter's UpdateEmitter function to be called once per tick and it to emit particles as defined. Newly created emitters are automatically in the update set. (Inherited from XNACS1ParticleEmitter.)
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws all the particles in the emitter (Inherited from XNACS1ParticleEmitter.)
Protected method | Emit | When this method is called a new particle will be added to the emitter set and NewParticle() will be called to change the initial parameters of the particle if needed. (Inherited from XNACS1ParticleEmitter.)
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Protected method | KillParticle(Int32) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Protected method | KillParticle(XNACS1Particle) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Protected method | NewParticle | (Overrides XNACS1ParticleEmitter..::..NewParticle(XNACS1Particle).)
Public method | RemoveEmitterFromUpdateSet | Removes the emitter from the emitter update list. To be called before removing all references to the emitter so that garbage collection can collect it. (Inherited from XNACS1ParticleEmitter.)
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Overloaded TravelPrimitive for Particles. Moves the particle during each update cycle. This function is automacially called for all visible particle. Default behavior is to move the particle if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true This method moves the particle in the direction of its velocity and also displaces it according to the ParticleTravelMode chosen. (Inherited from XNACS1Particle.)
Protected method | Update | Overloaded update functionality to make it only emit if the emitter has moved, so that the tail wont bunch up if it stops moving. (Overrides XNACS1ParticleEmitter..::..Update()()()().)
Protected method | UpdateParticle | Overloaded UpdateParticle to cause particles to fade as they die. (Overrides XNACS1ParticleEmitter..::..UpdateParticle(XNACS1Particle).)

Fields

 | Name | Description
Public field | TailTravelMode | Defines the behaviour for how the tail particles move.

Properties

 | Name | Description
Public property | AttachedPrimitive | Gets or Sets the primitive that this emitter is attached to. The emitter's center will be automatically updated each tick to match the attached primitive's center. (Inherited from XNACS1ParticleEmitter.)
Public property | AutoEmitEnabled | Gets or Sets whether or not particles should automatically be emitted every EmitFrequency ticks. (Inherited from XNACS1ParticleEmitter.)
Public property | AutoRemoveDeadParticles | Gets or sets whether or not particles with zero life remaining will be automatically deleted from the particle emitter set. Setting a particle's life to negative will ensure it is never deleted via this functionality. (Inherited from XNACS1ParticleEmitter.)
Public property | Center | Center of the primitive. (Inherited from XNACS1Particle.)
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | DefaultColor | Gets or Sets The default color of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | DefaultTexture | Gets or Sets The default texture of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | DisplacementAmplitude | The amplitude of the Particle TravelMode displacement. For example, the amplitude of the Sine Wave. (Inherited from XNACS1Particle.)
Public property | DisplacementFrequency | The frequency of the Particle TravelMode displacement. The default is 1, values between 0..1 would stretch a sine wave while values >1 would compress it. (Inherited from XNACS1Particle.)
Public property | EmitFrequency | Gets or Sets how many ticks between calls of EmitParticle if AutoEmitEnable = True. (Inherited from XNACS1ParticleEmitter.)
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | InitialLife | Gets or Sets the default life in ticks for emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | InitialSize | Gets or Sets The default size of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | Life | Gets or sets the life parameter of a particle. (Inherited from XNACS1Particle.)
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | ParticlesPerEmit | Gets or Sets the number of particles to be emitted per emit cycle if AutoEmitEnabled = true. (Inherited from XNACS1ParticleEmitter.)
Public property | Radius | Radius of the circle. (Inherited from XNACS1Circle.)
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false. (Inherited from XNACS1Particle.)
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | TravelMode | Gets or Sets the primitive's TravelMode if ShouldTravel = True. Used in conjunction with DisplacementAmplitude and DisplacementFrequecy. (Inherited from XNACS1Particle.)
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)

See Also

XNACS1ParticleEmitter..::..TailEmitter Class


XNACS1ParticleEmitter.TailEmitter Constructor

XNACS1ParticleEmitter..::..TailEmitter Constructor
XNACS1ParticleEmitter..::..TailEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Constructor for TailEmitter

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public TailEmitter(
    Vector2 center,
    int initialParticleLife,
    float particleSize,
    string tex,
    Color defaultColor
)

Parameters

center
Type: Vector2

[Missing <param name="center"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.TailEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color)"]

initialParticleLife
Type: System..::..Int32

[Missing <param name="initialParticleLife"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.TailEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color)"]

particleSize
Type: System..::..Single

[Missing <param name="particleSize"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.TailEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color)"]

tex
Type: System..::..String

[Missing <param name="tex"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.TailEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color)"]

defaultColor
Type: Color

[Missing <param name="defaultColor"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.TailEmitter.#ctor(Microsoft.Xna.Framework.Vector2,System.Int32,System.Single,System.String,Microsoft.Xna.Framework.Color)"]

See Also

XNACS1ParticleEmitter..::..TailEmitter Class


XNACS1ParticleEmitter.TailEmitter Fields

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter..::..TailEmitter Fields
XNACS1ParticleEmitter..::..TailEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1ParticleEmitter..::..TailEmitter type exposes the following members.

Fields

 | Name | Description
Public field | TailTravelMode | Defines the behaviour for how the tail particles move.

See Also

XNACS1ParticleEmitter..::..TailEmitter Class


TailTravelMode Field

XNACS1ParticleEmitter..::..TailEmitter..::..TailTravelMode Field
XNACS1ParticleEmitter..::..TailEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Defines the behaviour for how the tail particles move.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ParticleTravelMode TailTravelMode

See Also

XNACS1ParticleEmitter..::..TailEmitter Class


XNACS1ParticleEmitter.TailEmitter Methods

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter..::..TailEmitter Methods
XNACS1ParticleEmitter..::..TailEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1ParticleEmitter..::..TailEmitter type exposes the following members.

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddEmitterToUpdateSet | Adds the emitter to the emitter update list. This will cause the emitter's UpdateEmitter function to be called once per tick and it to emit particles as defined. Newly created emitters are automatically in the update set. (Inherited from XNACS1ParticleEmitter.)
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws all the particles in the emitter (Inherited from XNACS1ParticleEmitter.)
Protected method | Emit | When this method is called a new particle will be added to the emitter set and NewParticle() will be called to change the initial parameters of the particle if needed. (Inherited from XNACS1ParticleEmitter.)
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Protected method | KillParticle(Int32) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Protected method | KillParticle(XNACS1Particle) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Protected method | NewParticle | (Overrides XNACS1ParticleEmitter..::..NewParticle(XNACS1Particle).)
Public method | RemoveEmitterFromUpdateSet | Removes the emitter from the emitter update list. To be called before removing all references to the emitter so that garbage collection can collect it. (Inherited from XNACS1ParticleEmitter.)
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Overloaded TravelPrimitive for Particles. Moves the particle during each update cycle. This function is automacially called for all visible particle. Default behavior is to move the particle if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true This method moves the particle in the direction of its velocity and also displaces it according to the ParticleTravelMode chosen. (Inherited from XNACS1Particle.)
Protected method | Update | Overloaded update functionality to make it only emit if the emitter has moved, so that the tail wont bunch up if it stops moving. (Overrides XNACS1ParticleEmitter..::..Update()()()().)
Protected method | UpdateParticle | Overloaded UpdateParticle to cause particles to fade as they die. (Overrides XNACS1ParticleEmitter..::..UpdateParticle(XNACS1Particle).)

See Also

XNACS1ParticleEmitter..::..TailEmitter Class


Collided Method

[image]

XNACS1Lib Documentation
TailEmitter..::..Collided Method
XNACS1ParticleEmitter..::..TailEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)

See Also

XNACS1ParticleEmitter..::..TailEmitter Class
XNACS1ParticleEmitter..::..TailEmitter Members


KillParticle Method

[image]

XNACS1Lib Documentation
TailEmitter..::..KillParticle Method
XNACS1ParticleEmitter..::..TailEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Protected method | KillParticle(Int32) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)
Protected method | KillParticle(XNACS1Particle) | Removes a particle from the emitter list. (Inherited from XNACS1ParticleEmitter.)

See Also

XNACS1ParticleEmitter..::..TailEmitter Class
XNACS1ParticleEmitter..::..TailEmitter Members


NewParticle Method

XNACS1ParticleEmitter..::..TailEmitter..::..NewParticle Method
XNACS1ParticleEmitter..::..TailEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

[Missing <summary> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.TailEmitter.NewParticle(XNACS1Lib.XNACS1Particle)"]

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void NewParticle(
    XNACS1Particle newParticle
)

Parameters

newParticle
Type: XNACS1Lib..::..XNACS1Particle

[Missing <param name="newParticle"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.TailEmitter.NewParticle(XNACS1Lib.XNACS1Particle)"]

See Also

XNACS1ParticleEmitter..::..TailEmitter Class


Update Method

XNACS1ParticleEmitter..::..TailEmitter..::..Update Method
XNACS1ParticleEmitter..::..TailEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Overloaded update functionality to make it only emit if the emitter has moved, so that the tail wont bunch up if it stops moving.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void Update()

See Also

XNACS1ParticleEmitter..::..TailEmitter Class


UpdateParticle Method

XNACS1ParticleEmitter..::..TailEmitter..::..UpdateParticle Method
XNACS1ParticleEmitter..::..TailEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Overloaded UpdateParticle to cause particles to fade as they die.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void UpdateParticle(
    XNACS1Particle particle
)

Parameters

particle
Type: XNACS1Lib..::..XNACS1Particle

[Missing <param name="particle"/> documentation for "M:XNACS1Lib.XNACS1ParticleEmitter.TailEmitter.UpdateParticle(XNACS1Lib.XNACS1Particle)"]

See Also

XNACS1ParticleEmitter..::..TailEmitter Class


XNACS1ParticleEmitter.TailEmitter Properties

[image]

XNACS1Lib Documentation
XNACS1ParticleEmitter..::..TailEmitter Properties
XNACS1ParticleEmitter..::..TailEmitter Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1ParticleEmitter..::..TailEmitter type exposes the following members.

Properties

 | Name | Description
Public property | AttachedPrimitive | Gets or Sets the primitive that this emitter is attached to. The emitter's center will be automatically updated each tick to match the attached primitive's center. (Inherited from XNACS1ParticleEmitter.)
Public property | AutoEmitEnabled | Gets or Sets whether or not particles should automatically be emitted every EmitFrequency ticks. (Inherited from XNACS1ParticleEmitter.)
Public property | AutoRemoveDeadParticles | Gets or sets whether or not particles with zero life remaining will be automatically deleted from the particle emitter set. Setting a particle's life to negative will ensure it is never deleted via this functionality. (Inherited from XNACS1ParticleEmitter.)
Public property | Center | Center of the primitive. (Inherited from XNACS1Particle.)
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | DefaultColor | Gets or Sets The default color of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | DefaultTexture | Gets or Sets The default texture of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | DisplacementAmplitude | The amplitude of the Particle TravelMode displacement. For example, the amplitude of the Sine Wave. (Inherited from XNACS1Particle.)
Public property | DisplacementFrequency | The frequency of the Particle TravelMode displacement. The default is 1, values between 0..1 would stretch a sine wave while values >1 would compress it. (Inherited from XNACS1Particle.)
Public property | EmitFrequency | Gets or Sets how many ticks between calls of EmitParticle if AutoEmitEnable = True. (Inherited from XNACS1ParticleEmitter.)
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | InitialLife | Gets or Sets the default life in ticks for emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | InitialSize | Gets or Sets The default size of emitted particles. (Inherited from XNACS1ParticleEmitter.)
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | Life | Gets or sets the life parameter of a particle. (Inherited from XNACS1Particle.)
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | ParticlesPerEmit | Gets or Sets the number of particles to be emitted per emit cycle if AutoEmitEnabled = true. (Inherited from XNACS1ParticleEmitter.)
Public property | Radius | Radius of the circle. (Inherited from XNACS1Circle.)
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false. (Inherited from XNACS1Particle.)
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | TravelMode | Gets or Sets the primitive's TravelMode if ShouldTravel = True. Used in conjunction with DisplacementAmplitude and DisplacementFrequecy. (Inherited from XNACS1Particle.)
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)

See Also

XNACS1ParticleEmitter..::..TailEmitter Class


XNACS1Primitive Class

XNACS1Primitive Class
Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
This is the base class for the behavior of Primitives (circle, rectangle, and primitive-set).

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public abstract class XNACS1Primitive

Inheritance Hierarchy

System..::..Object
XNACS1Lib..::..XNACS1Primitive
XNACS1Lib..::..XNACS1Circle
XNACS1Lib..::..XNACS1Rectangle

See Also

XNACS1Primitive Members


XNACS1Primitive Members

[image]

XNACS1Lib Documentation
XNACS1Primitive Members
XNACS1Primitive Class Methods Properties See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Primitive type exposes the following members.

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive.
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet.
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive.
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive.
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position.
Public method | Draw | If visible, draws the primitive with the associated text label.
Protected method | DrawPrimitive | Draws the primitive.
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero.
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet.
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window.
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop.
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge.
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives.
Public method | TravelPrimitive | Moves the primitive during each update cycle. This function is automacially called for all visible primitives. Default behavior is to move the primitive if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true

Properties

 | Name | Description
Public property | Center | Center of the primitive.
Public property | CenterX | X coordinate of the center position of the primitive.
Public property | CenterY | Y coordinate of the center position of the primitive.
Public property | Color | Color of the primitive. (undefined for PrimitiveSet).
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing.
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing.
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction
Public property | Label | Annotated text label to be associated with the primitive.
Public property | LabelColor | Color of the anontated text label.
Public property | MaxBound | Upper left corner of the primitive.
Public property | MinBound | Lower left corner of the Primitive.
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly.
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false.
Protected property | Size | Get/Set width/height of the primitive.
Protected property | SizeX | Width of the primitive.
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined).
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity.
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive.
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity.
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet.
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence.
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel.
Public property | VelocityDirection | Get/Set the direction of the velocity.
Public property | VelocityX | Get/Set the x-component of the primitive velocity.
Public property | VelocityY | Get/Set the y-component of the primitive velocity.
Public property | Visible | Whether the primitive is visible.

See Also

XNACS1Primitive Class


XNACS1Primitive Methods

[image]

XNACS1Lib Documentation
XNACS1Primitive Methods
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Primitive type exposes the following members.

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive.
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet.
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive.
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive.
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position.
Public method | Draw | If visible, draws the primitive with the associated text label.
Protected method | DrawPrimitive | Draws the primitive.
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero.
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet.
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window.
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop.
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge.
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives.
Public method | TravelPrimitive | Moves the primitive during each update cycle. This function is automacially called for all visible primitives. Default behavior is to move the primitive if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true

See Also

XNACS1Primitive Class


Above Method

XNACS1Primitive..::..Above Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool Above(
    XNACS1Primitive otherPrimitive
)

Parameters

otherPrimitive
Type: XNACS1Lib..::..XNACS1Primitive
the other primitive.

Return Value

True: if the center's y value of this primitive is greater than the y value of the max bound of otherPrimitive, returns false otherwise.

See Also

XNACS1Primitive Class


AddToAutoDrawSet Method

XNACS1Primitive..::..AddToAutoDrawSet Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public virtual void AddToAutoDrawSet()

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..TopOfAutoDrawSet()()()()
XNACS1Primitive..::..IsInAutoDrawSet()()()()
XNACS1Primitive..::..RemoveFromAutoDrawSet()()()()


Below Method

XNACS1Primitive..::..Below Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool Below(
    XNACS1Primitive otherPrmitive
)

Parameters

otherPrmitive
Type: XNACS1Lib..::..XNACS1Primitive
the other primitive.

Return Value

True: if the center's y value of this primitive is smaller than the y value of the min bound of otherPrimitive, returns false otherwise.

See Also

XNACS1Primitive Class


Collided Method

[image]

XNACS1Lib Documentation
XNACS1Primitive..::..Collided Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive.
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position.

See Also

XNACS1Primitive Class
XNACS1Primitive Members


Collided Method (XNACS1Primitive)

XNACS1Primitive..::..Collided Method (XNACS1Primitive)
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Determines if this primitive collides with otherPrimitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool Collided(
    XNACS1Primitive otherPrimitive
)

Parameters

otherPrimitive
Type: XNACS1Lib..::..XNACS1Primitive
the other primitive.

Return Value

True: if the two primitives has collided. False: if the two primitives do not collide.

See Also

XNACS1Primitive Class
Collided Overload


Collided Method (XNACS1Primitive, )

XNACS1Primitive..::..Collided Method (XNACS1Primitive, )
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool Collided(
    XNACS1Primitive otherPrimitive,
    Vector2 pos
)

Parameters

otherPrimitive
Type: XNACS1Lib..::..XNACS1Primitive
the other primitive.
pos
Type: Vector2
If two primitives collide, this is the "average" of all the possible colliding positions.

Return Value

True: if the two primitives has collided. Pos is the approximated colliding position. False: if the two primitives do not collide, (Pos is undefined in this case).

See Also

XNACS1Primitive Class
Collided Overload


Draw Method

XNACS1Primitive..::..Draw Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
If visible, draws the primitive with the associated text label.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public void Draw()

See Also

XNACS1Primitive Class
XNACS1Primitive..::..Label


DrawPrimitive Method

XNACS1Primitive..::..DrawPrimitive Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Draws the primitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected abstract void DrawPrimitive()

See Also

XNACS1Primitive Class


HasNonZeroVelocity Method

XNACS1Primitive..::..HasNonZeroVelocity Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Retruns if the current velocity is non-zero.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool HasNonZeroVelocity()

Return Value

True, if velocity is non-zero, otherwise, returns false.

Remarks

When a primitive is moving very slowly (speed at 1/100,000 of world dimension), its velocity will be set to zero. This avoids final "jittering" of primitives that are moving very slowly.

See Also

XNACS1Primitive Class


IsInAutoDrawSet Method

XNACS1Primitive..::..IsInAutoDrawSet Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Determines if this primitive is in the AutoDrawSet.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public virtual bool IsInAutoDrawSet()

Return Value

True: if this primitive is in the AutoDrawSet, otherwise returns false.

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..AddToAutoDrawSet()()()()
XNACS1Primitive..::..TopOfAutoDrawSet()()()()
XNACS1Primitive..::..RemoveFromAutoDrawSet()()()()


LeftOf Method

XNACS1Primitive..::..LeftOf Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool LeftOf(
    XNACS1Primitive otherPrimitive
)

Parameters

otherPrimitive
Type: XNACS1Lib..::..XNACS1Primitive
the other primitive

Return Value

True: if the center's x value of this primitive is smaller than the x value of the min bound of otherPrimitive

See Also

XNACS1Primitive Class


RemoveFromAutoDrawSet Method

XNACS1Primitive..::..RemoveFromAutoDrawSet Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public virtual void RemoveFromAutoDrawSet()

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..AddToAutoDrawSet()()()()
XNACS1Primitive..::..TopOfAutoDrawSet()()()()
XNACS1Primitive..::..IsInAutoDrawSet()()()()


RightOf Method

XNACS1Primitive..::..RightOf Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool RightOf(
    XNACS1Primitive otherPrimitive
)

Parameters

otherPrimitive
Type: XNACS1Lib..::..XNACS1Primitive
the other primitive

Return Value

True: if the center's x value of this primitive is larger than the x value of the max bound of the otherPrimitive.

See Also

XNACS1Primitive Class


SetTextureSpriteAnimationFrames Method

XNACS1Primitive..::..SetTextureSpriteAnimationFrames Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public void SetTextureSpriteAnimationFrames(
    int beginX,
    int beginY,
    int endX,
    int endY,
    int ticksPerFrame,
    SpriteSheetAnimationMode mode
)

Parameters

beginX
Type: System..::..Int32

[Missing <param name="beginX"/> documentation for "M:XNACS1Lib.XNACS1Primitive.SetTextureSpriteAnimationFrames(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,XNACS1Lib.SpriteSheetAnimationMode)"]

beginY
Type: System..::..Int32

[Missing <param name="beginY"/> documentation for "M:XNACS1Lib.XNACS1Primitive.SetTextureSpriteAnimationFrames(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,XNACS1Lib.SpriteSheetAnimationMode)"]

endX
Type: System..::..Int32

[Missing <param name="endX"/> documentation for "M:XNACS1Lib.XNACS1Primitive.SetTextureSpriteAnimationFrames(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,XNACS1Lib.SpriteSheetAnimationMode)"]

endY
Type: System..::..Int32

[Missing <param name="endY"/> documentation for "M:XNACS1Lib.XNACS1Primitive.SetTextureSpriteAnimationFrames(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,XNACS1Lib.SpriteSheetAnimationMode)"]

ticksPerFrame
Type: System..::..Int32

[Missing <param name="ticksPerFrame"/> documentation for "M:XNACS1Lib.XNACS1Primitive.SetTextureSpriteAnimationFrames(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,XNACS1Lib.SpriteSheetAnimationMode)"]

mode
Type: XNACS1Lib..::..SpriteSheetAnimationMode

[Missing <param name="mode"/> documentation for "M:XNACS1Lib.XNACS1Primitive.SetTextureSpriteAnimationFrames(System.Int32,System.Int32,System.Int32,System.Int32,System.Int32,XNACS1Lib.SpriteSheetAnimationMode)"]

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..SetTextureSpriteSheet(String, Int32, Int32, Int32)
XNACS1Primitive..::..UseSpriteSheet
XNACS1Primitive..::..UseSpriteSheetAnimation
XNACS1Primitive..::..CurrentSpriteSheetFrameX
XNACS1Primitive..::..CurrentSpriteSheetFrameY


SetTextureSpriteSheet Method

XNACS1Primitive..::..SetTextureSpriteSheet Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public void SetTextureSpriteSheet(
    string SpriteSheetTexture,
    int numColumns,
    int numRows,
    int padding
)

Parameters

SpriteSheetTexture
Type: System..::..String

[Missing <param name="SpriteSheetTexture"/> documentation for "M:XNACS1Lib.XNACS1Primitive.SetTextureSpriteSheet(System.String,System.Int32,System.Int32,System.Int32)"]

numColumns
Type: System..::..Int32

[Missing <param name="numColumns"/> documentation for "M:XNACS1Lib.XNACS1Primitive.SetTextureSpriteSheet(System.String,System.Int32,System.Int32,System.Int32)"]

numRows
Type: System..::..Int32

[Missing <param name="numRows"/> documentation for "M:XNACS1Lib.XNACS1Primitive.SetTextureSpriteSheet(System.String,System.Int32,System.Int32,System.Int32)"]

padding
Type: System..::..Int32

[Missing <param name="padding"/> documentation for "M:XNACS1Lib.XNACS1Primitive.SetTextureSpriteSheet(System.String,System.Int32,System.Int32,System.Int32)"]

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..UseSpriteSheet
XNACS1Primitive..::..SetTextureSpriteAnimationFrames(Int32, Int32, Int32, Int32, Int32, SpriteSheetAnimationMode)
XNACS1Primitive..::..UseSpriteSheetAnimation
XNACS1Primitive..::..CurrentSpriteSheetFrameY
XNACS1Primitive..::..CurrentSpriteSheetFrameX


TopOfAutoDrawSet Method

XNACS1Primitive..::..TopOfAutoDrawSet Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Make sure this primitive is drawn on top of all other primitives.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public virtual void TopOfAutoDrawSet()

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..AddToAutoDrawSet()()()()
XNACS1Primitive..::..IsInAutoDrawSet()()()()
XNACS1Primitive..::..RemoveFromAutoDrawSet()()()()


TravelPrimitive Method

XNACS1Primitive..::..TravelPrimitive Method
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Moves the primitive during each update cycle. This function is automacially called for all visible primitives. Default behavior is to move the primitive if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public virtual void TravelPrimitive()

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..Visible
XNACS1Primitive..::..ShouldTravel
XNACS1Primitive..::..HasNonZeroVelocity()()()()


XNACS1Primitive Properties

[image]

XNACS1Lib Documentation
XNACS1Primitive Properties
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Primitive type exposes the following members.

Properties

 | Name | Description
Public property | Center | Center of the primitive.
Public property | CenterX | X coordinate of the center position of the primitive.
Public property | CenterY | Y coordinate of the center position of the primitive.
Public property | Color | Color of the primitive. (undefined for PrimitiveSet).
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing.
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing.
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction
Public property | Label | Annotated text label to be associated with the primitive.
Public property | LabelColor | Color of the anontated text label.
Public property | MaxBound | Upper left corner of the primitive.
Public property | MinBound | Lower left corner of the Primitive.
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly.
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false.
Protected property | Size | Get/Set width/height of the primitive.
Protected property | SizeX | Width of the primitive.
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined).
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity.
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive.
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity.
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet.
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence.
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel.
Public property | VelocityDirection | Get/Set the direction of the velocity.
Public property | VelocityX | Get/Set the x-component of the primitive velocity.
Public property | VelocityY | Get/Set the y-component of the primitive velocity.
Public property | Visible | Whether the primitive is visible.

See Also

XNACS1Primitive Class


Center Property

XNACS1Primitive..::..Center Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Center of the primitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Vector2 Center { get; set; }

Remarks

For PrimitiveCircle (center), PrimitiveRectangle (center), PrimitiveSet (undefined).

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..CenterX
XNACS1Primitive..::..CenterY
XNACS1Lib..::..XNACS1Rectangle
XNACS1Lib..::..XNACS1Circle


CenterX Property

XNACS1Primitive..::..CenterX Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
X coordinate of the center position of the primitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float CenterX { get; set; }

Remarks

For PrimitiveCircle (x-position of center), PrimitiveRectangle (x-position of center), PrimitiveSet (undefined).

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..Center
XNACS1Lib..::..XNACS1Rectangle
XNACS1Lib..::..XNACS1Circle


CenterY Property

XNACS1Primitive..::..CenterY Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Y coordinate of the center position of the primitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float CenterY { get; set; }

Remarks

For PrimitiveCircle (y-position of center), PrimitiveRectangle (y-position of center), PrimitiveSet (undefined).

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..Center
XNACS1Lib..::..XNACS1Rectangle
XNACS1Lib..::..XNACS1Circle


Color Property

XNACS1Primitive..::..Color Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Color of the primitive. (undefined for PrimitiveSet).

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Color Color { get; set; }

Remarks

When texture file name is valid, Color inforamtion is ignored.

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..Color
XNACS1Primitive..::..Texture


CurrentSpriteSheetFrameX Property

XNACS1Primitive..::..CurrentSpriteSheetFrameX Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or Sets the zero-based current sprite column for sprite sheet drawing.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public int CurrentSpriteSheetFrameX { get; set; }

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..SetTextureSpriteSheet(String, Int32, Int32, Int32)
XNACS1Primitive..::..SetTextureSpriteAnimationFrames(Int32, Int32, Int32, Int32, Int32, SpriteSheetAnimationMode)
XNACS1Primitive..::..UseSpriteSheetAnimation
XNACS1Primitive..::..UseSpriteSheet
XNACS1Primitive..::..CurrentSpriteSheetFrameY


CurrentSpriteSheetFrameY Property

XNACS1Primitive..::..CurrentSpriteSheetFrameY Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Gets or Sets the zero-based current sprite row for sprite sheet drawing.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public int CurrentSpriteSheetFrameY { get; set; }

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..SetTextureSpriteSheet(String, Int32, Int32, Int32)
XNACS1Primitive..::..SetTextureSpriteAnimationFrames(Int32, Int32, Int32, Int32, Int32, SpriteSheetAnimationMode)
XNACS1Primitive..::..UseSpriteSheetAnimation
XNACS1Primitive..::..UseSpriteSheet
XNACS1Primitive..::..CurrentSpriteSheetFrameX


FrontDirection Property

XNACS1Primitive..::..FrontDirection Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Vector2 FrontDirection { get; set; }

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..RotateAngle
XNACS1Primitive..::..NormalDirection


Label Property

XNACS1Primitive..::..Label Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Annotated text label to be associated with the primitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public string Label { get; set; }

See Also

XNACS1Primitive Class
XNACS1Primitive..::..LabelColor


LabelColor Property

XNACS1Primitive..::..LabelColor Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Color of the anontated text label.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Color LabelColor { get; set; }

See Also

XNACS1Primitive Class
XNACS1Primitive..::..Label


MaxBound Property

XNACS1Primitive..::..MaxBound Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Upper left corner of the primitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Vector2 MaxBound { get; }

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..MinBound
XNACS1Lib..::..XNACS1Rectangle
XNACS1Lib..::..XNACS1Circle


MinBound Property

XNACS1Primitive..::..MinBound Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Lower left corner of the Primitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Vector2 MinBound { get; }

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..MaxBound
XNACS1Lib..::..XNACS1Rectangle
XNACS1Lib..::..XNACS1Circle


NormalDirection Property

XNACS1Primitive..::..NormalDirection Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Vector2 NormalDirection { get; set; }

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..RotateAngle
XNACS1Primitive..::..FrontDirection


RotateAngle Property

XNACS1Primitive..::..RotateAngle Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float RotateAngle { get; set; }

See Also

XNACS1Primitive Class
XNACS1Primitive..::..FrontDirection


ShouldTravel Property

XNACS1Primitive..::..ShouldTravel Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Defines if the primitive should move by its current velocity. Defaults to false.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool ShouldTravel { get; set; }

Remarks

Must be set to true for a primitive to move.

See Also

XNACS1Primitive Class
XNACS1Primitive..::..Velocity


Size Property

XNACS1Primitive..::..Size Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Get/Set width/height of the primitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected internal Vector2 Size { get; set; }

Remarks

For PrimitiveCircle (diameter), PrimitiveRectangle (width/height), PrimitiveSet (undefined)

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..SizeX
XNACS1Primitive..::..SizeY
XNACS1Lib..::..XNACS1Rectangle
XNACS1Lib..::..XNACS1Circle


SizeX Property

XNACS1Primitive..::..SizeX Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Width of the primitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected internal float SizeX { get; set; }

Remarks

For PrimitiveCircle (diameter), PrimitiveRectangle (width), PrimitiveSet (undefined).

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..Size
XNACS1Lib..::..XNACS1Rectangle
XNACS1Lib..::..XNACS1Circle


SizeY Property

XNACS1Primitive..::..SizeY Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined).

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected internal float SizeY { get; set; }

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..Size
XNACS1Lib..::..XNACS1Rectangle
XNACS1Lib..::..XNACS1Circle


Speed Property

XNACS1Primitive..::..Speed Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Get/Set the speed (magnitude of the Velocity vector) for the velocity.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float Speed { get; set; }

Remarks

The direction which the primitive is traveling will not change, just how fast it is moving will be updated. Primitive with non-zero velocity will move only when ShouldTravel is set to true.

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..Velocity
XNACS1Primitive..::..VelocityDirection
XNACS1Primitive..::..ShouldTravel


Texture Property

XNACS1Primitive..::..Texture Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Texture file name (without the "." or the extension) to cover the primitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public string Texture { get; set; }

Remarks

When texture file name is valid, Color inforamtion is ignored.

See Also

XNACS1Primitive Class
XNACS1Primitive..::..Color


TextureTintColor Property

XNACS1Primitive..::..TextureTintColor Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Color TextureTintColor { get; set; }

See Also

XNACS1Primitive Class


UseSpriteSheet Property

XNACS1Primitive..::..UseSpriteSheet Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Allow the primitive to draw as a sprite sheet.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool UseSpriteSheet { get; set; }

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..SetTextureSpriteSheet(String, Int32, Int32, Int32)
XNACS1Primitive..::..SetTextureSpriteAnimationFrames(Int32, Int32, Int32, Int32, Int32, SpriteSheetAnimationMode)
XNACS1Primitive..::..UseSpriteSheetAnimation
XNACS1Primitive..::..CurrentSpriteSheetFrameX
XNACS1Primitive..::..CurrentSpriteSheetFrameY


UseSpriteSheetAnimation Property

XNACS1Primitive..::..UseSpriteSheetAnimation Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Allow the primitive to follow a specified sprite sheet animation sequence.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool UseSpriteSheetAnimation { get; set; }

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..SetTextureSpriteSheet(String, Int32, Int32, Int32)
XNACS1Primitive..::..SetTextureSpriteAnimationFrames(Int32, Int32, Int32, Int32, Int32, SpriteSheetAnimationMode)
XNACS1Primitive..::..UseSpriteSheet
XNACS1Primitive..::..CurrentSpriteSheetFrameX
XNACS1Primitive..::..CurrentSpriteSheetFrameY


Velocity Property

XNACS1Primitive..::..Velocity Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Vector2 Velocity { get; set; }

Remarks

Primitive with non-zero velocity will move only when ShouldTravel is set to true.

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..ShouldTravel
XNACS1Primitive..::..VelocityX
XNACS1Primitive..::..VelocityY
XNACS1Primitive..::..VelocityDirection
XNACS1Primitive..::..Speed


VelocityDirection Property

XNACS1Primitive..::..VelocityDirection Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Get/Set the direction of the velocity.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Vector2 VelocityDirection { get; set; }

Remarks

The speed upon which the primitive travels will not change, only the direction will be updated. Primitive with non-zero velocity will move only when ShouldTravel is set to true.

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..ShouldTravel
XNACS1Primitive..::..Velocity
XNACS1Primitive..::..Speed


VelocityX Property

XNACS1Primitive..::..VelocityX Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Get/Set the x-component of the primitive velocity.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float VelocityX { get; set; }

Remarks

Primitive with non-zero velocity will move only when ShouldTravel is set to true.

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..Velocity
XNACS1Primitive..::..ShouldTravel


VelocityY Property

XNACS1Primitive..::..VelocityY Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Get/Set the y-component of the primitive velocity.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float VelocityY { get; set; }

Remarks

Primitive with non-zero velocity will move only when ShouldTravel is set to true.

See Also

XNACS1Primitive Class
XNACS1Lib Namespace
XNACS1Primitive..::..Velocity
XNACS1Primitive..::..ShouldTravel


Visible Property

XNACS1Primitive..::..Visible Property
XNACS1Primitive Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Whether the primitive is visible.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool Visible { get; set; }

See Also

XNACS1Primitive Class


XNACS1PrimitiveSet Class

XNACS1PrimitiveSet Class
Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
XNACS1PrimitiveSet supports hiding/unhiding a collection of Primitives (Circle, or Rectangle).

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public class XNACS1PrimitiveSet

Remarks

This class is designed to be used where related primitives can be added/removed from the AutoDrawSet as a group. Typically, you would insert related primitives (e.g., all primitives associated with a car) into a PrimitiveSet. By default all the prmitives in the PrimitiveSet will be drawn in the application window. When required to hide this group of primitives (e.g., car moved out of world bound), you can remove the PrimitiveSet from the AutoDrawSet resutling in hiding all the primitives inthe set. Later on, you can add this PrimitiveSet back into the AutoDrawSet to unhide the primitives (e.g., the car moved back into the world bound). Removing all primitives from this set will result in the primitives being removed from the AutoDrawSet.

Inheritance Hierarchy

System..::..Object
XNACS1Lib..::..XNACS1PrimitiveSet

See Also

XNACS1PrimitiveSet Members


XNACS1PrimitiveSet Members

[image]

XNACS1Lib Documentation
XNACS1PrimitiveSet Members
XNACS1PrimitiveSet Class Constructors Methods See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1PrimitiveSet type exposes the following members.

Constructors

 | Name | Description
Public method | XNACS1PrimitiveSet | Defines a collection structure for storing a group of XNACS1Primitives (Circle, Rectangle, or other PrimitiveSet).

Methods

 | Name | Description
Public method | AddAllToAutoDraw | Add all primitives in the set to the AutoDrawSet. If the primitives in this set are already in the AutoDrawSet then nothing will happen.
Public method | AddToSet | Adds the thePrimitive to this set.
Public method | IsInDrawSet | Determs if thePrimitive is already in the draw set.
Public method | RemoveAllFromAutoDrawSet | Remove all primitives in this set from the AutoDrawSet. After this call, none of the primitives in this set will be visible in the appliation window.
Public method | RemoveAllFromSet | Remove all the prmitives from this set. Will aslo remove all the primitives from the AutoDrawSet.
Public method | RemoveFromSet | Remove thePrimitive from this set. Will also remove the primitive from the AutoDrawSet.
Public method | SetSize | Returns the number of primitives in this set.

See Also

XNACS1PrimitiveSet Class


XNACS1PrimitiveSet Constructor

XNACS1PrimitiveSet Constructor
XNACS1PrimitiveSet Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Defines a collection structure for storing a group of XNACS1Primitives (Circle, Rectangle, or other PrimitiveSet).

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public XNACS1PrimitiveSet()

See Also

XNACS1PrimitiveSet Class


XNACS1PrimitiveSet Methods

[image]

XNACS1Lib Documentation
XNACS1PrimitiveSet Methods
XNACS1PrimitiveSet Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1PrimitiveSet type exposes the following members.

Methods

 | Name | Description
Public method | AddAllToAutoDraw | Add all primitives in the set to the AutoDrawSet. If the primitives in this set are already in the AutoDrawSet then nothing will happen.
Public method | AddToSet | Adds the thePrimitive to this set.
Public method | IsInDrawSet | Determs if thePrimitive is already in the draw set.
Public method | RemoveAllFromAutoDrawSet | Remove all primitives in this set from the AutoDrawSet. After this call, none of the primitives in this set will be visible in the appliation window.
Public method | RemoveAllFromSet | Remove all the prmitives from this set. Will aslo remove all the primitives from the AutoDrawSet.
Public method | RemoveFromSet | Remove thePrimitive from this set. Will also remove the primitive from the AutoDrawSet.
Public method | SetSize | Returns the number of primitives in this set.

See Also

XNACS1PrimitiveSet Class


AddAllToAutoDraw Method

XNACS1PrimitiveSet..::..AddAllToAutoDraw Method
XNACS1PrimitiveSet Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Add all primitives in the set to the AutoDrawSet. If the primitives in this set are already in the AutoDrawSet then nothing will happen.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public virtual void AddAllToAutoDraw()

See Also

XNACS1PrimitiveSet Class


AddToSet Method

XNACS1PrimitiveSet..::..AddToSet Method
XNACS1PrimitiveSet Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Adds the thePrimitive to this set.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public void AddToSet(
    XNACS1Primitive thePrimitive
)

Parameters

thePrimitive
Type: XNACS1Lib..::..XNACS1Primitive
The primitive to be added.

See Also

XNACS1PrimitiveSet Class


IsInDrawSet Method

XNACS1PrimitiveSet..::..IsInDrawSet Method
XNACS1PrimitiveSet Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Determs if thePrimitive is already in the draw set.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool IsInDrawSet(
    XNACS1Primitive thePrimitive
)

Parameters

thePrimitive
Type: XNACS1Lib..::..XNACS1Primitive
Primitive to be tested

Return Value

True: if thePrmitive is already in the set, else returns False.

See Also

XNACS1PrimitiveSet Class


RemoveAllFromAutoDrawSet Method

XNACS1PrimitiveSet..::..RemoveAllFromAutoDrawSet Method
XNACS1PrimitiveSet Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Remove all primitives in this set from the AutoDrawSet. After this call, none of the primitives in this set will be visible in the appliation window.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public virtual void RemoveAllFromAutoDrawSet()

See Also

XNACS1PrimitiveSet Class


RemoveAllFromSet Method

XNACS1PrimitiveSet..::..RemoveAllFromSet Method
XNACS1PrimitiveSet Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Remove all the prmitives from this set. Will aslo remove all the primitives from the AutoDrawSet.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public void RemoveAllFromSet()

See Also

XNACS1PrimitiveSet Class


RemoveFromSet Method

XNACS1PrimitiveSet..::..RemoveFromSet Method
XNACS1PrimitiveSet Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Remove thePrimitive from this set. Will also remove the primitive from the AutoDrawSet.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public void RemoveFromSet(
    XNACS1Primitive thePrimitive
)

Parameters

thePrimitive
Type: XNACS1Lib..::..XNACS1Primitive
The primitive to be removed from this set.

See Also

XNACS1PrimitiveSet Class


SetSize Method

XNACS1PrimitiveSet..::..SetSize Method
XNACS1PrimitiveSet Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Returns the number of primitives in this set.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public int SetSize()

Return Value

Numver of primitives in this set.

See Also

XNACS1PrimitiveSet Class


XNACS1Rectangle Class

XNACS1Rectangle Class
Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
A Rectangle primitive.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public class XNACS1Rectangle : XNACS1Primitive

Inheritance Hierarchy

System..::..Object
XNACS1Lib..::..XNACS1Primitive
XNACS1Lib..::..XNACS1Rectangle

See Also

XNACS1Rectangle Members


XNACS1Rectangle Members

[image]

XNACS1Lib Documentation
XNACS1Rectangle Members
XNACS1Rectangle Class Constructors Methods Properties See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Rectangle type exposes the following members.

Constructors

 | Name | Description
Public method | XNACS1Rectangle()()()() | Constrcuts a 1x1 rectangle with center located at (0,0).
Public method | XNACS1Rectangle(Vector2, Single, Single) | Constructs a rectangle.
Public method | XNACS1Rectangle(Vector2, Vector2, Single, String) | Constructs a rectangle with end points located at aPos and bPos, and width.
Public method | XNACS1Rectangle(Vector2, Single, Single, String) | Constructs a rectangle.

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws the Rectangle. (Overrides XNACS1Primitive..::..DrawPrimitive()()()().)
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetEndPoints | aPos and bPos are two end positions on the opposite edges of the rectangle. Width is the width of the edge.
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Moves the primitive during each update cycle. This function is automacially called for all visible primitives. Default behavior is to move the primitive if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true (Inherited from XNACS1Primitive.)

Properties

 | Name | Description
Public property | Center | Center of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | Height | Height of the rectangle.
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | LowerLeft | Lower left corner of the rectangle.
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false. (Inherited from XNACS1Primitive.)
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)
Public property | Width | Width of the rectangle.

See Also

XNACS1Rectangle Class


XNACS1Rectangle Constructor

[image]

XNACS1Lib Documentation
XNACS1Rectangle Constructor
XNACS1Rectangle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Public method | XNACS1Rectangle()()()() | Constrcuts a 1x1 rectangle with center located at (0,0).
Public method | XNACS1Rectangle(Vector2, Single, Single) | Constructs a rectangle.
Public method | XNACS1Rectangle(Vector2, Vector2, Single, String) | Constructs a rectangle with end points located at aPos and bPos, and width.
Public method | XNACS1Rectangle(Vector2, Single, Single, String) | Constructs a rectangle.

See Also

XNACS1Rectangle Class
XNACS1Rectangle Members


XNACS1Rectangle Constructor

XNACS1Rectangle Constructor
XNACS1Rectangle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Constrcuts a 1x1 rectangle with center located at (0,0).

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public XNACS1Rectangle()

See Also

XNACS1Rectangle Class
XNACS1Rectangle Overload


XNACS1Rectangle Constructor (, Single, Single)

XNACS1Rectangle Constructor (, Single, Single)
XNACS1Rectangle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Constructs a rectangle.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public XNACS1Rectangle(
    Vector2 center,
    float width,
    float height
)

Parameters

center
Type: Vector2
center of the rectangle.
width
Type: System..::..Single
width of the rectangle.
height
Type: System..::..Single
height of the rectangle.

See Also

XNACS1Rectangle Class
XNACS1Rectangle Overload


XNACS1Rectangle Constructor (, , Single, String)

XNACS1Rectangle Constructor (, , Single, String)
XNACS1Rectangle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Constructs a rectangle with end points located at aPos and bPos, and width.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public XNACS1Rectangle(
    Vector2 aPos,
    Vector2 bPos,
    float width,
    string tex
)

Parameters

aPos
Type: Vector2
End position of rectangle.
bPos
Type: Vector2
End position of rectangle.
width
Type: System..::..Single
Width of rectangle.
tex
Type: System..::..String
texture image to be used to cover the rectangle.

See Also

XNACS1Rectangle Class
XNACS1Rectangle Overload


XNACS1Rectangle Constructor (, Single, Single, String)

XNACS1Rectangle Constructor (, Single, Single, String)
XNACS1Rectangle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Constructs a rectangle.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public XNACS1Rectangle(
    Vector2 center,
    float width,
    float height,
    string tex
)

Parameters

center
Type: Vector2
center of the rectangle.
width
Type: System..::..Single
width of the rectangle.
height
Type: System..::..Single
height of the rectangle.
tex
Type: System..::..String
texture to be used to cover the rectangle.

See Also

XNACS1Rectangle Class
XNACS1Rectangle Overload


XNACS1Rectangle Methods

[image]

XNACS1Lib Documentation
XNACS1Rectangle Methods
XNACS1Rectangle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Rectangle type exposes the following members.

Methods

 | Name | Description
Public method | Above | Returns if the center of this primitive is "above" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | AddToAutoDrawSet | Add this primitive to the AutoDrawSet. If this primitive already exists in the draw set, this function call is ignored. By default, all primitive are added into the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | Below | Returns if the center of this primitive is "below" (in y) in relation to the center of otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)
Public method | Draw | If visible, draws the primitive with the associated text label. (Inherited from XNACS1Primitive.)
Protected method | DrawPrimitive | Draws the Rectangle. (Overrides XNACS1Primitive..::..DrawPrimitive()()()().)
Public method | HasNonZeroVelocity | Retruns if the current velocity is non-zero. (Inherited from XNACS1Primitive.)
Public method | IsInAutoDrawSet | Determines if this primitive is in the AutoDrawSet. (Inherited from XNACS1Primitive.)
Public method | LeftOf | Returns if the center of this primitive is "to the left" (in x) in relation to the center of otherPrimtive (Inherited from XNACS1Primitive.)
Public method | RemoveFromAutoDrawSet | Remove this primitive from the AutoDrawSet. After this function call, this primitive will not be drawn in the application window. (Inherited from XNACS1Primitive.)
Public method | RightOf | Returns if the center of this primitive is "to the right" (in x) in relation to the center of otherPrimitive (Inherited from XNACS1Primitive.)
Public method | SetEndPoints | aPos and bPos are two end positions on the opposite edges of the rectangle. Width is the width of the edge.
Public method | SetTextureSpriteAnimationFrames | Sets animation parameters for a sprite sheet primitive. Zero-based first frame column for the beginning sprite in the animation sequence.Zero-based first frame row for the beginning sprite in the animation sequence.Zero-based first frame column for the ending sprite in the animation sequence.Zero-based first frame row for the ending sprite in the animation sequence.How many ticks the animation will pause for on each frame.The behavior of the animation loop. (Inherited from XNACS1Primitive.)
Public method | SetTextureSpriteSheet | Defines a texture specified for a primitive to behave like a sprite sheet with the specified number of sprites. The default sprite to be drawn is the top left sprite in the sheet. Example: The texture for a given primitive has 16 sprites in it, arranged in a 4 by 4 pattern. By default, all 16 sprites will be displayed, stretched to fit the primitive. Calling this method allows you to specify the number of sprites in the texture. The texture of the sprite sheet to be used.The number of columns in the sprite sheet (number of sprites in a single row). Number of rows in the sprite sheet. The padding between sprites and on the top and left edge. (Inherited from XNACS1Primitive.)
Public method | TopOfAutoDrawSet | Make sure this primitive is drawn on top of all other primitives. (Inherited from XNACS1Primitive.)
Public method | TravelPrimitive | Moves the primitive during each update cycle. This function is automacially called for all visible primitives. Default behavior is to move the primitive if: . Primitive is visible (invivislble primitive is not updated) . ShouldTravel is true . HasNonZeroVelocity() is true (Inherited from XNACS1Primitive.)

See Also

XNACS1Rectangle Class


Collided Method

[image]

XNACS1Lib Documentation
XNACS1Rectangle..::..Collided Method
XNACS1Rectangle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

Overload List

 | Name | Description
Public method | Collided(XNACS1Primitive) | Determines if this primitive collides with otherPrimitive. (Inherited from XNACS1Primitive.)
Public method | Collided(XNACS1Primitive, Vector2) | Determines if this primitive collides with the otherPrimitive. If true, pos is the colliding position. (Inherited from XNACS1Primitive.)

See Also

XNACS1Rectangle Class
XNACS1Rectangle Members


DrawPrimitive Method

XNACS1Rectangle..::..DrawPrimitive Method
XNACS1Rectangle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Draws the Rectangle.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
protected override void DrawPrimitive()

See Also

XNACS1Rectangle Class


SetEndPoints Method

XNACS1Rectangle..::..SetEndPoints Method
XNACS1Rectangle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
aPos and bPos are two end positions on the opposite edges of the rectangle. Width is the width of the edge.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public void SetEndPoints(
    Vector2 aPos,
    Vector2 bPos,
    float width
)

Parameters

aPos
Type: Vector2
Center of one end position.
bPos
Type: Vector2
Center of the opposite end position.
width
Type: System..::..Single
Width of the rectangle.

See Also

XNACS1Rectangle Class


XNACS1Rectangle Properties

[image]

XNACS1Lib Documentation
XNACS1Rectangle Properties
XNACS1Rectangle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The XNACS1Rectangle type exposes the following members.

Properties

 | Name | Description
Public property | Center | Center of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterX | X coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | CenterY | Y coordinate of the center position of the primitive. (Inherited from XNACS1Primitive.)
Public property | Color | Color of the primitive. (undefined for PrimitiveSet). (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameX | Gets or Sets the zero-based current sprite column for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | CurrentSpriteSheetFrameY | Gets or Sets the zero-based current sprite row for sprite sheet drawing. (Inherited from XNACS1Primitive.)
Public property | FrontDirection | Sets the front direction of the primitive. Setting FrontDireciton will cause the RotateAngle and NormalDirection of the primitive to be updated accordingly. y default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | Height | Height of the rectangle.
Public property | Label | Annotated text label to be associated with the primitive. (Inherited from XNACS1Primitive.)
Public property | LabelColor | Color of the anontated text label. (Inherited from XNACS1Primitive.)
Public property | LowerLeft | Lower left corner of the rectangle.
Public property | MaxBound | Upper left corner of the primitive. (Inherited from XNACS1Primitive.)
Public property | MinBound | Lower left corner of the Primitive. (Inherited from XNACS1Primitive.)
Public property | NormalDirection | Get or Set the normal direction of the primitive. Setting NormalDirection will update RotateAngle and FrontDirection accordingly. (Inherited from XNACS1Primitive.)
Public property | RotateAngle | Rotate the primitive by the Angle specified (in degree). After the rotation, the FrontDirection of the primitive will be udpated accordingly. By default, when RotateAngle is 0, FrontDireciton points towards (1,0) [positive X-direction]. E.g., if we set RotateAngle to 90-degrees, FrontDireciton will be updated accordinlgy to (0,1) [positive y-direciton], or rotated 90-degress in the anit-clockwise direction (Inherited from XNACS1Primitive.)
Public property | ShouldTravel | Defines if the primitive should move by its current velocity. Defaults to false. (Inherited from XNACS1Primitive.)
Protected property | Size | Get/Set width/height of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeX | Width of the primitive. (Inherited from XNACS1Primitive.)
Protected property | SizeY | Height of the primitive. For PrimitiveCircle (diameter), PrimitiveRectangle (height), PrimitiveSet (undefined). (Inherited from XNACS1Primitive.)
Public property | Speed | Get/Set the speed (magnitude of the Velocity vector) for the velocity. (Inherited from XNACS1Primitive.)
Public property | Texture | Texture file name (without the "." or the extension) to cover the primitive. (Inherited from XNACS1Primitive.)
Public property | TextureTintColor | If a primitive has a texture assigned, this will change the tint and or opacity of the texture when drawn, Color.White is no tint or opacity. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheet | Allow the primitive to draw as a sprite sheet. (Inherited from XNACS1Primitive.)
Public property | UseSpriteSheetAnimation | Allow the primitive to follow a specified sprite sheet animation sequence. (Inherited from XNACS1Primitive.)
Public property | Velocity | Velocity of a primitive. This is a true velocity: with magnitude (speed) and direction for tavel. (Inherited from XNACS1Primitive.)
Public property | VelocityDirection | Get/Set the direction of the velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityX | Get/Set the x-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | VelocityY | Get/Set the y-component of the primitive velocity. (Inherited from XNACS1Primitive.)
Public property | Visible | Whether the primitive is visible. (Inherited from XNACS1Primitive.)
Public property | Width | Width of the rectangle.

See Also

XNACS1Rectangle Class


Height Property

XNACS1Rectangle..::..Height Property
XNACS1Rectangle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Height of the rectangle.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float Height { get; set; }

See Also

XNACS1Rectangle Class
XNACS1Lib Namespace
XNACS1Rectangle..::..Width
XNACS1Rectangle..::..SetEndPoints(Vector2, Vector2, Single)
XNACS1Rectangle..::..LowerLeft


LowerLeft Property

XNACS1Rectangle..::..LowerLeft Property
XNACS1Rectangle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Lower left corner of the rectangle.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Vector2 LowerLeft { get; set; }

See Also

XNACS1Rectangle Class


Width Property

XNACS1Rectangle..::..Width Property
XNACS1Rectangle Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Width of the rectangle.

Namespace: XNACS1Lib
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float Width { get; set; }

See Also

XNACS1Rectangle Class
XNACS1Lib Namespace
XNACS1Rectangle..::..Height
XNACS1Rectangle..::..SetEndPoints(Vector2, Vector2, Single)
XNACS1Rectangle..::..LowerLeft


XNACS1Lib.XNACS1Lib.GamePadSupport Namespace

XNACS1Lib.XNACS1Lib.GamePadSupport Namespace
Send Feedback
XNACS1Lib: CSS490 Spring 2011
Mapping to XBOX 360 support

Classes

 | Class | Description
Public class | GamePadStruct | State information for all input mechanisms on the XBOX 360 game pad controller.

Structures

 | Structure | Description
Public structure | AllButtonsOnGamePad | Records the states (pressed or release) of all the buttons on a XBOX 360 game pad.
Public structure | DPadOnGamePad | States (depressed or released) of the DPad-buttons (left, right, top, down) on the XBOX 360 game pad.
Public structure | ThumbSticksOnGamePad | Positions of the left and right thumbSticks on the XBOX 360 controller.
Public structure | TriggersOnGamePad | Positions of the left and right triggers on the XBOX 360 controller.


AllButtonsOnGamePad Structure

AllButtonsOnGamePad Structure
Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Records the states (pressed or release) of all the buttons on a XBOX 360 game pad.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public struct AllButtonsOnGamePad

See Also

AllButtonsOnGamePad Members
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


AllButtonsOnGamePad Members

[image]

XNACS1Lib Documentation
AllButtonsOnGamePad Members
AllButtonsOnGamePad Structure Fields See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The AllButtonsOnGamePad type exposes the following members.

Fields

 | Name | Description
Public field | A | State of the A-Button (pressed or released).
Public field | B | State of the B-Button (pressed or released).
Public field | Back | State of the back-Button (pressed or released).
Public field | LeftShoulder | State of the leftShoulder-Button (pressed or released).
Public field | LeftStick | State of the LeftStick-Button (pressed or released).
Public field | RightShoulder | State of the RightShoulder-Button (pressed or released).
Public field | RightStick | State of the RightStick-Button (pressed or released).
Public field | Start | State of the Start-Button (pressed or released).
Public field | X | State of the X-Button (pressed or released).
Public field | Y | State of the Y-Button (pressed or released).

See Also

AllButtonsOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


AllButtonsOnGamePad Fields

[image]

XNACS1Lib Documentation
AllButtonsOnGamePad Fields
AllButtonsOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The AllButtonsOnGamePad type exposes the following members.

Fields

 | Name | Description
Public field | A | State of the A-Button (pressed or released).
Public field | B | State of the B-Button (pressed or released).
Public field | Back | State of the back-Button (pressed or released).
Public field | LeftShoulder | State of the leftShoulder-Button (pressed or released).
Public field | LeftStick | State of the LeftStick-Button (pressed or released).
Public field | RightShoulder | State of the RightShoulder-Button (pressed or released).
Public field | RightStick | State of the RightStick-Button (pressed or released).
Public field | Start | State of the Start-Button (pressed or released).
Public field | X | State of the X-Button (pressed or released).
Public field | Y | State of the Y-Button (pressed or released).

See Also

AllButtonsOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


A Field

AllButtonsOnGamePad..::..A Field
AllButtonsOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the A-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState A

See Also

AllButtonsOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


B Field

AllButtonsOnGamePad..::..B Field
AllButtonsOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the B-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState B

See Also

AllButtonsOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Back Field

AllButtonsOnGamePad..::..Back Field
AllButtonsOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the back-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState Back

See Also

AllButtonsOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


LeftShoulder Field

AllButtonsOnGamePad..::..LeftShoulder Field
AllButtonsOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the leftShoulder-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState LeftShoulder

See Also

AllButtonsOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


LeftStick Field

AllButtonsOnGamePad..::..LeftStick Field
AllButtonsOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the LeftStick-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState LeftStick

See Also

AllButtonsOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


RightShoulder Field

AllButtonsOnGamePad..::..RightShoulder Field
AllButtonsOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the RightShoulder-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState RightShoulder

See Also

AllButtonsOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


RightStick Field

AllButtonsOnGamePad..::..RightStick Field
AllButtonsOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the RightStick-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState RightStick

See Also

AllButtonsOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Start Field

AllButtonsOnGamePad..::..Start Field
AllButtonsOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the Start-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState Start

See Also

AllButtonsOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


X Field

AllButtonsOnGamePad..::..X Field
AllButtonsOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the X-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState X

See Also

AllButtonsOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Y Field

AllButtonsOnGamePad..::..Y Field
AllButtonsOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the Y-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState Y

See Also

AllButtonsOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


DPadOnGamePad Structure

DPadOnGamePad Structure
Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
States (depressed or released) of the DPad-buttons (left, right, top, down) on the XBOX 360 game pad.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public struct DPadOnGamePad

See Also

DPadOnGamePad Members
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


DPadOnGamePad Members

[image]

XNACS1Lib Documentation
DPadOnGamePad Members
DPadOnGamePad Structure Fields See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The DPadOnGamePad type exposes the following members.

Fields

 | Name | Description
Public field | Down | State of the DPad Down-Button (pressed or released).
Public field | Left | State of the DPad Left-Button (pressed or released).
Public field | Right | State of the DPad Right-Button (pressed or released).
Public field | Up | State of the DPad Up-Button (pressed or released).

See Also

DPadOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


DPadOnGamePad Fields

[image]

XNACS1Lib Documentation
DPadOnGamePad Fields
DPadOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The DPadOnGamePad type exposes the following members.

Fields

 | Name | Description
Public field | Down | State of the DPad Down-Button (pressed or released).
Public field | Left | State of the DPad Left-Button (pressed or released).
Public field | Right | State of the DPad Right-Button (pressed or released).
Public field | Up | State of the DPad Up-Button (pressed or released).

See Also

DPadOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Down Field

DPadOnGamePad..::..Down Field
DPadOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the DPad Down-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState Down

See Also

DPadOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Left Field

DPadOnGamePad..::..Left Field
DPadOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the DPad Left-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState Left

See Also

DPadOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Right Field

DPadOnGamePad..::..Right Field
DPadOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the DPad Right-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState Right

See Also

DPadOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Up Field

DPadOnGamePad..::..Up Field
DPadOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State of the DPad Up-Button (pressed or released).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ButtonState Up

See Also

DPadOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


GamePadStruct Class

GamePadStruct Class
Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
State information for all input mechanisms on the XBOX 360 game pad controller.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public class GamePadStruct

Inheritance Hierarchy

System..::..Object
XNACS1Lib.XNACS1Lib.GamePadSupport..::..GamePadStruct

See Also

GamePadStruct Members
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


GamePadStruct Members

[image]

XNACS1Lib Documentation
GamePadStruct Members
GamePadStruct Class Methods Fields See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The GamePadStruct type exposes the following members.

Methods

 | Name | Description
Public method | ButtonAClicked | If Button-A has been clicked.
Public method | ButtonBackClicked | If the back button has been clicked.
Public method | ButtonBClicked | If Button-B has been clicked.
Public method | ButtonStartClicked | If the start button has been clicked.
Public method | ButtonXClicked | If Button-X has been clicked.
Public method | ButtonYClicked | If Button-Y has been clicked.

Fields

 | Name | Description
Public field | Buttons | States of all the buttons on the XBOX 360 game pad.
Public field | Dpad | States of all the buttons on the DPad on the XBOX 360 game pad.
Public field | ThumbSticks | Positions of the left and right thumbsticks on the XBOX 360 game pad.
Public field | Triggers | Positions of the left and right triggers on the XBOX 360 game pad.

See Also

GamePadStruct Class
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


GamePadStruct Fields

[image]

XNACS1Lib Documentation
GamePadStruct Fields
GamePadStruct Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The GamePadStruct type exposes the following members.

Fields

 | Name | Description
Public field | Buttons | States of all the buttons on the XBOX 360 game pad.
Public field | Dpad | States of all the buttons on the DPad on the XBOX 360 game pad.
Public field | ThumbSticks | Positions of the left and right thumbsticks on the XBOX 360 game pad.
Public field | Triggers | Positions of the left and right triggers on the XBOX 360 game pad.

See Also

GamePadStruct Class
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Buttons Field

GamePadStruct..::..Buttons Field
GamePadStruct Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
States of all the buttons on the XBOX 360 game pad.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public AllButtonsOnGamePad Buttons

See Also

GamePadStruct Class
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Dpad Field

GamePadStruct..::..Dpad Field
GamePadStruct Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
States of all the buttons on the DPad on the XBOX 360 game pad.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public DPadOnGamePad Dpad

See Also

GamePadStruct Class
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


ThumbSticks Field

GamePadStruct..::..ThumbSticks Field
GamePadStruct Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Positions of the left and right thumbsticks on the XBOX 360 game pad.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public ThumbSticksOnGamePad ThumbSticks

See Also

GamePadStruct Class
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Triggers Field

GamePadStruct..::..Triggers Field
GamePadStruct Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Positions of the left and right triggers on the XBOX 360 game pad.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public TriggersOnGamePad Triggers

See Also

GamePadStruct Class
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


GamePadStruct Methods

[image]

XNACS1Lib Documentation
GamePadStruct Methods
GamePadStruct Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The GamePadStruct type exposes the following members.

Methods

 | Name | Description
Public method | ButtonAClicked | If Button-A has been clicked.
Public method | ButtonBackClicked | If the back button has been clicked.
Public method | ButtonBClicked | If Button-B has been clicked.
Public method | ButtonStartClicked | If the start button has been clicked.
Public method | ButtonXClicked | If Button-X has been clicked.
Public method | ButtonYClicked | If Button-Y has been clicked.

See Also

GamePadStruct Class
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


ButtonAClicked Method

GamePadStruct..::..ButtonAClicked Method
GamePadStruct Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
If Button-A has been clicked.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool ButtonAClicked()

Return Value

T/F on if the button has been clicked.

See Also

GamePadStruct Class
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


ButtonBackClicked Method

GamePadStruct..::..ButtonBackClicked Method
GamePadStruct Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
If the back button has been clicked.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool ButtonBackClicked()

Return Value

T/F on if the button has been clicked.

See Also

GamePadStruct Class
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


ButtonBClicked Method

GamePadStruct..::..ButtonBClicked Method
GamePadStruct Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
If Button-B has been clicked.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool ButtonBClicked()

Return Value

T/F on if the button has been clicked.

See Also

GamePadStruct Class
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


ButtonStartClicked Method

GamePadStruct..::..ButtonStartClicked Method
GamePadStruct Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
If the start button has been clicked.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool ButtonStartClicked()

Return Value

T/F on if the button has been clicked.

See Also

GamePadStruct Class
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


ButtonXClicked Method

GamePadStruct..::..ButtonXClicked Method
GamePadStruct Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
If Button-X has been clicked.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool ButtonXClicked()

Return Value

T/F on if the button has been clicked.

See Also

GamePadStruct Class
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


ButtonYClicked Method

GamePadStruct..::..ButtonYClicked Method
GamePadStruct Class See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
If Button-Y has been clicked.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public bool ButtonYClicked()

Return Value

T/F on if the button has been clicked.

See Also

GamePadStruct Class
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


ThumbSticksOnGamePad Structure

ThumbSticksOnGamePad Structure
Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Positions of the left and right thumbSticks on the XBOX 360 controller.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public struct ThumbSticksOnGamePad

See Also

ThumbSticksOnGamePad Members
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


ThumbSticksOnGamePad Members

[image]

XNACS1Lib Documentation
ThumbSticksOnGamePad Members
ThumbSticksOnGamePad Structure Fields See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The ThumbSticksOnGamePad type exposes the following members.

Fields

 | Name | Description
Public field | Left | Position of the left thumbStick (X/Y values between -1 and +1).
Public field | Right | Position of the right thumbStick (X/Y values between -1 and +1).

See Also

ThumbSticksOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


ThumbSticksOnGamePad Fields

[image]

XNACS1Lib Documentation
ThumbSticksOnGamePad Fields
ThumbSticksOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The ThumbSticksOnGamePad type exposes the following members.

Fields

 | Name | Description
Public field | Left | Position of the left thumbStick (X/Y values between -1 and +1).
Public field | Right | Position of the right thumbStick (X/Y values between -1 and +1).

See Also

ThumbSticksOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Left Field

ThumbSticksOnGamePad..::..Left Field
ThumbSticksOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Position of the left thumbStick (X/Y values between -1 and +1).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Vector2 Left

See Also

ThumbSticksOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Right Field

ThumbSticksOnGamePad..::..Right Field
ThumbSticksOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Position of the right thumbStick (X/Y values between -1 and +1).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public Vector2 Right

See Also

ThumbSticksOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


TriggersOnGamePad Structure

TriggersOnGamePad Structure
Members See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Positions of the left and right triggers on the XBOX 360 controller.

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public struct TriggersOnGamePad

See Also

TriggersOnGamePad Members
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


TriggersOnGamePad Members

[image]

XNACS1Lib Documentation
TriggersOnGamePad Members
TriggersOnGamePad Structure Fields See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The TriggersOnGamePad type exposes the following members.

Fields

 | Name | Description
Public field | Left | Position of the left trigger (value between 0 to 1).
Public field | Right | Position of the right trigger (value betwen 0 to 1).

See Also

TriggersOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


TriggersOnGamePad Fields

[image]

XNACS1Lib Documentation
TriggersOnGamePad Fields
TriggersOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011

The TriggersOnGamePad type exposes the following members.

Fields

 | Name | Description
Public field | Left | Position of the left trigger (value between 0 to 1).
Public field | Right | Position of the right trigger (value betwen 0 to 1).

See Also

TriggersOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Left Field

TriggersOnGamePad..::..Left Field
TriggersOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Position of the left trigger (value between 0 to 1).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float Left

See Also

TriggersOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace


Right Field

TriggersOnGamePad..::..Right Field
TriggersOnGamePad Structure See Also Send Feedback
XNACS1Lib: CSS490 Spring 2011
Position of the right trigger (value betwen 0 to 1).

Namespace: XNACS1Lib.XNACS1Lib.GamePadSupport
Assembly: XNACS1Lib (in XNACS1Lib.dll) Version: 1.0.0.0

Syntax

C#
public float Right

See Also

TriggersOnGamePad Structure
XNACS1Lib.XNACS1Lib.GamePadSupport Namespace