
Estimating the Heritability of a 
Quantitative Trait

This tutorial challenges you to design and run experiments to estimate the heritability of a 
quantitative trait  and to predict  how a population will respond to selection. The analytical tools you’ll 
need are described briefly here, and discussed in more detail in Chapter 9 of Evolutionary Analysis.

The organisms in the model population you will study are ladybugs. The trait  you will analyze is 
number of spots. I must make a disclaimer at  the outset: I don’t  know anything about  the genetics of 
spot  number in real ladybugs. For this simulation, I have assumed that spot number can vary from zero 
to fourteen and is under the combined influence of several genes of small effect plus a random 
environmental component.
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The Bugsville application
To complete this tutorial, you will need the software application Bugsville. You can download 

Bugsville from Jon Herron’s website at the following URL:

http://faculty.washington.edu/~herronjc/

Click on Software, then on Bugsville. There are versions of Bugsville for Windows, Mac OS Classic, 
and Mac OS X. Download the appropriate version to your computer and launch it.

The first window you will see is an ad for my book. Click on the Proceed button to dismiss it.

Next  you’ll see a small dialog box asking you to select  a scenario from a popup menu. You can 
choose from among four scenarios:

1. The heritability of spot number is 0.9. 

2. The heritability of spot number is 0.5. 

3. The heritability of spot number is 0.1. 

4. The heritability of spot number is chosen at random, and unknown to the user. 

You may want  to play with scenarios 1 through 3 as you practice the experiments and analyses 
required to estimate the heritability of spot  number. Ultimately, however, your challenge will be to run 
scenario four and accurately estimate an unknown heritability.
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After selecting a scenario, you will see Bugsville’s main window 
(see next  page). On the top are two large boxes, Left Field and Right 
Field. Left  Field is full of ladybugs, represented by red dots. To get a 
better look at them, click on some of the bugs and hold the mouse 
button down (right). The smaller dots are larvae. The larger ones are 
adults.

Click the Run button at lower right. The ladybugs will move 
around. Sometimes when two bugs bump into each other, they mate 
and make larvae (watch closely!). Larvae take 50 days to turn into 
adults. After maturing, adults live another 150 days, then die. Click 
on the Pause button to suspend the simulation.

Note that while the simulation is paused you can move bugs around by pointing at  them, holding 
the mouse button down, and dragging them to a new location. This gives you the ability to design and 
conduct your own experiments. For example:

• You can mate two ladybugs to see what  their offspring look like. Drag two adults to one of the 
empty cages in the bottom half of the Bugsville window. Encourage them to mate by making 
sure they are touching. Run the simulation. Typically, the adults will make one or two offspring 
in short  order. Pause the simulation to separate the offspring from the adults (so that  you know 
who is who). Run the simulation until the babies grow up. Compare the offspring to the adults. 

• You can do selective breeding experiments. From the Left  Field population, pick out the 
ladybugs with the most—or the fewest—spots. Move them to Right Field. Place them near each 
other to encourage them to mate. Run the simulation for an entire generation (200 days), then 
compare the new generation to the original population you started with.
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The two large white boxes are fields 
that will support populations of 100 
ladybugs each.

The red dots represent ladybugs. Large 
dots are adults, small dots are larvae. 
To see what a larva or bug looks like, 
click on one and hold the mouse button 
down. 

The five small white boxes are 
experimental cages that will support 25 
ladybugs each. To move a bug from 
one place to another, click on the bug, 
hold the mouse button down, and drag 
the bug to its new location.  

You can type labels 
here to keep track of 
your experiments.

This button will empty 
the cage of bugs. You 
can get rid of a particular 
bug by simply dragging it 
out of the cage. This button will run the 

simulation. Click on it to see 
the bugs run around and 
mate with each other.



Under the Tools menu you will find two items that will help you analyze your data. Histogram will 
graph the distribution of spot numbers in any of your populations, and calculate the average number of 
spots. Scatterplot will let you enter paired X and Y values, then plot them on a scatterplot.

If you need to reset your simulation, you can do so with the Reset command under the File menu. 
(Note, however, that  if you reset scenario four, Bugsville will pick a new heritability at random. This 
means that you will have to repeat your experiments to estimate the new value).

Your tasks in this tutorial are to:

1. Assess the variation in spot number in the Left Field population. 

2. Estimate the heritability of spot number in the Left Field population. 

3. Set up a selection experiment to select for high or low spot count, and calculate the selection 
differential. 

4. Use the selection differential and your estimate of the heritability to predict  the response to 
selection. 

5. Run your selection experiment, and compare your prediction to the actual response. 

If you have not already done so, use the Reset command under the File menu to reset  your 
simulation with an unknown heritability. You are now ready to begin.
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Assessing the variation in spot number
Take a minute to examine some of the lady bugs in the Left Field population. What is the highest 

spot count you can find? The lowest? What is a typical number of spots?

Now use the Histogram command under the Tools menu to plot a graph showing the distribution of 
spot  number in the population. Note that  the Histogram tool also reports the population average. Sketch 
the histogram in the space provided on the Bugsville Worksheet, and record the average number of 
spots.

Estimating the heritability of spot count
The heritability of a trait  is defined as that fraction of the variation among individuals that is due 

to differences in genes they inherited from their parents. If a trait is heritable, then parents and their 
offspring will resemble each other. You will use the resemblance between parents and offspring to 
estimate the heritability of spot  number. Before proceeding, read about  this technique on pages 343 to 
347 in Evolutionary Analysis.

Set up a mating between a different pair of ladybugs in each of the small empty cages on the lower 
half of the Bugsville window. Before running the simulation count the spots on each parent, and record 
your data in the table provided on the Bugsville Worksheet. Also calculate the average spot number for 
each pair of parents, or midparent  value. Now run the simulation until larvae appear in each cage, then 
pause. Separate the adults from the larvae (you can return the adults to Left Field if you like, or just 
throw them out), then run the simulation again until the larvae grow up and pause again. Record the 
spot counts for the offspring in each family, and calculate the midoffspring value.
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Continue to set  up matings and examine offspring until you have data on at least 15 families. Then 
select  the Scatterplot tool under the Tools menu. Enter your data in the table on the left  side of the 
Scatterplot window. Each family gets its own row. Enter the average spot count for the parents as the X 
value, and the average spot count  for offspring as the Y value. After entering all your data click on the 
graph button. You will get a scatterplot that will show you whether offspring resemble their parents. 
You will also get the best-fit line. The slope of this line is an estimate of the heritability of spot number.

How accurate is your estimate of the heritability? Set up more matings and gather more data until 
you feel your estimate is a good one. Are there particular matings you can set  up to get  the information 
you need more quickly? Before moving on, sketch the scatterplot on the Bugsville Worksheet  and 
record your best estimate of the heritability.

Set up a selection experiment and calculate the selection 
differential

You can check the accuracy of your heritability estimate by doing a selection experiment. Before 
proceeding, read about measuring differences in survival and reproductive success on pages 348 to 350 
in Evolutionary Analysis.

Decide whether you are going to select for high spot counts or low spot counts. Select from the 
Left  Field population individual bugs with high (or low) spot counts and move them to Right  Field. 
Use the histogram to plot the distribution of spot  counts among your selected parents, and to get  their 
mean spot count. Sketch the histogram and record the mean on the Bugsville Worksheet.
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The selection differential is the difference between the average of the selected breeders (the bugs 
you just  moved to Right Field) and the average of the whole parental population (selected breeders plus 
nonbreeders). You recorded the average spot count  for the whole Left  Field population in Question 1. 
Calculate and record the selection differential.

Predict the response to selection
The response to selection  is the difference between average of the selected breeders’ offspring and 

the average of the offspring of all the parents. Before proceeding, read about  how to predict  the 
response to selection on pages 350 to 351 in Evolutionary Analysis.

If you multiply the selection differential by the heritability, it should give you a reasonably accurate 
estimate of the response to selection.

Run your selection experiment and compare your predicted 
response to the actual response

Before proceeding, read about Candy Galen’s selection experiment  on pages 351 to 353 of 
Evolutionary Analysis.

Run your simulation for 200 days. This will give all the parents in your Right  Field population time 
to complete their life spans, and thereby ensure that only their offspring remain. Now use the histogram 
tool to plot  the distribution and determine the average spot count in your Right  Field population. 
Sketch the histogram and record the mean spot count on the Bugsville Worksheet.
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Recall that the response to selection is the difference between the average of the offspring of the 
selected parents and the average of the offspring of all the parents. You don’t know this second value. 
But you can use the mean of your starting Left Field population, from Task #1, as a reasonable 
estimate. In other words, you can calculate the actual response to selection as the difference between 
the average of your present Right Field population (the offspring of the selected parents) and the 
average of the original Left Field population (the entire population before selection).

Compare the actual response to selection to your prediction. How closely do they match?

Learning the Truth
Because Bugsville is a simulation, it  allows you to do something you cannot do in the real world. 

You can ask the application to tell you the Truth about the simulation you are running. Under the Tools 
menu, select Tell the truth. Enter the password Galton. Then click Now tell me. Bugsville will reveal 
the true heritability of spot number in your population.

Did your experiments give you a reasonably accurate estimate? If not, try to figure out  why. Design 
a new experiment that will give you a better estimate. Then run your new experiment and see how well 
it works.
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Write a brief discussion, as might appear at the end of a lab 
report

Summarize your study:

• What did you set out to determine?

• What experiments did you perform?

• What did you learn and on what evidence?

• How well did your data match your predictions?

• How might your study have been better designed?

• What is the broader significance?
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