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Data Import and Editing

This chapter guides you through the first stages of data analysis, data import and data manipulation. We first provide a description of the data and then discuss the following:

Importing Data

Editing Data

Data Types

Handling Missing Values

Formatting Data 

Overview

S-PLUS is an object-oriented system. The main consequence of this is that S-PLUS does not operate directly on data files.  Instead, before any data analysis can begin you must import data from a file, to create an object in S-PLUS’s own database containing a copy of the data. In this way the original data files are never modified, and you are free to manipulate the data objects in S-PLUS at will.

3.1  Importing Data

 S-PLUS 2000 allows you to import data sets from many file types:  

· Text (ASCII) files (*.PRN, *.TXT, *.ASC)

· Formatted ASCII files (*.FSC)

· Microsoft Excel (versions 2.1 through Excel ‘97 .XLS* files)

· Quattro Pro Worksheets (.WQ1)

· Paradox Databases (.DB)

· Lotus Worksheets (.WKS,.WK1,.WK3,.WK4 and.WRK)

· dBase files (.DBF  II, II+, III, IV files)

· FoxPro files (.DBF)

· Systat files (double or single precision .SYS files)

· SigmaPlot  files (.JNB)

· SPSS files (.SAV)

· SAS files (.SD2)

· SAS Transport files (version 6.x. TPT). Some special export options may need to be specified in your SAS program. We suggest using the SAS Xport engine (not PROC CPORT) to read and write these files.

· Microsoft Access files (.MDB)

· Matlab (.MAT)

· SPSS Export files (.POR)

· S-PLUS Transport Files (.SDD)

· STATA files (.DTA Versions 2.0 and higher)

· Gauss (.DAT files - automatically reads the related DHT file)

3.1.1 Example: Excel data

As an illustration, we will import data from the Excel file ftse100data.xls.  This file contains share prices for 95 of the FTSE100 companies, from Feb 14 1997 to Feb 15 1998. It also includes the index itself, and a column of dates.  The first row of the Excel file is column labels.

To import ftse100data.xls from the disk: 

1. From the menu, choose File ► Import Data ► From File.
2. In the field Look In, browse to the directory where the file is located.
3. In the text field for Files of type, use the dropdown list to select an Excel file with extension ".xls".
4. Under the File name, choose ftse100data.xls by highlighting it in the list window.
5. In the text field for Import to Data Set, type the name for the object which will contain the imported data. The default name ftse100data (chosen from the file name) is suitable.
6. Now, click on the Options tab of the dialog box.

7. Leave the Name Col field blank.
This option is used to indicate to S-PLUS that a certain column of the Excel file should be used as the row labels for the data in S-PLUS. By leaving it blank, we use the default row labels.

8. In the Page Number field leave the default value, 1.  If the Excel file contains multiple worksheets, you can use this option to read in data from other worksheets (e.g. 2 for the second worksheet in the workbook).
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Click Open.



Helpful Hint: 

By default, S-PLUS will import the entire data set. To choose certain columns and rows to import or to randomly select a section of data, use the options and filter pages of the Import Data dialog. See the Help files or manuals for more details.

We have just created a data frame object ftse100data containing the data from the first worksheet in the file ftse100data.xls. A data frame is the most common structure used for data analysis in S‑PLUS. 

In a data frame, data are in rows and columns with the rows corresponding to observations and the columns corresponding to variables. 

Different types of data can be stored in the different columns of the same data sheet.  For example, in a single data frame, you might first encounter a column of numbers, then a factor column (discussed later), another column of character strings, etc. The columns in a data frame must all be of the same length.

We will work with data frames in detail in this manual.

3.1.2 Example: Comma-separated files

You can import comma-separated files (for example, Excel .csv files) as ordinary text files, by specifying the delimiter in the Options page explicitly. In this example, we will import the file tb.csv which contains Treasury Bill yields at 3 months, 6 months, 1, 5, 10 and 30 years. The first few lines of the file (if viewed in Notepad) look like this:

date,tb 3mo,tb 6mo,tb 1yr,tb 5yr,tb 10yr,tb 30yr
950103.00,5.78,6.37,6.76,7.88,7.85,7.92
950104.00,5.70,6.29,6.70,7.81,7.84,7.84
950105.00,5.72,6.32,6.72,7.86,,7.88

To import tb.csv from the disk: 

1. From the menu, choose File ► Import Data ► From File.
2. In the field Look In, browse to the directory where the file is located.
3. In the text field for Files of type, use the dropdown list to select All files (*.*). (.csv is not an extension recognised by S-PLUS).
4. Under the File name, choose tb.csv by highlighting it in the list window.
5. Return to the text field for Files of type, and now use the dropdown list to select ASCII Text Files. Although tb.csv is not listed in the files window, it is still listed as the File Name. This is the general method for importing a file whose extension is unrecognised or does not match its file type.
6.  In the text field for Import to Data Set, type the name for the object which will contain the imported data. Enter the name tb.all here.
7. Now, click on the Options tab of the dialog box.

8. Change the field Delimiters to a single comma.
By default, any amount of whitespace or commas are used to separate columns in text files.  For this file, a single comma separates the columns. Leaving the space in the delimiters would cause S-PLUS to think the spaces in the column labels separated columns, which isn’t what we want here.

9. Select the checkbox Separate Delimiters
If this check box is not selected, several delimiters which appear consecutively only add one new column.  In a comma-delimited file, a blank column might look like this:




950105.00,5.72,6.32,6.72,7.86,,7.88

Without this option selected, that line would be interpreted as six columns, instead of seven columns (with the sixth value missing).

10. .Click on Open
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Notes:

1. The dates column has been read in as floating point numbers (double type). We will see how to convert this into dates later in the course.

2. The column labels have changed from names like “tb3 mo” to tb3.mo. This is because the column labels have been converted to conform to the conventions of S object names (more on this later).
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3.1.3 Example: Fixed format files

Next, we will go over a short example of importing a data set that is stored in a fixed format text file. A fixed format file is an ordinary text file in which each variable takes up a set amount of characters on each line.

Example The training disk contains the file FixFormat.fsc, a formatted text file:

12.3BPAmoco34.01
45.6Zeneca 78.09
98.7BHP    56.01
31.2BAT    98.27

1. From the menu, choose File ► Import Data ► From File.
2. In the field Look In, select 3 ½ Floppy (A).
3. In the text field for Files of type, use the dropdown list to select fixed format ASCII files with extension ".fsc".
4. Under the File name:, choose FixFormat.fsc by highlighting it in the list window.
Note that the Import to Data Set field will now say FixFormat
5. Now, click on the Options tab of the dialog box.

6. In the Format String field, type %4f, %7s, %6f 
Note: For each column, you need to specify a percent sign (%) followed by the data type. The "s" denotes a string data type, "f" denotes a float data type, and the asterisk (*) denotes a skipped column. The integer between the percent sign denotes the length of the variables. A carriage return, "\n", counts as one character, so the last field is 6 characters long; 5 for the data and 1 for the end of line.
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Click Open. 

Note: No column labels were supplied in the first line of the file or in theColumn Names field of the dialog, so default column names (V1, V2, V3) have been provided. These can be changed by double-clicking on the column label (more later).

3.2 Other data sources

S-PLUS can also import data directly from databases (e.g. Sybase, Oracle) through ODBC, or from financial data vendors Bloomberg, Fame, and LIM. These features require licences for the data source (and network connections to access them).  As a result they unfortunately cannot be demonstrated live in this course. 

For example, the File ► Import Data ► From Bloomberg dialog looks like this:
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Once this dialog successfully completes, a data frame SPX will be created containing the daily S&P500 lows, highs, opens and closes from 1 Jan 1998 to present.

3.3 S-PLUS transport files

Data can also be read in from S-PLUS transport files (extension .sdd). In addition to the data themselves, S-PLUS transport files can contain information about the data types and formatting.  Transport files may also contain more than one data object in a single file.  For this reason, the name of the object is recorded within the file itself (instead of using the filename).  Therefore changing the filename of a .sdd file will not change the name of the object when it is imported.

Unlike other data formats S-PLUS transport files can be imported directly with File ► Open (without going through the Import Data dialog). If you modify a data set in a data window, you will be given the opportunity to save the data set to a file in S-PLUS transport file format (“Save changes to object in a file?”)

S-PLUS transport files can be created from the command line with the data.dump() function.

3.4 Notes on importing data

1. If the data file does not correspond to the format expected by S-PLUS (for example, not every row has the same number of data entries), then either the data will be coerced into a suitable format (and a warning will appear in the Messages window), or the import will fail (and the import dialog will remain open).

2. For most file types other than Formatted ASCII, S-PLUS will try to guess the type of each column of data (numeric or character).  Character columns are usually read in as factor objects (more on factors later).  This can sometimes be confusing, as factor objects have special properties (such as sorting data alphabetically in plots).  To disable this feature, set Import Text as Factors to Never in the Options tab of the dialog.

3. Similarly, a column which contains mostly numeric data but which has letters or other non-numeric characters anywhere in the column will be read in as a factor variable.  Common culprits here are missing data codes like “.” or “#N/A”.  Such columns will have to be converted to numeric after import.

4. There is no in-built limit to the size of data file you can import.  There are however practical limits, primarily that the data object must be able to be contained in virtual memory (physical RAM plus swap).

5. It’s possible to export data to all the file types you can import from with File ► Export Data ► To File.

6. Importing can also be done from command line (and script files) with the import.data function. A common practice is to import a file with the menus, and then copy the import.data call from the History Log.  There is also a function read.table which can be used to read ASCII and Formatted ASCII files.

3.5  Undoing Mistakes on Data

Mistakes do happen during data manipulation steps. In S‑PLUS you can undo your most recent action or you can restore your data set to its original state as it existed at the beginning of your S‑PLUS session.

To undo the most recent action click the Undo button on the Standard toolbar, [image: image5.bmp], or choose Edit ► Undo from the main menu.

To restore a data set to its initial state:

1. Click the Restore Data Objects button on the Standard toolbar, [image: image6.bmp], or choose Edit ► Restore Data Objects from the main menu.

2. Select your data set from the list of objects displayed in the Restore Data Objects dialog.

3. Click the Restore to Initial State radio button.

4. Click OK.
 Viewing Data

There are two ways to view and manipulate data in the GUI: via a data window or via the Object Explorer. A data window contains the data set in a format that looks like a spreadsheet. We have already seen an example of this when we imported the ftse100data.xls file to create the object ftse100data.

3.5.1 The Data Window

When we imported the ftse100data.xls file into S‑PLUS, two things happened. First, the data was converted into an S‑PLUS data object and saved to disk (in S-PLUS’s internal database). Then, the data was displayed in a data window. Now that the data is stored in an S‑PLUS format, we can view it in a data window any time we want. 

Example Open up the ftse100data object in a data window.

1. Close the ftse100data window, if it is already open.

2. Select Data ► Select Data from the main menu.

3. In the Name field, select ftse100data .

4. Click the OK button.

There are some important differences between the Data window and spreadsheets.
In understanding the difference between the Data window and spreadsheets, it is useful to understand S-PLUS objects and files: 

The most common data objects in S‑PLUS are column-oriented, that is, columns are the basic unit. Data objects such as data frames can be considered to be collections of columns. 

Functional computations in S-PLUS are vectorized, that is, computations are inherently performed for each element of the vector or column. 

Spreadsheets are different from S‑PLUS data sheets in many ways: 

Spreadsheets are tabular in nature, where cells are the basic unit. 

Formulas, similar to S-PLUS functions in many respects, operate on cells or collections of cells (columns or rows). In spreadsheets a formula can be applied to a column of cells, but you must specifically request this operation to be done.  In spreadsheets, formulas are usually “live links” between cells, in the sense that when the original cell changes, the linked cell updates accordingly. In S-PLUS data objects, no such linking occurs.

 The Data window was formatted to comply with the column-orientation of data sheets in the S-PLUS engine. 

Because data are column-oriented, each column can contain a different data type. By default, numeric data are read into S‑PLUS as double precision and character data are converted into factors.

3.5.2 Accessing Data using the Object Explorer

With the Object Explorer, we cannot view the actual data entries in a data sheet, but we can perform certain operations on variables (for example, edit variable names). Also, if the set of variables in a data set is large, then it is often more convenient to use the Object Explorer than a data window to see the entire list of variables at once.

Note that if you select (highlight) a data set in the left pane of the Object Explorer, all of its variables will appear in the right pane.
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3.6  Selecting Data in a Data Window

3.6.1 Selecting Rows

In S-PLUS a row contains information for a single observation or record.

To select rows that are contiguous (next to each other):

1. Click and hold the left mouse button on the number of the first row that you are choosing.

2. Drag the mouse across the row numbers you are selecting. All rows you have dragged the mouse across should be highlighted.





-OR-

1. Click on the first row number for the rows you want to select.

2. Shift-click on the last row number for the rows you want to select. Everything between the first row you selected and the last row you selected should be highlighted.

To select discontiguous rows:

1. Click on the number for the first row you want to select.

2. CTRL-click the remaining row numbers you are selecting. 

When rows are selected, the plotting buttons and statistics dialogs will generally work with the selected subset of the data.

3.6.2 Selecting Column Variables

To select variables (columns) that are contiguous (next to each other) in either the Object Explorer or a data window:

1. Click and hold the left mouse button on the first variable (column) name (or number) that you are choosing.

2. Drag the mouse across the variable names (or numbers) you are selecting. All of the variables that you have dragged the mouse across should be highlighted.





-OR-

1. Click on the first variable name (or number) of the variables you want to select.

2. Shift-click on the last variable name (or number) of the variable you want to select. Everything between the first row you selected and the last row you selected should be highlighted.

To select discontiguous variables

1. Click the first variable (column) you want to select.

2. CTRL-click the remaining variable (column) you are selecting. 

Example  In a data window, CTRL-click dates, ZENECA and HSBC.HOLDINGS (columns 1,5, 6) in that order.  Only those columns should be highlighted.

Example  In the right pane of the Object Explorer, CTRL-click on dates, NATIONAL.GRID and ORANGE. Only those three variables should be highlighted.  The corresponding column in the data window will also be highlighted.

When columns are selected, only these variables will be used for the plot or analysis.  The order in which columns are selected is usually important.  For example, the first column is the x axis for a plot.

3.6.3 Selecting Blocks of Data

To select blocks of data (a subset of a selection of rows), select the rows first, and then Ctrl-click on the columns.

3.7 Data Types

There are 8 different basic data types to choose from in S‑PLUS. They are:

· character

character strings

· complex
complex numbers (each value uses 16 bytes of memory)

· dates



dates

· double
numeric values stored in double precision, numbers with up to 15 significant digits (each value uses 8 bytes of memory)

· factor



factor, or categorical, values

· integer
integers between the values of  ‑2147483648 and 2147483647 (each value uses 4 bytes of memory)

· logical
logical values (T/F) (each value uses 4 bytes of memory)

· single
numeric values stored in single precision, numbers with up to 7 significant digits (each value uses 4 bytes of memory)

In addition, the symbol NA is used to denote missing values.

We will discuss each of these data types in detail in this section.

Tip: You can check the data type of a column by hovering the cursor above the column header.  Data types are also listed in the Object Explorer in the Data Class field.
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3.7.1 Double, Single, and Integer

The double, single, and integer data types are used to describe numbers. Double is by far the most common storage mode for numerical data since it produces higher accuracy in statistical modeling than either single or integer.  This is the default data type for imported numeric data.

Example  In ftse100data all columns except dates have a data type of double. 

You can conduct algebraic computations, trigonometric transformations, etc. with numeric variables.

3.7.2 Factor

Categorical data are common in data analysis.  A categorical data variable is one where the values of the variable are taken from a relatively small set of pre-defined values, and no other value is allowed.  Examples:

· Currency: GBP, DEM, FRF, USD, JPY

· Sector: manufacture, telecoms, insurance, banking, IT

· Type: equity, bond, option, swap

S-PLUS uses a special data type for categorical data: factor variables. A factor is stored as integers (an integer vector as long as the variable) with corresponding character string labels (a character variable as long as the number of unique labels). These labeled integers correspond to the possible categories in the factor variable.

Factor variables are generally used to indicate partitions of the data into subsets.  Unlike character vectors (see below), factors have special meanings when used in plotting and analysis functions.  For example, the order of the labels (usually alphabetical) has particular consequences.

Notes on factors:

1. When imported into S‑PLUS, character data are converted into factors. Most times this is desirable. However, when it is not desirable, you can convert the factor variable back to a character variable using the menu Data ► Change Data Type action, or by right-clicking on the relevant column and selecting Change Data Type from the menu.

2. Converting a factor column into numeric (e.g. double) converts it into the codes used to represent the factor (1 for the first label, 2 for the second, etc.)  This is particularly relevant if a numeric column has been read in as a factor by mistake (perhaps because it had #N/A in the column somewhere).  The solution is to first convert it to character, and then convert it to numeric (when the “#N/A” will be converted to the S missing value code NA).

3. A column of non-numeric data where every value is different (or nearly so) should usually be stored as a character vector rather than a factor (as no benefit is gained by storing the values as codes, and the column does not define a useful partition of the data).

Logical

Logical values in S‑PLUS are T  (for true) and F (for false). There are no quotes around these values. 

You can create logical variables by typing the T’s and F’s in the cells of a data window, or, you can use S-PLUS logical operators to create the new variable.

Table 4.2  Logical Operators in S-PLUS

Operator
Description
Example

==
Equals
country == "UK"

!=
Not Equals
country != "UK"

<
Less Than
PRICE < 400

<=
Less Than or Equal
PRICE <= 400

>
Greater Than
splits > 5

>=
Greater Than or Equal
splits >= 5

&
Elementwise And
splits==1 & PRICE < 400

|
Elementwise Or
PRICE < 100 | PRICE > 400

Examples

ZENECA > 3500

returns <= quantile(returns, 0.01)

date >= dates("5/30/98")

country == "UK" & sector == "telecoms"

3.7.3 Character

Character data, or text, are letters of the alphabet plus other symbols and numbers.  

Character data are used for labeling observations in graphs and subsetting  data for models. If numbers are present, they will act like character strings in that you cannot perform numeric computations using these cells. Also, function arguments often require character strings. 

When entering character strings in the data window, there is no need to use quotes. However, creating character strings when using S‑PLUS expressions requires that you use quotes around each character string. You can use either the double-quote (") or single-quote (‘) to create character strings. Just be sure that they are balanced, i.e. if you use a single quote in front of a character string, you have to end the character string with a single-quote.

3.7.4 Dates

Dates in S-PLUS are represented using the dates data type.  Dates can be imported automatically from some data files which support them (for example, Microsoft Excel).  The format of the dates in the data window is controlled by Microsoft Windows under "Control Panel | Regional Settings". 

Character columns can be converted into dates only if they are in the American format, e.g. 5/25/99 for May 25, 1999.  There are very flexible functions for converting dates from the command line (discussed later).

Numeric columns may be converted to dates, and will be interpreted as the number of days since 1 Jan 1960.  Converting a column of dates to numeric yields the number of days since 1 Jan 1960.  Excel uses the same convention; you can force a column of dates from Excel to be read in as numbers with the Dates as Doubles option in the import dialog. 

When importing data from a file (or entering dates direct into a data window), years 01-29 are interpreted as year 20xx.  There are options to control this century conversion.

3.7.5 Complex Number

Complex numbers have the form A+Bi, where i =
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We will not be using complex numbers in this course.

3.7.6  Missing Values

The missing value code in S‑PLUS is NA. There are no quotes around the NA.

When you import data, the missing value symbol of the file you are importing will be automatically converted to NA.
 Formatting Data

Often, data are not organized in the format you need for data analysis and graphing. S‑PLUS provides many options for manipulating your data.

In this section we will discuss how to:

· Edit column names.

· Add column descriptions.

· Change numeric display.

· Change numeric precision.

3.7.7 Variable Names

Variable (column) names are used to refer to data for graphing or data manipulations. The variable naming conventions in S‑PLUS are: 

Variable names must start with a letter and may contain any combination of letters, numbers, and periods ("."). 

Variable names cannot be used more than once within a data set.

Names in S-PLUS are case sensitive. Price is different from price. 

S-PLUS function names and other reserved words should not be used as variable names.

Spaces or underscores (_) cannot be used in variable names; use a period (.) to separate words. 

Variable names are not limited in length.
Example  We will edit some of the column names in the tb.all data window.

Double-click on the column name tb.3mo (column 2) or select column 2 and press F9.

Change the name to tbill3m.

2. Click once outside of the cell to accept the change..

Example We will now edit some variable names using the Object Explorer.

1. In the left pane of the Object Explorer, highlight (select) tb.all.

2. In the right pane, right-click on tb.6mo and select Properties.

3. In the dialog box that appears, change the Name field to tbill6m
4. Click OK.
Variable Descriptions

Because column names must conform to the S object name conventions, and because they will need to by typed often when programming, we recommend keeping them short but mnemonic.

Each variable can be given a more verbose description than the column name. A column description can contain up to 75 characters and can contain any combination of letters, numbers, symbols, or spaces.

This variable description will be displayed as a Data Tip when you pause the mouse cursor over the variable name in the column header.  It will also be used as the axis label for GUI plots.

Example We will edit some of the column descriptions in the tb.all data window.

1. Double-click on the column number 2 that resides in the header for the tbill3m column or right-click in the column and Properties from the context menu.

2. In the dialog box that appears, change the Description field to
3 month treasury bill yields.
3. Repeat for the remaining columns.

Numeric Variable Formats

There are a variety of ways in which double and single precision data types can be represented in a data window. These formats are mixed, number, decimal, scientific, currency, financial, date, Date&Time, Time, Elapsed_H:M:S.

The Mixed format a combination of Decimal and Scientific formats in which any values outside of the column Precision are given in Scientific notation.

The following formats are specified in Microsoft Windows under "Control Panel | Regional Settings": Number, Currency, Financial, Date, Date&Time, and Time.

The date format is automatically set for date data imported with the Dates as Doubles option set.  This is why such columns still appear as dates even though the column type is double.

3.7.8 Numeric Variable Display Precision

You can change the precision that is displayed in double and single precision columns. This only affects the way numbers are displayed, and has no effect on internal computations, which always use the maximum available precision.
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