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Tutorial 4 Overview

This tutorial changes the focus from building spreadsheet models to using and
analyzing them. You will learn how to use several very useful (and powerful)
analysis aids that are available in Excel. When you are done, you should
understand and be able to perform both goal seeking and sensitivity analysis.

You will learn to create and define names for cells, use the Goal Seek…
command, and use the Scenario Manager.

The Spreadsheet

For this tutorial you will use the spreadsheet that was completed during Tutorial
2 (see figure 4-1).

Figure 4-1
Spreadsheet model
from Tutorial 2 to be
used for this tutorial.
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Estimated Model Parameter Values
Purchase Cost 350,000$ 
Life (years) 8
Resale Value 30,000$   
Annual Revenues 225,000$ 
Annual Expenses 125,000$ 
Tax Rate 33.0%
NPV Discount Factor 15.0%

Cash Flow Model

Year Revenues Expenses Depreciation Taxes
Additional 
Revenue Cash Flow

1 225,000$ 125,000$ 77,778$       7,333$   -$        92,667$      
2 225,000$ 125,000$ 68,056$       10,542$ -$        89,458$      
3 225,000$ 125,000$ 58,333$       13,750$ -$        86,250$      
4 225,000$ 125,000$ 48,611$       16,958$ -$        83,042$      
5 225,000$ 125,000$ 38,889$       20,167$ -$        79,833$      
6 225,000$ 125,000$ 29,167$       23,375$ -$        76,625$      
7 225,000$ 125,000$ 19,444$       26,583$ -$        73,417$      
8 225,000$ 125,000$ 9,722$         29,792$ 30,000$  100,208$    

Net Present Value 35,590$  

Create Copies of the Spreadsheet

You will need several copies of the spreadsheet from Tutorial 2. One way to do
this is to use Excel’s Save As command.

üüüü To make copies of a spreadsheet file.

1. Start Excel and open the spreadsheet from Tutorial 2.

2. Choose the Save As… command from the File menu.

3. Name the file with a name different than the original file.

4. Repeat the Save As… command two more times giving each copy a
new, unique name.
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Goal Seek
You have already used Excel to perform “What if” analyses. In a “what if”
analysis, you change the value of an independent variable and assess the impact
of this change on the model. For example, with the spreadsheet in figure 4-1, you
might ask: “What if the tax rate is 28%?” By simply changing this value on the
spreadsheet, you can see the impact on the cash flows as well as the net present
value.

A “Goal Seek” is just the opposite. You specify a value (a goal or target) for a
dependent variable, and then ask, “how can this goal be met?” For example, you
might set the goal for the net present value to be zero. This value is useful
because when NPV is zero, the return on the project is exactly equal to the NPV
discount factor. For example, you might ask: “What would I pay for this asset in
order to achieve a NPV of zero?”

To answer a question like this, you could start entering new values for the
purchase cost. After observing the change in NPV, you could continue this
process until NPV was sufficiently close to zero. However, while this “brute
force” approach would eventually get you close to the answer, there is a simpler
way.

Assume that you want to answer the question: “What purchase price for this
asset would achieve a target NPV of zero?”

üüüü To perform a Goal Seek.

1. Open one of the copies of the spreadsheet.

2. Activate cell G23 (the NPV value that you will target at zero).

3. Choose the Goal Seek… command from the Tools menu.

You will be presented with the Goal Seek dialog box as shown in figure 4-2.

Figure 4-2
The Goal Seek dialog
box.

Since you started this operation with cell G23 active, its reference is
automatically placed in the “Set cell” box.

4. Click in the “To value” box and enter the constant 0.

Note: This box can only contain constants.

5. Click in the “By changing cell” box and either enter B4 or click on cell
B4.
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The Goal Seek dialog box should now look like figure 4-3.

Figure 4-3
The completed Goal
Seek.

This dialog box can be interpreted as saying: “Set cell G23 (NPV) to a value
of 0 by changing cell B4 (Purchase Cost)”.

6. Click on OK.

After a brief delay, the dialog box in figure 4-4 will appear. Note the Current
value is formatted and the dash is used to indicate zero.

Figure 4-4
The completed Goal
Seek.

The system found an answer! If you click on OK, the dialog box will be closed
and the new purchase cost will be left on the spreadsheet. If you click on
Cancel, then the purchase cost will be set back to its original value.

7. Click on OK.

Notice that a purchase cost of $395,318 produces a NPV of zero. This means
that at this purchase cost, the return on the investment is exactly 15% (the
NPV Discount Factor used to compute the NPV).

8. To restore the purchase cost to its original value, choose the Undo
Goal Seek command from the Edit menu.

Now try the goal seek on your own. Use the previous procedure to determine
what NPV Discount Factor produces a NPV of zero. If you do it correctly, your
answer will be 18.1%. This means that, given the original values of the
assumptions, the investment will return 18.1%.

As you can see, the Goal Seek operation is a very powerful and useful feature of
Excel.
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Naming Cells

It is possible to assign a name to a cell or range of cells. After doing so, the cell
name can be used in place of the cell address. For example, look at the
spreadsheet in figure 4-5.

Figure 4-5
This spreadsheet has
given cell B2 the
name “Rate”.
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Base value 1,000.00

Growth rate 5%

Projections at end of:

Year 1 Year 2

1,050.00 1,102.50

For this spreadsheet, the name “Rate” is defined for cell B2. The resulting
formulas in cells B6 and C6 are shown in figure 4-6.

Figure 4-6
The cell name is used
in the formulas in cells
B6 and C6.
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Base value 1,000.00

Growth rate 5%

Projections at end of:

Year 1 Year 2

 =B1*(1+Rate)  =B6*(1+Rate)

This feature is designed to make the spreadsheet easier to read. The only
drawback is the fact that someone reading the spreadsheet cannot tell from the
formula alone what cell is being referenced by the name.

However, despite this drawback, there are some places in Excel where names are
very useful.

üüüü To define cell names.

1. Close the current spreadsheet “Lab2gs”.

2. Open the spreadsheet named “Lab2fs”.

3. Activate cells A4 through B10 as shown in figure 4-7.
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Figure 4-7
The text in column A
will be used to give
names to the
constants in column
B.

Notice that each constant in column B has identifying text on its left in
column A.

4. Choose the Name command from the Insert menu and select the
Create… subcommand.

The dialog box in figure 4-8 shows that names will be created using the text
in the left column.

Figure 4-8
The Create Names
dialog box and its
options.

5. Click OK.

You have now defined names for the seven parameters of the problem. You can
use these names in formulas instead of cell references. You can also use the
Name box on the formula bar to locate parameters in the spreadsheet.

üüüü To see defined names.

uu Click on cell B4 and look at the name in the Name box on the far left of
the formula bar.

uu Click on the pull-down menu arrow of the Name box (see figure 4-9).
Click on any name and that cell will become the active cell.
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Figure 4-9
The Name box pull-
down menu.

üüüü To edit the defined names.

1. Choose the Name command from the Insert menu and select the
Define… subcommand.

2. Click on any of the names in the “Names in Workbook:” box.

Figure 4-10 shows the name “Annual_Revenues” and the fact that it is
defined as cell B7.

Figure 4-10
From the Define
Name dialog box, you
can add, delete, or
edit cell names.

In defining the names, Excel replaces blanks with an underscore and omits
special characters like the parentheses.

You can edit a name in the “Names in Workbook:” box or edit the cell
reference in the “Refers to:” box if you like. In addition, you can use the
Delete button to delete a definition.

3. Click on the Close button.
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The text and corresponding constants in the previous example were in adjacent
cells. However, the NPV value in cell G23 does not have text directly adjacent to
it.

üüüü To name a cell without adjacent text.

1. Select cell G23.

2. Choose the Name command from the Insert menu and select the
Define… subcommand.

As figure 4-11 shows, you can enter a name into the “Names in Workbook:”
box that will refer to cell G23.

Figure 4-11
Preparing to define a
name for cell G23.

3. Enter the name “NPV”.

4. Click on the Add button.

Notice that NPV is added to the list of names on the left.

5. Click on OK.

Scenarios

Excel defines a scenario as a group of input values saved with a name. Scenarios
can be used to try different possible conditions that might occur in the problem
domain being analyzed.

Consider the cash flow analysis spreadsheet that you are working on. Assume
that you do not know the exact values of the parameters, but you have some idea
of possible variations within them.

Consider the table in figure 4-12.
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Figure 4-12
Three different
scenarios.

Parameter Worst Case Best Case Average Case

Annual Revenues $175,000 $300,000 $225,000

Annual Expenses $145,000 $110,000 $125,000

Each case is considered a different scenario. What you want to do is to try each
scenario and see what impact it has on the net present value.
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The Scenario Manager

You could use the original spreadsheet and enter a pair of values, record the
NPV, return them to their original values, and repeat the process for another
pair. However, Excel has a feature called the Scenario Manager that makes this
process much easier.

üüüü To use the Scenario Manager to enter scenarios.

1. Using the spreadsheet with the named cells (that should still be open),
activate cells B7 and B8 (the Annual Revenues and Expenses
parameters).

2. Choose the Scenarios… command from the Tools menu.

This may take a few moments as Excel finds the appropriate code and loads
it into RAM.

A dialog box like the one shown in figure 4-13 will be displayed.

Figure 4-13
The initial Scenario
Manager dialog box.

3. Click on the Add button. The Add Scenario dialog box will be
displayed as in figure 4-14.
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Figure 4-14
The Add Scenario
dialog box.

Since you already selected cells B7 and B8, they are shown in the “Changing
Cells” box. This means that the values in these two cells will be changing in
this scenario.

4. Enter “Average Case” into the “Scenario name:” box.

5. Click on the OK button.

You will next be presented with a dialog box that asks you to enter values for
the “changing cells” that relate to the scenario you are working on (the
average case scenario here).

Figure 4-15
The Scenario Values
dialog box used to
enter parameter
values for the specific
scenario.

Since the values that already exist on the spreadsheet represent the average
case scenario, you can just leave those values as they initially appear in the
dialog box.

6. Click on the Add button.

You want to add two more scenarios so clicking on Add is the appropriate
action. Another Add Scenario dialog box will be displayed.

7. Enter “Worse Case” in the “Scenario Name:” box.
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8. Click on OK.

9. In the Scenario Values dialog box, enter the values from the table in
figure 4-12 for the Worse Case scenario.

Figure 4-16
The “Worst Case”
scenario values.

10. Click on the Add button.

11. Enter “Best Case” in the “Scenario Name:” box.

12. Click on OK.

13. In the Scenario Values dialog box, enter the values from the table in
figure 4-12 for the Best Case scenario.

Figure 4-17
The “Best Case”
scenario values.

14. Since you do not want to add additional scenarios, click on OK.

You are now back to the Scenario Manager dialog box. You can elect several
options at this time (see figure 4-18).
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Figure 4-18
The Scenario Manager
dialog box with some
scenarios defined.

You can show a specific scenario on the spreadsheet by clicking on the Show
button. You can use the Add, Delete, and Edit buttons to modify scenarios.
The Summary button produces a summary report.

We will try out two of these features next.

üüüü To show a specific scenario.

uu With the Scenario Manager open, click on a specific scenario (Average
Case, Worst Case, or Best Case), and then click on Show.

The spreadsheet will be updated with the parameter values for the selected
scenario and the resulting NPV will be calculated. You may have to make
some columns wider to see the results.

Scenario Summaries

Excel provides a means of documenting the result of each scenario in summary
report form. You will find this very useful.

üüüü To produce a scenario summary.

1. With the Scenario Manager open, click on the Summary button.

The Scenario Summary dialog box (see figure 4-19 on the next page) asks
you to specify a results variable to be printed in the summary report. Since
you are interested in the impact of each scenario on NPV, you want to
specify cell G23 (or the name “NPV”) here.
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Figure 4-19
Use this dialog box to
specify a dependent
variable to be
included in the
scenario summary.

2. Click on OK.

After a brief delay, Excel creates a new spreadsheet (named Scenario
Summary) that contains a summary report and adds it to your workbook. A
portion of this report is shown in figure 4-20.

Figure 4-20
The scenario report as
a new tabbed
spreadsheet in your
workbook.

Ignore the symbols at the left and top margin for a moment, but notice that
the cell names (as defined earlier) are shown in the report instead of the
actual cell addresses. This is extremely useful and why you gave the
parameters names earlier.

The symbols on the left and top margin are used to expand and contract
detail. Notice that row 4 of the spreadsheet is not shown. If you click on the
“+” by row 3, it will cause the row to be displayed. The plus sign expands the
outline and the minus sign collapses the outline.

3. Choose the Save command from the File menu.

Your workbook will be saved. This workbook will include both the original
spreadsheet and the Scenario Summary spreadsheet. It will also include the
scenario you defined earlier.
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Scenario Manager Usage Summary

The following summarizes the steps involved to create scenarios using the
Scenario Manager tool.

o Be sure that the cells you are going to use have names (both the
changing cells and the result cell).

o Choose the Scenarios… command from the Tools menu.

o Click on Add in the Scenario Manager dialog box.

o Use the Add Scenario and Scenario Value dialog boxes to enter your
scenarios.

o When done adding scenarios, click on the OK button on the last Scenario
Values dialog box.

o Use the Scenario Manager dialog to show scenarios, edit scenarios, or
produce a summary report.

Sensitivity Analysis

Sensitivity analysis is a systematic procedure used to determine which of the
parameters are affecting the decision variable(s) the most. For example, in our
cash flow model, the NPV decision variable is determined by the values of the
purchase cost, life, resale value, etc. Sensitivity analysis helps us understand
which of these parameters impacts NPV the most. The outcome of a sensitivity
analysis indicates areas where additional resources might be used to obtain
better estimates.

Excel does not have a sensitivity analysis feature, but one can easily use the
Scenario Manager to carry out the analysis. The basic strategy involves changing
each appropriate parameter by the same percentage amount and seeing how
much the NPV changes. Since each parameter will be changed by the same
percentage amount, we will be looking for the ones with the greatest impact on
NPV.

Spreadsheet Modifications

We first need to make some minor additions to the spreadsheet used earlier.

üüüü To prepare the spreadsheet for sensitivity analysis.

1. Close the current spreadsheet.

2. Open one of the copies of the spreadsheet created at the beginning of
the tutorial.

3. Using the instructions beginning on page 4-4, enter the cell names for
cells B4 through B10 and cell G23 exactly as you did before.

4. In cell A11, enter the text “Sensitivity %”.
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5. In cell B11 enter the constant 10%.

6. In cell D3, enter the text “New Values”.

For each parameter (except Life and NPV Discount Factor), you will now
enter new values that are 10% larger or smaller than the original values. The
direction of change (larger/smaller) will be selected so that all changes cause
NPV to increase.

7. Activate cell D4 and enter the formula:  =B4*(1-B$11).

This formula reduces the purchase price by 10%, which causes the NPV to
increase.

8. Copy the formula in cell D4 and paste it into cells D8 and D9.

9. Activate cell D6 and enter the formula:  =B6*(1+B$11).

This formula increases the resale value that causes the NPV to increase.

10. Extend the formula from cell D6 to cell D7.

When you are done, the new definitions in column D should look like those
in figure 4-21 (although the formulas will not be displayed).

Figure 4-21
Spreadsheet
modifications to
define revised
parameter values.
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A B C D

Estimated Model Parameter Values New Values
Purchase Cost 350,000$  =B4*(1-B$11)
Life (years) 8
Resale Value 30,000$    =B6 * (1+B$11)
Annual Revenues 225,000$  =B7 * (1+B$11)
Annual Expenses 125,000$  =B8 * (1-B$11)
Tax Rate 33.0%  =B9 * (1-B$11)
NPV Discount Factor 15.0%
Sensitivity % 10%

11. Select cells B4 through B9 and choose Copy from the Edit menu.

12. Select cells D4 through D9 and choose Paste Special… from the Edit
menu.

13. Click on the Formats option in the Paste section of the Paste Special
dialog box as shown in figure 4-22.
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Figure 4-22
Selecting Formats to
be pasted on the
range of cells.

Your spreadsheet should now look like that shown in figure 4-23.

Figure 4-23
The new values of the
five parameters to be
used in the sensitivity
analysis.
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A B C D

Estimated Model Parameter Values New Values
Purchase Cost 350,000$ 315,000$     
Life (years) 8
Resale Value 30,000$   33,000$       
Annual Revenues 225,000$ 247,500$     
Annual Expenses 125,000$ 112,500$     
Tax Rate 33.0% 29.7%
NPV Discount Factor 15.0%
Sensitivity % 10%

14. Save your spreadsheet.

Using the Scenario Manager in Sensitivity Analysis

You now want to create five different scenarios. For each of the five scenarios,
you will change only one of the five parameters under study (purchase cost,
resale value, annual revenues, annual expenses, and tax rate). Thus by
comparing scenarios, you will be able to compare the impact on NPV of a 10%
change in each parameter and also compare that against the base NPV value.

You should review the Scenario Manager summary on page 4-13. You have
already named the cells so now you need to go to the Scenario Manager and add
a series of five scenarios as described above. The following steps guide you
through this process. Since the cells that you be changing are not contiguous,
there are a couple of “tricks” that you will need to employ to make things work.
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üüüü To set up the Scenario Manager.

1. Choose the Scenarios… command from the Tools menu.

2. Click on the Add button to start your first scenario (the Purchase Cost
scenario).

3. In the Add Scenario dialog box, enter “Purchase Cost Sensitivity” in
the Scenario Name box (see figure 4-24).

Figure 4-24
Creating the scenario
that uses the new
purchase cost.

4. Double-click on the “Changing cells:” box and press DELETE to clear it.

5. As the instructions under the “Changing cells:” box explain, hold
down the control (CTRL) key and click on cells B4, B6, B7, B8, and B9.

6. Click on the OK button.

7. In the Scenario Values dialog box, enter the new value of 315000 in the
Purchase_Cost box (see figure 4-25).

Figure 4-25
Changing the value of
Purchase_Cost in the
first box of the
Scenario Values dialog
box to the new value
(315000).

8. Click the Add button.
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You now need to repeat steps 7 and 8 for the remaining four parameters (Resale
Value, Annual Revenues, Annual Expenses, and Tax Rate). For each of these new
scenarios, change the value of the appropriate parameter in the Scenario Values
dialog box using the new value computed and displayed in column D of your
spreadsheet

After entering the new value for the final parameter (Tax Rate) in the Scenario
Values dialog box, you can click on OK instead of Add to go back to the Scenario
Manager dialog box. If you click on Add by mistake, then click on Cancel in the
Add Scenario dialog box.

Working With the Summary

You want to create a summary spreadsheet just like you did for the earlier
scenario analysis. However, you need to modify the summary spreadsheet so
that it will be more useful.

üüüü To create the summary spreadsheet.

1. With the Scenario Manager dialog box open, click on the Summary…
button.

2. Set the “Result Cell:” box to G23.

3. Be sure that the Report Type is set to “Scenario Summary”.

4. Click on OK.

5. Save the spreadsheet.

A new “Scenario Summary” spreadsheet should be added to your workbook. This
spreadsheet shows all the different scenarios and the NPV generated from each
of them. However, the spreadsheet can be improved with a little formatting and
adding an additional row to help summarize the results.

üüüü To modify the scenario summary.

1. Make column A very narrow.

2. The text in row 3 (the scenario names) is too long making the
spreadsheet unnecessarily wide. Highlight D3 through I3 and then use
the Cells… command from the Format menu to allow the text to wrap
in the cell (see the Alignment tab).

3. Increase the height of row 3 by placing the cursor on the boundary
between row 3 and 4 and clicking and dragging the boundary down.

4. Decrease the widths of columns D through I to as narrow as possible
while still being able to read the headings.

5. Change the alignment in D3 through I3 to be centered.

These modifications make the spreadsheet easier to read because more of the
results can be seen on the screen at one time.
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Next we want to add a new row that computes the difference between the
Current Values NPV and the other scenario NPV values.

üüüü To compute the NPV differences.

1. Click on the 13 in the row heading for row 13. This should select the
entire row.

2. Choose Rows from the Insert menu.

An empty row should be added and labeled as row 13.

3. In cell C13, enter the text “NPV Difference”.

4. In cell E13, enter the formula:  =E12-$D12.

5. Extend the formula from cell E13 across through cell I13.

The result is a value that can be used to see how much the change in the
parameter impacted the NPV (see figure 4-26).

Figure 4-26
The NPV Difference
values show which
parameters produce
the greatest change in
NPV.

Scenario Summary

Current 
Values:

Purchase 
Cost 

Sensitivity

Resale 
Value 

Sensitivity

Annual 
Revenues 
Sensitivity

Annual 
Expenses 
Sensitivity

Tax Rate 
Sensitivity

Changing Cells:
Purchase_Cost 350,000$ 315,000$   350,000$  350,000$ 350,000$  350,000$  
Resale_Value 30,000$   30,000$     33,000$    30,000$   30,000$    30,000$    
Annual_Revenues 225,000$ 225,000$   225,000$  247,500$ 225,000$  225,000$  
Annual_Expenses 125,000$ 125,000$   125,000$  125,000$ 112,500$  125,000$  
Tax_Rate 33.0% 33.0% 33.0% 33.0% 33.0% 29.7%

Result Cells:
NPV 35,590$   63,077$     36,571$    103,236$ 73,171$    42,885$    
NPV Difference 27,487$     981$         67,646$   37,581$    7,295$      

Notes:  Current Values column represents values of changing cells at
time Scenario Summary Report was created.  Changing cells for each
scenario are highlighted in gray.

6. Save the spreadsheet.


